myatsina added a comment.
Vitaly,
Thanks for fixing the test!
Test was fixed by in
https://reviews.llvm.org/rL290621: [asan] Fix test broken by r290540
Review:
https://reviews.llvm.org/D28128
Repository:
rL LLVM
https://reviews.llvm.org/D15075
___
ioeric added inline comments.
Comment at: lib/Format/Format.cpp:1890
}
- FormatStyle Style = getLLVMStyle();
- Style.Language = getLanguageByFileName(FileName);
+ FormatStyle::LanguageKind Language = getLanguageByFileName(FileName);
amaiorano wrote:
> ioe
Author: ericwf
Date: Wed Dec 28 03:50:23 2016
New Revision: 290662
URL: http://llvm.org/viewvc/llvm-project?rev=290662&view=rev
Log:
Fix ABI incompatible C++03 nullptr_t
In C++03 libc++ emulates nullptr_t using a class, and #define's nullptr.
However this makes nullptr_t mangle differently betwee
ABataev accepted this revision.
ABataev added a comment.
This revision is now accepted and ready to land.
Function names must start with a lower case letter. LG for other changes
https://reviews.llvm.org/D28124
___
cfe-commits mailing list
cfe-commi
ABataev added inline comments.
Comment at: lib/CodeGen/CGOpenMPRuntimeNVPTX.cpp:248
+ Address WorkFn = CGF.CreateTempAlloca(
+ CGF.Int8PtrTy, CharUnits::fromQuantity(8), /*Name*/ "work_fn");
+ Address ExecStatus =
I don't like the idea of using absolute nu
Author: ericwf
Date: Wed Dec 28 05:09:18 2016
New Revision: 290666
URL: http://llvm.org/viewvc/llvm-project?rev=290666&view=rev
Log:
Fix typo in comment
Modified:
libcxx/trunk/include/__config
Modified: libcxx/trunk/include/__config
URL:
http://llvm.org/viewvc/llvm-project/libcxx/trunk/incl
ed added a comment.
I'd be interested in seeing a feature like this appearing. Any chance this
feature may be part of Clang 4.0?
https://reviews.llvm.org/D23934
___
cfe-commits mailing list
cfe-commits@lists.llvm.org
http://lists.llvm.org/cgi-bin/m
echuraev created this revision.
echuraev added a reviewer: Anastasia.
echuraev added subscribers: bader, yaxunl, cfe-commits.
https://reviews.llvm.org/D28136
Files:
lib/Headers/opencl-c.h
Index: lib/Headers/opencl-c.h
===
--- lib/
iid_iunknown abandoned this revision.
iid_iunknown added a comment.
Abandoning the patch as it is too old.
Repository:
rL LLVM
https://reviews.llvm.org/D16901
___
cfe-commits mailing list
cfe-commits@lists.llvm.org
http://lists.llvm.org/cgi-bin/m
Author: alexfh
Date: Wed Dec 28 07:48:03 2016
New Revision: 290668
URL: http://llvm.org/viewvc/llvm-project?rev=290668&view=rev
Log:
[clang-tidy] google-explicit-constructor: ignore compiler-generated conversion
operators.
Modified:
clang-tools-extra/trunk/clang-tidy/google/ExplicitConstruct
hfinkel added a comment.
In https://reviews.llvm.org/D23934#631656, @ed wrote:
> I'd be interested in seeing a feature like this appearing.
I agree.
Comment at: lib/Driver/Tools.cpp:4687
+CmdArgs.push_back(Args.MakeArgString("-ffixed-date-time=" + DateTime));
+ }
+
firolino marked 27 inline comments as done.
firolino added inline comments.
Comment at: clang-tidy/readability/OneNamePerDeclarationCheck.cpp:34
+ // a tag declaration (e.g. struct, class etc.):
+ // class A { } Object1, Object2; <-- won't be matched
+ Finder->addMatcher(
---
firolino marked 3 inline comments as done.
firolino added inline comments.
Comment at: clang-tidy/readability/OneNamePerDeclarationCheck.cpp:34
+ // a tag declaration (e.g. struct, class etc.):
+ // class A { } Object1, Object2; <-- won't be matched
+ Finder->addMatcher(
Author: tejohnson
Date: Wed Dec 28 10:45:37 2016
New Revision: 290671
URL: http://llvm.org/viewvc/llvm-project?rev=290671&view=rev
Log:
[ThinLTO] Add missing FileCheck invocation
One of the intended checks was not being performed.
Modified:
cfe/trunk/test/CodeGen/thinlto_backend.ll
Modified
tejohnson created this revision.
tejohnson added reviewers: mehdi_amini, pcc.
tejohnson added a subscriber: cfe-commits.
We can simply import all external values with summaries included in
the individual index file created for the distributed backend job,
as only those are added to the individual
I suspect this broke Win64:
http://lab.llvm.org:8011/builders/clang-x64-ninja-win7/builds/1410
On Mon, Dec 26, 2016 at 6:20 PM, Saleem Abdulrasool via cfe-commits <
cfe-commits@lists.llvm.org> wrote:
> Author: compnerd
> Date: Mon Dec 26 20:20:35 2016
> New Revision: 290569
>
> URL: http://llvm.o
This affected code generation of jump tables from switches. This was the
assembly difference for a switch when going from PIC to static:
$ cat t.cpp
void g(int);
void f(int x) {
switch (x) {
case 0: g(0); break;
case 1: g(1); break;
case 2: g(2); break;
case 3: g(3); break;
case 4: g(4
I filed https://llvm.org/bugs/show_bug.cgi?id=31488 for this.
On Wed, Dec 28, 2016 at 9:37 AM, Reid Kleckner wrote:
> This affected code generation of jump tables from switches. This was the
> assembly difference for a switch when going from PIC to static:
>
> $ cat t.cpp
> void g(int);
> void f
Author: rnk
Date: Wed Dec 28 11:41:36 2016
New Revision: 290672
URL: http://llvm.org/viewvc/llvm-project?rev=290672&view=rev
Log:
Revert "Driver: switch Windows to static RelocModel"
This reverts commit r290569. It caused unforeseen codegen changes for
switch jump tables described in PR31488.
Mo
Author: kli
Date: Wed Dec 28 11:57:07 2016
New Revision: 290673
URL: http://llvm.org/viewvc/llvm-project?rev=290673&view=rev
Log:
Fix format. NFC
Modified:
cfe/trunk/lib/CodeGen/CGStmtOpenMP.cpp
Modified: cfe/trunk/lib/CodeGen/CGStmtOpenMP.cpp
URL:
http://llvm.org/viewvc/llvm-project/cfe/tr
mehdi_amini accepted this revision.
mehdi_amini added a comment.
This revision is now accepted and ready to land.
LGTM.
https://reviews.llvm.org/D28139
___
cfe-commits mailing list
cfe-commits@lists.llvm.org
http://lists.llvm.org/cgi-bin/mailman/lis
Author: tejohnson
Date: Wed Dec 28 12:00:08 2016
New Revision: 290674
URL: http://llvm.org/viewvc/llvm-project?rev=290674&view=rev
Log:
[ThinLTO] No need to rediscover imports in distributed backend
Summary:
We can simply import all external values with summaries included in
the individual index
This revision was automatically updated to reflect the committed changes.
Closed by commit rL290674: [ThinLTO] No need to rediscover imports in
distributed backend (authored by tejohnson).
Changed prior to commit:
https://reviews.llvm.org/D28139?vs=82603&id=82608#toc
Repository:
rL LLVM
htt
jlebar added inline comments.
Comment at: lib/CodeGen/CGOpenMPRuntimeNVPTX.cpp:31
+// NVPTX Address space
+enum ADDRESS_SPACE {
+ ADDRESS_SPACE_SHARED = 3,
Please fix enum typename name and the name of the enumerator:
http://llvm.org/docs/CodingStandards.html#n
Author: prazek
Date: Wed Dec 28 12:23:23 2016
New Revision: 290675
URL: http://llvm.org/viewvc/llvm-project?rev=290675&view=rev
Log:
Mention devirtualization in release notes
Modified:
cfe/trunk/docs/ReleaseNotes.rst
Modified: cfe/trunk/docs/ReleaseNotes.rst
URL:
http://llvm.org/viewvc/llvm
jlebar added a comment.
Apologies for the drive-by review.
Comment at: lib/CodeGen/CGOpenMPRuntimeNVPTX.h:30
+ // Private state and methods.
+ //
+
This comment seems redundant with "private:" above?
https://reviews.llvm.org/D28125
__
Author: prazek
Date: Wed Dec 28 12:25:30 2016
New Revision: 290676
URL: http://llvm.org/viewvc/llvm-project?rev=290676&view=rev
Log:
Revert "Mention devirtualization in release notes"
Accidental commit. LLVM changes have not been pushed yet
This reverts commit 592453413690a2d16784667d1644758b9af7
Author: prazek
Date: Wed Dec 28 12:26:08 2016
New Revision: 290677
URL: http://llvm.org/viewvc/llvm-project?rev=290677&view=rev
Log:
[ItaniumABI] NFC changes
Modified:
cfe/trunk/lib/CodeGen/ItaniumCXXABI.cpp
Modified: cfe/trunk/lib/CodeGen/ItaniumCXXABI.cpp
URL:
http://llvm.org/viewvc/llvm-
amaiorano added inline comments.
Comment at: lib/Format/Format.cpp:1984
+// If so, can't return this error here...
+return make_string_error("Configuration file(s) do(es) not support " +
+ getLanguageName(Language) + ": " +
ama
smeenai added a comment.
Ping.
https://reviews.llvm.org/D26949
___
cfe-commits mailing list
cfe-commits@lists.llvm.org
http://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits
arpith-jacob updated this revision to Diff 82619.
arpith-jacob added a comment.
Addressed comments in review to start function names with a lowercase letter
and to fix the enum type name along with the enumerator name.
https://reviews.llvm.org/D28124
Files:
lib/CodeGen/CGOpenMPRuntimeNVPTX.c
arpith-jacob updated this revision to Diff 82621.
arpith-jacob added a comment.
Alexey and Justin, thank you for spending the time to review this patch. I've
updated the patch accordingly. I've also removed a dot ('.') from the worker
function name since the character is not accepted by the nv
lamikr created this revision.
lamikr added a subscriber: cfe-commits.
Herald added subscribers: srhines, danalbert, aemerson.
- add Mageia definition and IsMageia method
- add Mageia name for triples arrays used for x86, x86_64 and 32-bit ARM soft
and hard floating point toolchains
- --hash-style
arpith-jacob created this revision.
arpith-jacob added reviewers: ABataev, sfantao, carlo.bertolli, kkwli0, caomhin.
arpith-jacob added a subscriber: cfe-commits.
Herald added a subscriber: jholewinski.
This patch introduces support for the execution of parallel constructs in a
target
region on t
arpith-jacob added inline comments.
Comment at: lib/CodeGen/CGOpenMPRuntime.cpp:114
/// \brief Get the name of the capture helper.
- StringRef getHelperName() const override { return ".omp_outlined."; }
+ StringRef getHelperName() const override { return "__omp_outlined__";
mgorny created this revision.
mgorny added reviewers: ddunbar, sdmitrouk, dschuff.
mgorny added a subscriber: cfe-commits.
Herald added subscribers: mehdi_amini, dberris.
Remove the failing tests for __fixunssfdi() and __fixunsdfdi() that
relied on undefined (and most likely obsolete in terms of c
sgilles created this revision.
sgilles added reviewers: cfe-commits, rsmith, zaks.anna.
Add ZeroInitializer as a language option, attached to all standards of
C. Relax checks for -Wmissing-field-initializers and -Wmissing-braces so
that, for such languages, assigning to a structure with { 0 } prod
rsmith added a comment.
Why are you adding a language option for this? Just use `!LangOpts.CPlusPlus`.
https://reviews.llvm.org/D28148
___
cfe-commits mailing list
cfe-commits@lists.llvm.org
http://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits
nwilson added a comment.
Small Ping. @rsmith - did you have anymore thoughts about this patch?
https://reviews.llvm.org/D26882
___
cfe-commits mailing list
cfe-commits@lists.llvm.org
http://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits
sgilles added a comment.
In https://reviews.llvm.org/D28148#632002, @rsmith wrote:
> Why are you adding a language option for this? Just use `!LangOpts.CPlusPlus`.
I didn't want to have this change accidentally apply to other, non-C++
languages, since I'm not sure which languages would go thro
sgilles updated the summary for this revision.
sgilles updated this revision to Diff 82638.
sgilles added a comment.
Instead of adding a language option to distinguish C, negatively check
against C++.
https://reviews.llvm.org/D28148
Files:
lib/Sema/SemaInit.cpp
test/Sema/zero-initializer.c
alexshap created this revision.
alexshap added reviewers: beanz, bogner.
alexshap added a subscriber: cfe-commits.
alexshap set the repository for this revision to rL LLVM.
Herald added a subscriber: mgorny.
This diff fixes the clean build of the target generate-order-file.
In llvm/tools/clang/CMa
ABataev added a comment.
LG
https://reviews.llvm.org/D28124
___
cfe-commits mailing list
cfe-commits@lists.llvm.org
http://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits
ABataev accepted this revision.
ABataev added a comment.
This revision is now accepted and ready to land.
LG
https://reviews.llvm.org/D28125
___
cfe-commits mailing list
cfe-commits@lists.llvm.org
http://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-c
ABataev added inline comments.
Comment at: lib/CodeGen/CGOpenMPRuntime.cpp:114
/// \brief Get the name of the capture helper.
- StringRef getHelperName() const override { return ".omp_outlined."; }
+ StringRef getHelperName() const override { return "__omp_outlined__"; }
-
45 matches
Mail list logo