This revision was automatically updated to reflect the committed changes.
Closed by commit rL290489: [clang-tidy] refactor ExprSequence out of
use-after-move check (authored by mnbvmar).
Changed prior to commit:
https://reviews.llvm.org/D27700?vs=81732&id=82440#toc
Repository:
rL LLVM
https
Author: mnbvmar
Date: Sat Dec 24 06:45:07 2016
New Revision: 290489
URL: http://llvm.org/viewvc/llvm-project?rev=290489&view=rev
Log:
[clang-tidy] refactor ExprSequence out of use-after-move check
Differential Revision: https://reviews.llvm.org/D27700
Added:
clang-tools-extra/trunk/clang-tid
Author: malcolm.parsons
Date: Sat Dec 24 07:22:26 2016
New Revision: 290491
URL: http://llvm.org/viewvc/llvm-project?rev=290491&view=rev
Log:
[ASTMatchers] Fix doc for hasBitWidth
Modified:
cfe/trunk/docs/LibASTMatchersReference.html
cfe/trunk/include/clang/ASTMatchers/ASTMatchers.h
Modi
malcolm.parsons updated this revision to Diff 82441.
malcolm.parsons added a comment.
Improve doc.
https://reviews.llvm.org/D28034
Files:
docs/LibASTMatchersReference.html
include/clang/ASTMatchers/ASTMatchers.h
lib/ASTMatchers/Dynamic/Registry.cpp
unittests/ASTMatchers/ASTMatchersNarro
Author: malcolm.parsons
Date: Sat Dec 24 07:35:14 2016
New Revision: 290492
URL: http://llvm.org/viewvc/llvm-project?rev=290492&view=rev
Log:
[ASTMatchers] Add hasInClassInitializer traversal matcher for FieldDecl.
Summary:
I needed to know whether a FieldDecl had an in-class
initializer for D264
This revision was automatically updated to reflect the committed changes.
Closed by commit rL290492: [ASTMatchers] Add hasInClassInitializer traversal
matcher for FieldDecl. (authored by malcolm.parsons).
Changed prior to commit:
https://reviews.llvm.org/D28034?vs=82441&id=82442#toc
Repository
malcolm.parsons updated this revision to Diff 82443.
malcolm.parsons added a comment.
Add double backticks.
https://reviews.llvm.org/D28022
Files:
clang-tidy/performance/UnnecessaryValueParamCheck.cpp
clang-tidy/utils/DeclRefExprUtils.cpp
clang-tidy/utils/DeclRefExprUtils.h
test/clang-t
Author: malcolm.parsons
Date: Sat Dec 24 08:30:29 2016
New Revision: 290493
URL: http://llvm.org/viewvc/llvm-project?rev=290493&view=rev
Log:
[clang-tidy] Remove local hasInClassInitializer matcher. NFC
Modified:
clang-tools-extra/trunk/clang-tidy/modernize/UseDefaultMemberInitCheck.cpp
Modi
Author: yrnkrn
Date: Sat Dec 24 09:32:39 2016
New Revision: 290495
URL: http://llvm.org/viewvc/llvm-project?rev=290495&view=rev
Log:
Deduplicate several GD.getDecl() calls into Decl * local variable.
Modified:
cfe/trunk/lib/CodeGen/CodeGenModule.cpp
Modified: cfe/trunk/lib/CodeGen/CodeGenMo
aaron.ballman added inline comments.
Comment at: clang-tidy/readability/OneNamePerDeclarationCheck.cpp:22
+
+const internal::VariadicDynCastAllOfMatcher tagDecl;
+
firolino wrote:
> aaron.ballman wrote:
> > We may want to consider adding this to ASTMatchers.h at
Author: rsmith
Date: Sat Dec 24 10:40:51 2016
New Revision: 290497
URL: http://llvm.org/viewvc/llvm-project?rev=290497&view=rev
Log:
Factor out duplication between partial ordering for class template partial
specializations and variable template partial specializations.
Modified:
cfe/trunk/li
Author: marshall
Date: Sat Dec 24 11:21:03 2016
New Revision: 290500
URL: http://llvm.org/viewvc/llvm-project?rev=290500&view=rev
Log:
Fix bug #31387 - not checking end iterator when parsing decimal escape. Thanks
to Karen for the report.
Added:
libcxx/trunk/test/std/re/re.regex/re.regex.con
amaiorano added a comment.
One more thing I forgot to mention is that this change comes from a discussion
we had on this other change: https://reviews.llvm.org/D27440 where @djasper
agreed that "fallback-style should only be used when there is no .clang-format
file. If we find one, and it doesn
Author: smeenai
Date: Sat Dec 24 12:05:32 2016
New Revision: 290503
URL: http://llvm.org/viewvc/llvm-project?rev=290503&view=rev
Log:
[libc++] Make __num_get_float hidden
It's an internal function and shouldn't be exported. It's also a source
of discrepancy in the published ABI list; these symbol
This revision was automatically updated to reflect the committed changes.
Closed by commit rL290503: [libc++] Make __num_get_float hidden (authored by
smeenai).
Changed prior to commit:
https://reviews.llvm.org/D27153?vs=79362&id=82452#toc
Repository:
rL LLVM
https://reviews.llvm.org/D27153
Author: ayartsev
Date: Sat Dec 24 18:57:51 2016
New Revision: 290505
URL: http://llvm.org/viewvc/llvm-project?rev=290505&view=rev
Log:
Fix for PR15623 (corrected r290413 reverted at 290415). The patch eliminates
unwanted ProgramState checker data propagation from an operand of the logical
operat
rjmccall added a comment.
In https://reviews.llvm.org/D27680#630192, @ahatanak wrote:
> Ah, good idea. That sounds like a much simpler and less invasive approach. I
> agree that the performance impact would probably be small, and if it turns
> out to have a significant impact, we can reduce the
Author: majnemer
Date: Sat Dec 24 23:26:02 2016
New Revision: 290509
URL: http://llvm.org/viewvc/llvm-project?rev=290509&view=rev
Log:
[MS ABI] Mangle unnamed enums correctly
Unnamed enums take the name of the first enumerator they define.
Modified:
cfe/trunk/lib/AST/MicrosoftMangle.cpp
18 matches
Mail list logo