This revision was automatically updated to reflect the committed changes.
Closed by commit rGe018698bec36: [clang, test] Fix use of undef FileCheck var
(authored by thopre).
Repository:
rG LLVM Github Monorepo
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D99898/new/
https://reviews.ll
rjmccall accepted this revision.
rjmccall added a comment.
This revision is now accepted and ready to land.
Thanks!
Repository:
rG LLVM Github Monorepo
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D99898/new/
https://reviews.llvm.org/D99898
__
thopre updated this revision to Diff 335640.
thopre added a comment.
Rename NUW_RN for CHECK-YES to NUW
Repository:
rG LLVM Github Monorepo
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D99898/new/
https://reviews.llvm.org/D99898
Files:
clang/test/CodeGen/libcalls.c
Index: clang/
rjmccall added a comment.
`NUW_RN` isn't a good name for the variable in this alternative since it's not
`readnone` anymore. With an appropriate rename, LGTM.
Repository:
rG LLVM Github Monorepo
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D99898/new/
https://reviews.llvm.org/D9989
thopre updated this revision to Diff 335618.
thopre added a comment.
Change attribute check to a positive match
Repository:
rG LLVM Github Monorepo
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D99898/new/
https://reviews.llvm.org/D99898
Files:
clang/test/CodeGen/libcalls.c
Index
spatel added inline comments.
Comment at: clang/test/CodeGen/libcalls.c:127
// CHECK-NO-DAG: attributes [[NUW_RN]] = { nounwind readnone{{.*}} }
+// CHECK-YES-NOT: attributes [[NUW_RN]] = { nounwind readnone{{.*}} }
// CHECK-NO-DAG: attributes [[NUW_RNI]] = { nofree nosync noun
thopre created this revision.
thopre added reviewers: ddunbar, MaskRay, rjmccall, spatel, arsenm, hfinkel,
void, mcrosier.
thopre requested review of this revision.
Herald added a subscriber: wdng.
Herald added a project: clang.
Clang test CodeGen/libcalls.c contains CHECK-NOT directives using a