This revision was automatically updated to reflect the committed changes.
Closed by commit rG3c79734f2928: [ASTMatchers] Add invocation matcher (authored
by stephenkelly).
Changed prior to commit:
https://reviews.llvm.org/D94865?vs=319672&id=319943#toc
Repository:
rG LLVM Github Monorepo
CH
aaron.ballman accepted this revision.
aaron.ballman added a comment.
This revision is now accepted and ready to land.
LGTM aside from the list order nit. Thanks!
Comment at: clang/lib/ASTMatchers/Dynamic/Registry.cpp:155
REGISTER_MATCHER(callExpr);
+ REGISTER_MATCHER(invoca
steveire updated this revision to Diff 319672.
steveire added a comment.
Update
Repository:
rG LLVM Github Monorepo
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D94865/new/
https://reviews.llvm.org/D94865
Files:
clang/docs/LibASTMatchersReference.html
clang/include/clang/ASTMatc
steveire updated this revision to Diff 319660.
steveire added a comment.
Update
Repository:
rG LLVM Github Monorepo
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D94865/new/
https://reviews.llvm.org/D94865
Files:
clang/docs/LibASTMatchersReference.html
clang/include/clang/ASTMatc
aaron.ballman added inline comments.
Comment at: clang/include/clang/ASTMatchers/ASTMatchers.h:2867
+extern const internal::MapAnyOfMatcher
+callOrConstruct;
+
steveire wrote:
> aaron.ballman wrote:
> > steveire wrote:
> > > aaron.ballman wrote:
> > > > steve
steveire added inline comments.
Comment at: clang/include/clang/ASTMatchers/ASTMatchers.h:2867
+extern const internal::MapAnyOfMatcher
+callOrConstruct;
+
aaron.ballman wrote:
> steveire wrote:
> > aaron.ballman wrote:
> > > steveire wrote:
> > > > aaron.ball
aaron.ballman added a comment.
Pinging the reviewers to help with the naming questions.
Comment at: clang/include/clang/ASTMatchers/ASTMatchers.h:2867
+extern const internal::MapAnyOfMatcher
+callOrConstruct;
+
steveire wrote:
> aaron.ballman wrote:
> > ste
steveire added inline comments.
Comment at: clang/include/clang/ASTMatchers/ASTMatchers.h:2867
+extern const internal::MapAnyOfMatcher
+callOrConstruct;
+
aaron.ballman wrote:
> steveire wrote:
> > aaron.ballman wrote:
> > > I'm not super keen on this name. I
aaron.ballman added reviewers: klimek, sammccall, dblaikie, echristo.
aaron.ballman added a comment.
Adding some reviewers to see if we can bikeshed a somewhat better name than
`callOrConstruct`, or to see if my concerns are unfounded.
Comment at: clang/include/clang/ASTMatche
steveire updated this revision to Diff 317709.
steveire added a comment.
Update
Repository:
rG LLVM Github Monorepo
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D94865/new/
https://reviews.llvm.org/D94865
Files:
clang/docs/LibASTMatchersReference.html
clang/include/clang/ASTMatc
steveire added inline comments.
Comment at: clang/include/clang/ASTMatchers/ASTMatchers.h:2867
+extern const internal::MapAnyOfMatcher
+callOrConstruct;
+
aaron.ballman wrote:
> I'm not super keen on this name. It's certainly descriptive, but I do wonder
> i
aaron.ballman added inline comments.
Comment at: clang/include/clang/ASTMatchers/ASTMatchers.h:2867
+extern const internal::MapAnyOfMatcher
+callOrConstruct;
+
I'm not super keen on this name. It's certainly descriptive, but I do wonder if
it's a bit too spe
steveire created this revision.
steveire added a reviewer: aaron.ballman.
steveire requested review of this revision.
Herald added a project: clang.
Herald added a subscriber: cfe-commits.
Repository:
rG LLVM Github Monorepo
https://reviews.llvm.org/D94865
Files:
clang/docs/LibASTMatchersRef
13 matches
Mail list logo