This revision was automatically updated to reflect the committed changes.
Closed by commit rL350233: [sanitizer_common] Implement funopen*() interceptors
for NetBSD (authored by mgorny, committed by ).
Herald added a subscriber: delcypher.
Changed prior to commit:
https://reviews.llvm.org/D5615
mgorny updated this revision to Diff 179728.
mgorny added a comment.
Renamed stuff as requested.
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D56158/new/
https://reviews.llvm.org/D56158
Files:
lib/sanitizer_common/sanitizer_common_interceptors.inc
lib/sanitizer_common/sanitizer_pla
krytarowski added inline comments.
Comment at: lib/sanitizer_common/sanitizer_common_interceptors.inc:9150
+
+static int wrapped_read(void *cookie, char *buf, int len) {
+ COMMON_INTERCEPTOR_UNPOISON_PARAM(3);
How about `wrapped_funopen_read` etc? It won't clash
krytarowski added inline comments.
Comment at: lib/sanitizer_common/sanitizer_common_interceptors.inc:9142
+
+struct WrappedCookie {
+ void *real_cookie;
I would call it WrappedFunopenCookie to be less generic, similarly for funopen2.
CHANGES SINCE LAST ACTION
mgorny updated this revision to Diff 179723.
mgorny added a comment.
Fixed accidental whitespace change.
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D56158/new/
https://reviews.llvm.org/D56158
Files:
lib/sanitizer_common/sanitizer_common_interceptors.inc
lib/sanitizer_common/sanit
mgorny updated this revision to Diff 179722.
mgorny added a comment.
Implemented wrappers as requested.
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D56158/new/
https://reviews.llvm.org/D56158
Files:
lib/sanitizer_common/sanitizer_common_interceptors.inc
lib/sanitizer_common/saniti
krytarowski added a comment.
Shouldn't this follow SANITIZER_INTERCEPT_FOPENCOOKIE and implement a wrapper
for operations?
Repository:
rCRT Compiler Runtime
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D56158/new/
https://reviews.llvm.org/D56158
__
mgorny created this revision.
mgorny added reviewers: krytarowski, vitalybuka.
Herald added subscribers: Sanitizers, llvm-commits, kubamracek.
Repository:
rCRT Compiler Runtime
https://reviews.llvm.org/D56158
Files:
lib/sanitizer_common/sanitizer_common_interceptors.inc
lib/sanitizer_commo