This revision was automatically updated to reflect the committed changes.
Closed by commit rC321203: [hwasan] Implement -fsanitize-recover=hwaddress.
(authored by eugenis, committed by ).
Changed prior to commit:
https://reviews.llvm.org/D41417?vs=127642&id=127760#toc
Repository:
rC Clang
h
eugenis updated this revision to Diff 127642.
eugenis added a comment.
Tweaked a test.
https://reviews.llvm.org/D41417
Files:
clang/lib/CodeGen/BackendUtil.cpp
compiler-rt/lib/hwasan/hwasan.cc
compiler-rt/lib/hwasan/hwasan_interface_internal.h
compiler-rt/lib/hwasan/hwasan_linux.cc
co
eugenis updated this revision to Diff 127640.
eugenis added a comment.
Replaced booleans with enums.
Added __builtin_unreachable in non-recover variants of callbacks.
https://reviews.llvm.org/D41417
Files:
clang/lib/CodeGen/BackendUtil.cpp
compiler-rt/lib/hwasan/hwasan.cc
compiler-rt/lib/
eugenis added inline comments.
Comment at: compiler-rt/lib/hwasan/hwasan.cc:255
-template
+template
__attribute__((always_inline, nodebug))
kcc wrote:
> I'd prefer enums to booleans, for better readability
good idea!
https://reviews.llvm.org/D41417
__
kcc accepted this revision.
kcc added a comment.
This revision is now accepted and ready to land.
LGTM with a nit
Comment at: compiler-rt/lib/hwasan/hwasan.cc:255
-template
+template
__attribute__((always_inline, nodebug))
I'd prefer enums to booleans, for b
eugenis created this revision.
eugenis added reviewers: kcc, alekseyshl.
Herald added subscribers: hiraditya, kubamracek.
Very similar to AddressSanitizer, with the exception of the error type encoding.
https://reviews.llvm.org/D41417
Files:
clang/lib/CodeGen/BackendUtil.cpp
compiler-rt/lib