This revision was automatically updated to reflect the committed changes.
Closed by commit rL286472: [clang-tidy] Add modernize-use-equals-delete check
(authored by malcolm.parsons).
Changed prior to commit:
https://reviews.llvm.org/D26138?vs=76971&id=77500#toc
Repository:
rL LLVM
https://r
aaron.ballman accepted this revision.
aaron.ballman added a comment.
This revision is now accepted and ready to land.
LGTM, thank you!
Comment at: clang-tidy/modernize/UseEqualsDeleteCheck.cpp:58
+ << FixItHint::CreateInsertion(StartLoc, "public: ")
+ << FixItHint::Cr
malcolm.parsons updated this revision to Diff 76971.
malcolm.parsons added a comment.
Check for non-public deleted methods.
Remove imperfect FixItHint.
Add FIXME comments.
https://reviews.llvm.org/D26138
Files:
clang-tidy/modernize/CMakeLists.txt
clang-tidy/modernize/ModernizeTidyModule.cpp
malcolm.parsons planned changes to this revision.
malcolm.parsons added inline comments.
Comment at: clang-tidy/modernize/UseEqualsDeleteCheck.cpp:58
+ << FixItHint::CreateInsertion(StartLoc, "public: ")
+ << FixItHint::CreateInsertion(AfterLoc, " private:");
+}
---
aaron.ballman added inline comments.
Comment at: clang-tidy/modernize/UseEqualsDeleteCheck.cpp:58
+ << FixItHint::CreateInsertion(StartLoc, "public: ")
+ << FixItHint::CreateInsertion(AfterLoc, " private:");
+}
malcolm.parsons wrote:
> aaron.ballman wro
malcolm.parsons added inline comments.
Comment at: clang-tidy/modernize/UseEqualsDeleteCheck.cpp:58
+ << FixItHint::CreateInsertion(StartLoc, "public: ")
+ << FixItHint::CreateInsertion(AfterLoc, " private:");
+}
aaron.ballman wrote:
> I am on the fence
malcolm.parsons updated this revision to Diff 76729.
malcolm.parsons added a comment.
Take out renaming of modernize-use-default.
https://reviews.llvm.org/D26138
Files:
clang-tidy/modernize/CMakeLists.txt
clang-tidy/modernize/ModernizeTidyModule.cpp
clang-tidy/modernize/UseEqualsDeleteChe
aaron.ballman added a comment.
Can you split the modernize-use-default changes into a separate patch? I think
that change requires additional discussion, because renaming the check may
break users relying on the old name. The changes aren't really related (aside
from naming consistency), and I'
malcolm.parsons updated this revision to Diff 76561.
malcolm.parsons added a comment.
Add quick hack to make methods public.
Cleanup around replacements should be enhanced with rules to remove
empty private/protected/public sections.
private: public: -> public:
public: private: -> private:
https
malcolm.parsons updated this revision to Diff 76558.
malcolm.parsons added a comment.
Add FIXME comment.
https://reviews.llvm.org/D26138
Files:
clang-tidy/modernize/CMakeLists.txt
clang-tidy/modernize/ModernizeTidyModule.cpp
clang-tidy/modernize/UseDefaultCheck.cpp
clang-tidy/modernize/
malcolm.parsons updated this revision to Diff 76557.
malcolm.parsons added a comment.
Reword diagnostic.
https://reviews.llvm.org/D26138
Files:
clang-tidy/modernize/CMakeLists.txt
clang-tidy/modernize/ModernizeTidyModule.cpp
clang-tidy/modernize/UseDefaultCheck.cpp
clang-tidy/modernize/
aaron.ballman added inline comments.
Comment at: clang-tidy/modernize/UseEqualsDeleteCheck.cpp:29
+cxxMethodDecl(
+anyOf(isCopyAssignmentOperator(), isMoveAssignmentOperator())),
+cxxDestructorDecl()));
malcolm.parsons wrot
malcolm.parsons added inline comments.
Comment at: clang-tidy/modernize/UseEqualsDeleteCheck.cpp:29
+cxxMethodDecl(
+anyOf(isCopyAssignmentOperator(), isMoveAssignmentOperator())),
+cxxDestructorDecl()));
aaron.ballman wrot
aaron.ballman added inline comments.
Comment at: clang-tidy/modernize/UseEqualsDeleteCheck.cpp:29
+cxxMethodDecl(
+anyOf(isCopyAssignmentOperator(), isMoveAssignmentOperator())),
+cxxDestructorDecl()));
malcolm.parsons wrot
malcolm.parsons updated this revision to Diff 76529.
malcolm.parsons added a comment.
Rename modernize-use-default to modernize-use-equals-default
https://reviews.llvm.org/D26138
Files:
clang-tidy/modernize/CMakeLists.txt
clang-tidy/modernize/ModernizeTidyModule.cpp
clang-tidy/modernize/U
malcolm.parsons updated this revision to Diff 76493.
malcolm.parsons added a comment.
Fix comment.
Rename variable.
Use global.
https://reviews.llvm.org/D26138
Files:
clang-tidy/modernize/CMakeLists.txt
clang-tidy/modernize/ModernizeTidyModule.cpp
clang-tidy/modernize/UseEqualsDeleteCheck
malcolm.parsons added inline comments.
Comment at: clang-tidy/modernize/UseEqualsDeleteCheck.cpp:29
+cxxMethodDecl(
+anyOf(isCopyAssignmentOperator(), isMoveAssignmentOperator())),
+cxxDestructorDecl()));
aaron.ballman wrot
aaron.ballman added inline comments.
Comment at: clang-tidy/modernize/UseEqualsDeleteCheck.cpp:29
+cxxMethodDecl(
+anyOf(isCopyAssignmentOperator(), isMoveAssignmentOperator())),
+cxxDestructorDecl()));
How about a conversi
Eugene.Zelenko added a comment.
It'll be good idea to rename //modernize-use-default// in similar fashion,
since both checks are closely relate and in both cases keywords are ambiguous.
https://reviews.llvm.org/D26138
___
cfe-commits mailing list
c
19 matches
Mail list logo