.llvm.org
> Sent: Wednesday, September 28, 2016 2:55:44 PM
> Subject: Re: [PATCH] D24481: make “#pragma STDC FP_CONTRACT” on by default
>
>
> If we do this we should at least be targetted and restrict it to the
> tests that need the flag. For example you could put:
> list(A
;,
>> cfe-commits@lists.llvm.org <mailto:cfe-commits@lists.llvm.org>
>> Sent: Friday, September 23, 2016 4:47:32 PM
>> Subject: Re: [PATCH] D24481: make “#pragma STDC FP_CONTRACT” on by default
>>
>> Without digging into them yet, these are almost caused by
98...@reviews.llvm.org
>> Cc: "a skolnik" , clatt...@apple.com,
>> hfin...@anl.gov, "yaxun liu" ,
>> cfe-commits@lists.llvm.org
>> Sent: Friday, September 23, 2016 4:47:32 PM
>> Subject: Re: [PATCH] D24481: make “#pragma STDC FP_CONTRACT” o
ot;Steve Canon"
> To: reviews+d24481+public+c0b8d50a92298...@reviews.llvm.org
> Cc: "a skolnik" , clatt...@apple.com, hfin...@anl.gov,
> "yaxun liu" ,
> cfe-commits@lists.llvm.org
> Sent: Friday, September 23, 2016 4:47:32 PM
> Subject: Re: [PATCH] D2
Without digging into them yet, these are almost caused by overly-sensitive
tests that are erroneously expecting bit-exact results.
- Steve
Sent from my iPhone
> On Sep 23, 2016, at 4:42 PM, Renato Golin wrote:
>
> rengolin added a subscriber: rengolin.
> rengolin added a comment.
>
> Folks,
rengolin added a subscriber: rengolin.
rengolin added a comment.
Folks, this commit has broken both AArch64 test-suite buildbots:
http://lab.llvm.org:8011/builders/clang-cmake-aarch64-full/builds/3162
http://lab.llvm.org:8011/builders/clang-cmake-aarch64-quick/builds/10449
I have reverted in r2
This revision was automatically updated to reflect the committed changes.
Closed by commit rL282259: set the underlying value of “#pragma STDC
FP_CONTRACT” on by default (authored by spop).
Changed prior to commit:
https://reviews.llvm.org/D24481?vs=72186&id=72299#toc
Repository:
rL LLVM
ht
scanon accepted this revision.
scanon added a comment.
This revision is now accepted and ready to land.
LGTM
https://reviews.llvm.org/D24481
___
cfe-commits mailing list
cfe-commits@lists.llvm.org
http://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-c
yaxunl added a comment.
LGTM. Thanks.
https://reviews.llvm.org/D24481
___
cfe-commits mailing list
cfe-commits@lists.llvm.org
http://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits
Abe updated this revision to Diff 72186.
Abe added a comment.
Minor edits for style-guidelines conformance.
https://reviews.llvm.org/D24481
Files:
clang/lib/Frontend/CompilerInvocation.cpp
clang/test/CodeGen/aarch64-neon-fma.c
clang/test/CodeGen/aarch64-scalar-fma.c
clang/test/CodeGen/f
yaxunl added inline comments.
Comment at: clang/lib/Frontend/CompilerInvocation.cpp:2441
@@ +2440,3 @@
+
+ if ((LangOpts.C11 || LangOpts.C99 || LangOpts.CPlusPlus)
+ && ( CodeGenOptions::FPC_On == Res.getCodeGenOpts().getFPContractMode()
)
The format o
Abe updated this revision to Diff 72103.
Abe added a comment.
Combined "fp-contract-pragma___on-by-default___-O0___aarch64-backend.c" and
"fp-contract-pragma___on-by-default___-O1...3___aarch64-backend.c" into a
single file ["fp-contract-pragma___on-by-default.c"].
https://reviews.llvm.org/D24
yaxunl added inline comments.
Comment at:
clang/test/CodeGen/fp-contract-pragma___on-by-default___-O1...3___aarch64-backend.c:8
@@ +7,3 @@
+// CHECK: fmadd d0, d{{[0-7]}}, d{{[0-7]}}, d{{[0-7]}}
+// CHECK-NEXT: ret
+double fmadd_double(double a, double b, double c) {
Abe updated this revision to Diff 71959.
Abe added a comment.
Collapsed 4 test-case files that didn`t really need to be separate into 1 file,
as suggested by Yaxun Liu.
https://reviews.llvm.org/D24481
Files:
clang/lib/Frontend/CompilerInvocation.cpp
clang/test/CodeGen/aarch64-neon-fma.c
Abe added a comment.
In https://reviews.llvm.org/D24481#547694, @yaxunl wrote:
> Is it possible to merge
> cfe/trunk/test/CodeGen/fp-contract-pragma___on-by-default___-O[0-3]___aarch64-backend.c
> as one and remove
> cfe/trunk/test/CodeGen/fp-contract-pragma___on-by-default___-O1...3___aarch64
Abe updated this revision to Diff 71953.
Abe added a comment.
Removed some comments that I felt were good for clarity but at least 2 people
disagreed.
https://reviews.llvm.org/D24481
Files:
cfe/trunk/lib/Frontend/CompilerInvocation.cpp
cfe/trunk/test/CodeGen/aarch64-neon-fma.c
cfe/trunk/
yaxunl added a comment.
> ... then that will cause 3 compilations and 3 tests, right?
Right.
https://reviews.llvm.org/D24481
___
cfe-commits mailing list
cfe-commits@lists.llvm.org
http://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits
yaxunl added a comment.
Is it possible to merge
cfe/trunk/test/CodeGen/fp-contract-pragma___on-by-default___-O[0-3]___aarch64-backend.c
as one and remove
cfe/trunk/test/CodeGen/fp-contract-pragma___on-by-default___-O1...3___aarch64-backend.h?
They look the same except the RUN commands. Why not
18 matches
Mail list logo