jolanta.jensen added a comment.
@tahonermann, I addressed your comments in https://reviews.llvm.org/D129373. I
just need to remove a tab that crept in and it seems to be more difficult than
I thought as my code does not seem to have any tab and reformatting the code
does not change the file.
tahonermann added a comment.
@jolanta.jensen, I was on vacation last week and missed my opportunity to
comment on this. I know the change has already landed, but I added a few
comments anyway.
Comment at: clang/include/clang/Basic/TargetInfo.h:226-227
+ unsigned RealTypeUses
This revision was automatically updated to reflect the committed changes.
Closed by commit rG32aac7babfdd: [NFC] Switch FloatModeKind enum class to use
bitmask enums (authored by jolanta.jensen).
Repository:
rG LLVM Github Monorepo
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D128182/n
aaron.ballman accepted this revision.
aaron.ballman added a comment.
This revision is now accepted and ready to land.
LGTM again, this time for real.
Comment at: clang/include/clang/Basic/TargetInfo.h:225-226
unsigned HasAlignMac68kSupport : 1;
- unsigned RealTypeUsesObjCFP
jolanta.jensen added inline comments.
Comment at: clang/include/clang/Basic/TargetInfo.h:225-226
unsigned HasAlignMac68kSupport : 1;
- unsigned RealTypeUsesObjCFPRetMask : (int)FloatModeKind::Last + 1;
+ unsigned RealTypeUsesObjCFPRetMask
+ : (int)FloatModeKind::LLVM_BI
jolanta.jensen updated this revision to Diff 440653.
jolanta.jensen added a comment.
Correcting computation of RealTypeUsesObjCFPRetMask.
Repository:
rG LLVM Github Monorepo
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D128182/new/
https://reviews.llvm.org/D128182
Files:
clang/inc
aaron.ballman requested changes to this revision.
aaron.ballman added a subscriber: shafik.
aaron.ballman added inline comments.
This revision now requires changes to proceed.
Comment at: clang/include/clang/Basic/TargetInfo.h:225-226
unsigned HasAlignMac68kSupport : 1;
- uns
aaron.ballman accepted this revision.
aaron.ballman added a comment.
LGTM, thanks!
Repository:
rG LLVM Github Monorepo
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D128182/new/
https://reviews.llvm.org/D128182
___
cfe-commits mailing list
jolanta.jensen updated this revision to Diff 440141.
jolanta.jensen added a comment.
Removed an unnecessary local variable.
Repository:
rG LLVM Github Monorepo
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D128182/new/
https://reviews.llvm.org/D128182
Files:
clang/include/clang/Bas
aaron.ballman accepted this revision.
aaron.ballman added a comment.
This revision is now accepted and ready to land.
LGTM aside from a tiny naming nit. Thank you for the cleanup!
Comment at: clang/include/clang/Basic/TargetInfo.h:895-896
bool useObjCFPRetForRealType(FloatMo
jolanta.jensen created this revision.
Herald added a project: All.
jolanta.jensen requested review of this revision.
Herald added a project: clang.
Herald added a subscriber: cfe-commits.
Using bitmask enums simplifies and clarifies the code.
Repository:
rG LLVM Github Monorepo
https://review
11 matches
Mail list logo