[PATCH] D97753: [clang-tidy] Add a check for enforcing minimum length for variable names

2021-08-07 Thread Florin Iucha via Phabricator via cfe-commits
0x8000- updated this revision to Diff 364997. 0x8000- added a comment. Added separate check for parameter names. CHANGES SINCE LAST ACTION https://reviews.llvm.org/D97753/new/ https://reviews.llvm.org/D97753 Files: clang-tools-extra/clang-tidy/readability/CMakeLists.txt clang-too

[PATCH] D107641: [clang-tidy] fix duplicate '{}' in cppcoreguidelines-pro-type-member-init

2021-08-07 Thread liushuai wang via Phabricator via cfe-commits
MTC added inline comments. Comment at: clang-tools-extra/clang-tidy/cppcoreguidelines/ProTypeMemberInitCheck.cpp:36 template void forEachField(const RecordDecl &Record, const T &Fields, Func &&Fn) { for (const FieldDecl *F : Fields) { Btw, the parameter `R

[PATCH] D107506: [PowerPC][AIX] Warn when using pragma align(packed) on AIX.

2021-08-07 Thread Sean Fertile via Phabricator via cfe-commits
sfertile updated this revision to Diff 364996. sfertile marked an inline comment as done. sfertile added a comment. Add a couple more struct layouts to the testing to show cases diagnostic is not issued. Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https://reviews.llvm.org

[PATCH] D107703: [AST][clangd] Expose documentation of Attrs on hover.

2021-08-07 Thread Sam McCall via Phabricator via cfe-commits
sammccall created this revision. sammccall added reviewers: aaron.ballman, kadircet. Herald added subscribers: usaxena95, arphaman, mgorny. sammccall requested review of this revision. Herald added subscribers: cfe-commits, MaskRay, ilya-biryukov. Herald added projects: clang, clang-tools-extra. T

[PATCH] D97753: [clang-tidy] Add a check for enforcing minimum length for variable names

2021-08-07 Thread Florin Iucha via Phabricator via cfe-commits
0x8000- marked an inline comment as done. 0x8000- added a comment. Added regex for exception names and rebased onto current 'main' branch. Comment at: clang-tools-extra/clang-tidy/readability/ReadabilityTidyModule.cpp:136 +CheckFactories.registerCheck( +"re

[PATCH] D69764: [clang-format] Add East/West Const fixer capability

2021-08-07 Thread Stephen Kelly via Phabricator via cfe-commits
steveire added a comment. Making a separate tool for this makes no sense. Especially as you are only proposing it to satisfy one (or are there more) vocal objector. The objections to this make no sense. If you don't want to use it, then don't enable it. That principle applies whether "the way t

[PATCH] D107559: [clang] Fix libclang linking on Solaris

2021-08-07 Thread Rainer Orth via Phabricator via cfe-commits
This revision was automatically updated to reflect the committed changes. Closed by commit rGa382a746275b: [clang] Fix libclang linking on Solaris (authored by ro). Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https://reviews.llvm.org/D107559/new/ https://reviews.llvm.org/D

[clang] a382a74 - [clang] Fix libclang linking on Solaris

2021-08-07 Thread Rainer Orth via cfe-commits
Author: Rainer Orth Date: 2021-08-07T21:14:15+02:00 New Revision: a382a746275b4a1eb1867331efa2319c614305d8 URL: https://github.com/llvm/llvm-project/commit/a382a746275b4a1eb1867331efa2319c614305d8 DIFF: https://github.com/llvm/llvm-project/commit/a382a746275b4a1eb1867331efa2319c614305d8.diff L

[PATCH] D107138: [PowerPC] Implement cmplxl builtins

2021-08-07 Thread Nemanja Ivanovic via Phabricator via cfe-commits
nemanjai added inline comments. Comment at: clang/test/CodeGen/builtins-ppc-xlcompat-complex.c:1 +// RUN: %clang_cc1 -O2 -triple powerpc64-unknown-unknown \ +// RUN: -emit-llvm %s -o - -target-cpu pwr7 | FileCheck %s Conanap wrote: > NeHuang wrote: > > NeHuang

[PATCH] D107242: [AIX] Define __HOS_AIX__ macro

2021-08-07 Thread Nemanja Ivanovic via Phabricator via cfe-commits
nemanjai added a comment. In D107242#2932289 , @joerg wrote: > I'm puzzled by this change. I don't think we have any case so far where the > compiler behavior changes with the host OS and I don't think it should. > What's the point / use case of this ma

[PATCH] D107696: [CodeComplete] Basic code completion for attribute names.

2021-08-07 Thread Sam McCall via Phabricator via cfe-commits
sammccall created this revision. sammccall added reviewers: aaron.ballman, kadircet. Herald added subscribers: usaxena95, arphaman. sammccall requested review of this revision. Herald added projects: clang, clang-tools-extra. Herald added a subscriber: cfe-commits. Only the bare name is completed,

[clang] 618543b - [clang][NFC] Fix a -Wparentheses warning.

2021-08-07 Thread Craig Topper via cfe-commits
Author: Craig Topper Date: 2021-08-07T08:56:31-07:00 New Revision: 618543bb120b5c92e692a4b22deb59012e047c9d URL: https://github.com/llvm/llvm-project/commit/618543bb120b5c92e692a4b22deb59012e047c9d DIFF: https://github.com/llvm/llvm-project/commit/618543bb120b5c92e692a4b22deb59012e047c9d.diff

[PATCH] D107682: [AVR][clang] Improve search for avr-libc installation path

2021-08-07 Thread Ben Shi via Phabricator via cfe-commits
benshi001 updated this revision to Diff 364955. benshi001 edited the summary of this revision. Herald added a subscriber: ormris. CHANGES SINCE LAST ACTION https://reviews.llvm.org/D107682/new/ https://reviews.llvm.org/D107682 Files: clang/lib/Driver/ToolChains/AVR.cpp clang/test/Driver/av

[PATCH] D107682: [AVR][clang] Improve search for avr-libc installation path

2021-08-07 Thread Ben Shi via Phabricator via cfe-commits
benshi001 added a comment. In D107682#2932607 , @mhjacobson wrote: > For other examples of using four `..`s, look in `Gnu.cpp`, where there are > several places where `getParentLibPath()` is appended with `/../`. > `AddMultilibPaths()`, `PushPPaths()`

[PATCH] D107682: [AVR][clang] Improve search for avr-libc installation path

2021-08-07 Thread Ben Shi via Phabricator via cfe-commits
benshi001 updated this revision to Diff 364954. CHANGES SINCE LAST ACTION https://reviews.llvm.org/D107682/new/ https://reviews.llvm.org/D107682 Files: clang/lib/Driver/ToolChains/AVR.cpp clang/test/Driver/avr-toolchain.c Index: clang/test/Driver/avr-toolchain.c =

[PATCH] D107693: [Parser] Fix attr infloop on "int x [[c"

2021-08-07 Thread Sam McCall via Phabricator via cfe-commits
sammccall created this revision. sammccall added a reviewer: aaron.ballman. Herald added a subscriber: jdoerfert. sammccall requested review of this revision. Herald added a project: clang. Herald added a subscriber: cfe-commits. Similar to ad2d6bbb1435cef0a048c9aed3dcf9617640f222

[PATCH] D107684: [NFC][AVR][clang] Add test for D107672

2021-08-07 Thread Ben Shi via Phabricator via cfe-commits
benshi001 added a comment. @MaskRay I think this test is OK. What is your opinion ? Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https://reviews.llvm.org/D107684/new/ https://reviews.llvm.org/D107684 ___ cfe-commits mailing lis

[PATCH] D92024: [clang] Implement P0692R1 from C++20 (access checking on specializations and instantiations)

2021-08-07 Thread Kristina Bessonova via Phabricator via cfe-commits
krisb accepted this revision. krisb added a comment. This revision is now accepted and ready to land. @aorlov, thank you! LGTM. Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https://reviews.llvm.org/D92024/new/ https://reviews.llvm.org/D92024 __

[PATCH] D107684: [NFC][AVR][clang] Add test for D107672

2021-08-07 Thread Matt Jacobson via Phabricator via cfe-commits
mhjacobson added a comment. In D107684#2932609 , @benshi001 wrote: > In D107684#2932605 , @mhjacobson > wrote: > >> In D107684#2932603 , @benshi001 >> wrote: >> >>> We n

[PATCH] D107684: [NFC][AVR][clang] Add test for D107672

2021-08-07 Thread Matt Jacobson via Phabricator via cfe-commits
mhjacobson updated this revision to Diff 364942. mhjacobson added a comment. Simplify. Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https://reviews.llvm.org/D107684/new/ https://reviews.llvm.org/D107684 Files: clang/test/Driver/avr-toolchain.c Index: clang/test/Driver

[PATCH] D107684: [NFC][AVR][clang] Add test for D107672

2021-08-07 Thread Ben Shi via Phabricator via cfe-commits
benshi001 added a comment. In D107684#2932605 , @mhjacobson wrote: > In D107684#2932603 , @benshi001 > wrote: > >> We need not add another `basic_avr_tree_opt_local`, since you added `/avr` >> to possible avr-l

[PATCH] D107682: [AVR][clang] Improve search for avr-libc installation path

2021-08-07 Thread Matt Jacobson via Phabricator via cfe-commits
mhjacobson added a comment. For other examples of using four `..`s, look in `Gnu.cpp`, where there are several places where `getParentLibPath()` is appended with `/../`. `AddMultilibPaths()`, `PushPPaths()`. `getParentLibPath()`, in turn, is `GCCInstallPath/../../../` CHANGES SINCE LAST ACTI

[PATCH] D107684: [NFC][AVR][clang] Add test for D107672

2021-08-07 Thread Matt Jacobson via Phabricator via cfe-commits
mhjacobson added a comment. In D107684#2932603 , @benshi001 wrote: > We need not add another `basic_avr_tree_opt_local`, since you added `/avr` to > possible avr-libc pathes, you can test your change by specifying `--sysroot > %S/Inputs/basic_avr_tree/

[PATCH] D107682: [AVR][clang] Improve search for avr-libc installation path

2021-08-07 Thread Matt Jacobson via Phabricator via cfe-commits
mhjacobson added a comment. In D107682#2932599 , @benshi001 wrote: > @mhjacobson Could you please check if my modification also works as expected > on your platform ? Hm... it doesn't, because there aren't enough `..`s. Here's what my directory tree lo

[PATCH] D107684: [NFC][AVR][clang] Add test for D107672

2021-08-07 Thread Ben Shi via Phabricator via cfe-commits
benshi001 added a comment. We need not add another `basic_avr_tree_opt_local`, since you added `/avr` to possible avr-libc pathes, you can test your change by specifying `--sysroot %S/Inputs/basic_avr_tree/usr/lib/` . Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https://

[PATCH] D107684: [NFC][AVR][clang] Add test for D107672

2021-08-07 Thread Ben Shi via Phabricator via cfe-commits
benshi001 added inline comments. Comment at: clang/test/Driver/avr-toolchain.c:9 -// RUN: %clang %s -### -target avr --sysroot %S/Inputs/basic_avr_tree 2>&1 -nostdinc | FileCheck -check-prefix CC1B %s -// CC1B-NOT: "-internal-isystem" {{".*avr/include"}} +// RUN: %clang %s -##

[PATCH] D104975: Implement P1949

2021-08-07 Thread Corentin Jabot via Phabricator via cfe-commits
cor3ntin updated this revision to Diff 364941. cor3ntin added a comment. Update cxx_status Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https://reviews.llvm.org/D104975/new/ https://reviews.llvm.org/D104975 Files: clang/include/clang/Basic/DiagnosticLexKinds.td clang/

[PATCH] D107682: [AVR][clang] Improve search for avr-libc installation path

2021-08-07 Thread Ben Shi via Phabricator via cfe-commits
benshi001 added a comment. @mhjacobson Could you please check if my modification also works as expected on your platform ? CHANGES SINCE LAST ACTION https://reviews.llvm.org/D107682/new/ https://reviews.llvm.org/D107682 ___ cfe-commits mailing lis

[PATCH] D107682: [AVR][clang] Improve search for avr-libc installation path

2021-08-07 Thread Ben Shi via Phabricator via cfe-commits
benshi001 marked an inline comment as done. benshi001 added a comment. Thanks. I have added some comments about our agreed logic, as discussed in https://reviews.llvm.org/D107672. I think this way is clear enough. CHANGES SINCE LAST ACTION https://reviews.llvm.org/D107682/new/ https://revie

[PATCH] D107682: [AVR][clang] Improve search for avr-libc installation path

2021-08-07 Thread Ben Shi via Phabricator via cfe-commits
benshi001 updated this revision to Diff 364940. CHANGES SINCE LAST ACTION https://reviews.llvm.org/D107682/new/ https://reviews.llvm.org/D107682 Files: clang/lib/Driver/ToolChains/AVR.cpp clang/test/Driver/avr-toolchain.c Index: clang/test/Driver/avr-toolchain.c =

[PATCH] D107682: [AVR][clang] Improve search for avr-libc installation path

2021-08-07 Thread Matt Jacobson via Phabricator via cfe-commits
mhjacobson added inline comments. Comment at: clang/lib/Driver/ToolChains/AVR.cpp:457 + std::string GCCRoot(GCCInstallation.getInstallPath()); + std::string Path(GCCRoot + "/../../../avr"); + if (llvm::sys::fs::is_directory(Path)) Would it be worth encapsulati

[PATCH] D107682: [AVR][clang] Improve search for avr-libc installation path

2021-08-07 Thread Ben Shi via Phabricator via cfe-commits
benshi001 updated this revision to Diff 364938. benshi001 retitled this revision from "[AVR][clang] Search avr-libc installtion path according to avr-gcc's" to "[AVR][clang] Improve search for avr-libc installation path". benshi001 edited the summary of this revision. CHANGES SINCE LAST ACTION