dvyukov added a comment.
This needs some tests, at least to exercise interceptors code once.
Comment at: lib/esan/esan_interceptors.cpp:90
} while (false)
+#define COMMON_INTERCEPTOR_PIPE_OPEN(ctx, file)
\
+ do {
This revision was automatically updated to reflect the committed changes.
Closed by commit rL350171: [gn build] Make `ninja check-clang` also run
Clang's unit tests (authored by nico, committed by ).
Herald added a subscriber: llvm-commits.
Changed prior to commit:
https://reviews.llvm.org/D561
phosek accepted this revision.
phosek added a comment.
This revision is now accepted and ready to land.
LGTM
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D56116/new/
https://reviews.llvm.org/D56116
___
cfe-commits mailing list
cfe-commits@l
thakis updated this revision to Diff 179744.
thakis marked 2 inline comments as done.
thakis added a comment.
comments
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D56116/new/
https://reviews.llvm.org/D56116
Files:
llvm/utils/gn/build/BUILDCONFIG.gn
llvm/utils/gn/build/sync_source_
thakis added a comment.
Thanks for the fast turnaround!
Comment at: llvm/utils/gn/secondary/llvm/utils/unittest/unittest.gni:34
+# out/gn/obj/clang/unittests/Format/FormatTests, which seems fine.
+output_dir = target_out_dir
+deps += [
phosek wrote:
phosek added inline comments.
Comment at: llvm/utils/gn/secondary/llvm/utils/unittest/unittest.gni:34
+# out/gn/obj/clang/unittests/Format/FormatTests, which seems fine.
+output_dir = target_out_dir
+deps += [
What if someone explicitly sets `output_d
Author: mps
Date: Sun Dec 30 12:22:37 2018
New Revision: 350167
URL: http://llvm.org/viewvc/llvm-project?rev=350167&view=rev
Log:
DeclAccessPair visualizer should be expandable
Modified:
cfe/trunk/utils/ClangVisualizers/clang.natvis
Modified: cfe/trunk/utils/ClangVisualizers/clang.natvis
URL
Eugene.Zelenko added a comment.
Please mention new check in Release Notes and list of checks. It'll be good
idea to used add_new_check.py.
Comment at: clang-tidy/modernize/UseTrailingReturnCheck.cpp:22
+// very similar to UseOverrideCheck
+SourceLocation findTrailingReturnType
thakis updated this revision to Diff 179736.
thakis edited the summary of this revision.
thakis added a comment.
Add unittest template. This is now ready to go.
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D56116/new/
https://reviews.llvm.org/D56116
Files:
llvm/utils/gn/build/BUILDCO
lebedev.ri added a comment.
Some thoughts.
Comment at: clang-tidy/modernize/UseTrailingReturnCheck.cpp:21-22
+
+// very similar to UseOverrideCheck
+SourceLocation findTrailingReturnTypeLocation(const CharSourceRange &range,
+ const
bernhardmgruber updated this revision to Diff 179734.
bernhardmgruber added a comment.
updated diff to one with full context
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D56160/new/
https://reviews.llvm.org/D56160
Files:
clang-tidy/modernize/CMakeLists.txt
clang-tidy/modernize/Mode
bernhardmgruber added a comment.
Hi!
This is my first contribution to LLVM and I may not yet know the conventions
here.
I decided to write this pass, as some work colleagues and me oftenly want to
modernize legacy code bases. We like the trailing return type syntax available
since C++11 and u
lebedev.ri added a comment.
Please always upload all patches with full context (`-U9`).
Repository:
rCTE Clang Tools Extra
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D56160/new/
https://reviews.llvm.org/D56160
___
cfe-commits maili
bernhardmgruber created this revision.
bernhardmgruber added a reviewer: alexfh.
bernhardmgruber added a project: clang-tools-extra.
Herald added subscribers: cfe-commits, mgorny.
The new clang-tidy pass modernize-use-trailing-return rewrites function
signatures to use a trailing return type.
A
mgorny updated this revision to Diff 179728.
mgorny added a comment.
Renamed stuff as requested.
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D56158/new/
https://reviews.llvm.org/D56158
Files:
lib/sanitizer_common/sanitizer_common_interceptors.inc
lib/sanitizer_common/sanitizer_pla
krytarowski added inline comments.
Comment at: lib/sanitizer_common/sanitizer_common_interceptors.inc:9150
+
+static int wrapped_read(void *cookie, char *buf, int len) {
+ COMMON_INTERCEPTOR_UNPOISON_PARAM(3);
How about `wrapped_funopen_read` etc? It won't clash
krytarowski added inline comments.
Comment at: lib/sanitizer_common/sanitizer_common_interceptors.inc:9142
+
+struct WrappedCookie {
+ void *real_cookie;
I would call it WrappedFunopenCookie to be less generic, similarly for funopen2.
CHANGES SINCE LAST ACTION
lebedev.ri added a comment.
Differential lacks description.
Repository:
rC Clang
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D54408/new/
https://reviews.llvm.org/D54408
___
cfe-commits mailing list
cfe-commits@lists.llvm.org
http://list
steveire updated this revision to Diff 179725.
steveire added a comment.
Some updates
Repository:
rC Clang
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D54408/new/
https://reviews.llvm.org/D54408
Files:
lib/ASTMatchers/Dynamic/Registry.cpp
unittests/ASTMatchers/Dynamic/RegistryT
mgorny updated this revision to Diff 179723.
mgorny added a comment.
Fixed accidental whitespace change.
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D56158/new/
https://reviews.llvm.org/D56158
Files:
lib/sanitizer_common/sanitizer_common_interceptors.inc
lib/sanitizer_common/sanit
mgorny updated this revision to Diff 179722.
mgorny added a comment.
Implemented wrappers as requested.
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D56158/new/
https://reviews.llvm.org/D56158
Files:
lib/sanitizer_common/sanitizer_common_interceptors.inc
lib/sanitizer_common/saniti
kristina added a comment.
Seems good, it could eliminate the need for a lot of preprocessor checks like
`#if __gnu_linux__ && !defined(__ANDROID__)`. It doesn't seem that there are
any preprocessor checks where this would cause problems (from a quick search)
since all of them seem to focus on m
22 matches
Mail list logo