mstorsjo updated this revision to Diff 72988.
mstorsjo added a comment.
Implemented using `CreateAlignedStore` and `CreateAlignedLoad` instead.
I'm less confident in what this actually does though - e.g. is the
`CreateBitCast` part necessary at all? I just based this on code I found in the
same
Author: vleschuk
Date: Fri Sep 30 01:39:48 2016
New Revision: 282846
URL: http://llvm.org/viewvc/llvm-project?rev=282846&view=rev
Log:
Cosmetic fix: deleted unnecessary line break in comment.
Modified:
cfe/trunk/lib/CodeGen/CGDebugInfo.h
Modified: cfe/trunk/lib/CodeGen/CGDebugInfo.h
URL:
ht
zlei created this revision.
zlei added a reviewer: jcownie.
zlei added a subscriber: cfe-commits.
Function `strerror_r()` has different signatures in different implementations
of libc: glibc's version returns a `char*`, while BSDs and musl return a `int`.
libomp unconditionally assumes glibc on
mgorny added a comment.
@ismail, ping.
https://reviews.llvm.org/D24954
___
cfe-commits mailing list
cfe-commits@lists.llvm.org
http://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits
mgorny added a comment.
Side note: I see that gcc is solving similar problem via .spec files for its
libraries, e.g.:
$ cat /usr/lib/gcc/x86_64-pc-linux-gnu/5.4.0/libgomp.spec
# This spec file is read by gcc when linking. It is used to specify the
# standard libraries we need in order to
majnemer added inline comments.
> CGBuiltin.cpp:2597-2611
> +case ARM::BI__iso_volatile_load8:
> +case ARM::BI__iso_volatile_load16:
> +case ARM::BI__iso_volatile_load32:
> +case ARM::BI__iso_volatile_load64:
> + return RValue::get(EmitVolatileLoad(*this, E));
> +case ARM
I've switched the default email format to be plain text only now. This
option should be per-user configurable, but somehow it is not shown in the
"Settings"; I'll try if I can make the option personalized.
Regarding new features and bug fixes in this upgrade, I don't really have a
list since the P
One of the new “feature” is that emails are HTML only right now. Not quite nice
for the archive (or for interacting by email).
See for instance:
http://lists.llvm.org/pipermail/cfe-commits/Week-of-Mon-20160926/172081.html
(Also the funky "[Changed Subscribers] “ in the title)
Another issue is
It looks like the new phabricator sends html email by default.
I personally prefer text email. What do others think? Is this configurable in
the new installation?
Thanks,
-- Sanjoy
Zachary Turner via llvm-commits wrote:
You mentioned this was for an upgrade. Are there any major new features
mgehre updated this revision to Diff 72981.mgehre added a comment.
View RevisionAdd additional gsl::suppress spelling, add test, add documentationhttps://reviews.llvm.org/D24886Files:include/clang/Basic/Attr.td
include/clang/Basic/AttrDocs.td
lib/Sema/SemaDeclAttr.cpp
lib/Sema/SemaStmtAttr.cpp
test
majnemer added inline comments.
View RevisionView InlineSemaDeclCXX.cpp:8287-8290
NamespaceDecl *Sema::getStdExperimentalNamespace() const {
return cast_or_null(
StdExperimentalNamespace.get(Context.getExternalSource()));
}
Is this clang-format'd?https://reviews.
On Sep 29, 2016 8:23 PM, "Gor Nishanov" wrote:
>
> You beat me to it, Eric. :) I'll add mine for review, too. Let's see
which one Richard will respond :) .
>
> 1. Remove __has_feature
> 2. Rename fcoroutines => fcoroutines_TS
> 3. Rename __cpp_coroutines => __cpp_experimental_coroutines
The TS sp
Author: ioeric
Date: Thu Sep 29 23:32:39 2016
New Revision: 282837
URL: http://llvm.org/viewvc/llvm-project?rev=282837&view=rev
Log:
[change-namespace] fix namespace specifier of global variables.
Reviewers: hokein
Subscribers: cfe-commits
Differential Revision: https://reviews.llvm.org/D24963
This revision was automatically updated to reflect the committed changes.Closed by commit rL282837: [change-namespace] fix namespace specifier of global variables. (authored by ioeric).
View RevisionChanged prior to commit:https://reviews.llvm.org/D24963?vs=72648&id=72976#tocRepository:rL LLVMhttps
GorNishanov created this revision.GorNishanov added reviewers: EricWF, rsmith, cfe-commits.Herald added a subscriber: mehdi_amini.
View RevisionLook for coroutine_traits and friends in std::experimental namespace.
Patch (mostly) by EricWF.https://reviews.llvm.org/D25068Files:include/clang/Basic/Dia
You mentioned this was for an upgrade. Are there any major new features or
bugfixes to be aware of?
On Thu, Sep 29, 2016 at 9:26 PM Eric Liu via llvm-commits <
llvm-comm...@lists.llvm.org> wrote:
> Hi all,
>
> Phabricator is (finally) back online! Let me know if you have any feedback
> or problem
Hi all,
Phabricator is (finally) back online! Let me know if you have any feedback
or problem :)
Thanks,
Eric
On Thu, Sep 29, 2016 at 10:23 PM Eric Liu wrote:
> According to top and iotop, mysqld is still working, and the progress bar
> did move by a little bit, so I think it's just really slo
ioeric created this revision.ioeric added a reviewer: hokein.ioeric added a subscriber: cfe-commits.
View RevisionAlso test phabricator.https://reviews.llvm.org/D25065Files:change-namespace/ChangeNamespace.cpp
unittests/change-namespace/ChangeNamespaceTests.cppunittests/change-namespace/ChangeNames
ioeric added a comment.
View RevisionPhab test.https://reviews.llvm.org/D24963
___
cfe-commits mailing list
cfe-commits@lists.llvm.org
http://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits
You beat me to it, Eric. :) I'll add mine for review, too. Let's see which
one Richard will respond :) .
1. Remove __has_feature
2. Rename fcoroutines => fcoroutines_TS
3. Rename __cpp_coroutines => __cpp_experimental_coroutines
Since phabricator is down, here is a handy diff on a github
https://
+def fcoroutines : Flag <["-"], "fcoroutines-ts">, Group,
+ Flags<[DriverOption, CC1Option]>,
+ HelpText<"Enable support for the C++ Coroutines TS">;
+def fno_coroutines : Flag <["-"], "fno-coroutines-ts">, Group,
These should be named fcoroutines_ts, fno_coroutines_ts (see comment at the
top of
Author: jlebar
Date: Thu Sep 29 19:38:45 2016
New Revision: 282822
URL: http://llvm.org/viewvc/llvm-project?rev=282822&view=rev
Log:
Move UTF functions into namespace llvm.
Summary:
This lets people link against LLVM and their own version of the UTF
library.
I determined this only affects llvm,
Let's see if renaming the attachment to *.txt helps.
On Thu, Sep 29, 2016 at 5:42 PM, Gor Nishanov wrote:
> Currently the -fcoroutines flag is a CC1 only flag. It really should be
> both a Driver and CC1 flag. This patch fixes the option and adds tests for
> the new options.
>
> Also adds a __ha
Currently the -fcoroutines flag is a CC1 only flag. It really should be
both a Driver and CC1 flag. This patch fixes the option and adds tests for
the new options.
Also adds a __has_feature for coroutines.
Patch is mostly by Eric Fiselier
.
Meticulous and painstaking extraction from the larger cor
Author: rsmith
Date: Thu Sep 29 17:49:46 2016
New Revision: 282800
URL: http://llvm.org/viewvc/llvm-project?rev=282800&view=rev
Log:
P0035R4: add std::align_val_t overloads of operator new/delete in C++17 mode.
Added:
cfe/trunk/test/PCH/cxx1z-aligned-alloc.cpp
Modified:
cfe/trunk/include/
Author: ericwf
Date: Thu Sep 29 16:47:39 2016
New Revision: 282792
URL: http://llvm.org/viewvc/llvm-project?rev=282792&view=rev
Log:
[Coroutines] Fix assertion about uncorrected typos in
co_await/co_yield/co_return expressions
Modified:
cfe/trunk/lib/Sema/SemaCoroutine.cpp
cfe/trunk/test
Author: rsmith
Date: Thu Sep 29 16:30:12 2016
New Revision: 282777
URL: http://llvm.org/viewvc/llvm-project?rev=282777&view=rev
Log:
Switch to a different workaround for unimplementability of P0145R3 in MS ABIs.
Instead of ignoring the evaluation order rule, ignore the "destroy parameters
in rever
Author: dougk
Date: Thu Sep 29 14:59:12 2016
New Revision: 282757
URL: http://llvm.org/viewvc/llvm-project?rev=282757&view=rev
Log:
[Myriad] Silently ignore -fno-split-dwarf-inlining
Modified:
cfe/trunk/lib/Driver/Tools.cpp
cfe/trunk/test/Driver/myriad-toolchain.c
Modified: cfe/trunk/lib
Author: kcc
Date: Thu Sep 29 14:06:09 2016
New Revision: 282752
URL: http://llvm.org/viewvc/llvm-project?rev=282752&view=rev
Log:
[sanitizer-coverage] a bit more docs
Modified:
cfe/trunk/docs/SanitizerCoverage.rst
Modified: cfe/trunk/docs/SanitizerCoverage.rst
URL:
http://llvm.org/viewvc/ll
Author: kcc
Date: Thu Sep 29 13:58:17 2016
New Revision: 282751
URL: http://llvm.org/viewvc/llvm-project?rev=282751&view=rev
Log:
[sanitizer-coverage] more docs
Modified:
cfe/trunk/docs/SanitizerCoverage.rst
Modified: cfe/trunk/docs/SanitizerCoverage.rst
URL:
http://llvm.org/viewvc/llvm-pro
LGTM
On Wed, Sep 28, 2016 at 10:09 PM, Eric Fiselier wrote:
> EricWF created this revision.
> EricWF added reviewers: rsmith, GorNishanov.
> EricWF added a subscriber: cfe-commits.
> Herald added a subscriber: mehdi_amini.
>
> If there is an error finding the `coroutine_traits` template when bui
Author: kcc
Date: Thu Sep 29 13:34:40 2016
New Revision: 282749
URL: http://llvm.org/viewvc/llvm-project?rev=282749&view=rev
Log:
[sanitize-coverage] doc typo
Modified:
cfe/trunk/docs/SanitizerCoverage.rst
Modified: cfe/trunk/docs/SanitizerCoverage.rst
URL:
http://llvm.org/viewvc/llvm-proje
Author: kcc
Date: Thu Sep 29 12:43:24 2016
New Revision: 282735
URL: http://llvm.org/viewvc/llvm-project?rev=282735&view=rev
Log:
[sanitizer-coverage/libFuzzer] make the guards for trace-pc 32-bit; create one
array of guards per function, instead of one guard per BB. reorganize the code
so that
coby updated this revision to Diff 72961.
coby marked an inline comment as done.
coby added a comment.
Addressing comments:
Added a check for KNL as well
Repository:
rL LLVM
https://reviews.llvm.org/D25004
Files:
x86-inline-asm-v-constraint.c
Index: x86-inline-asm-v-constraint.c
=
Author: hiraditya
Date: Thu Sep 29 06:37:23 2016
New Revision: 282710
URL: http://llvm.org/viewvc/llvm-project?rev=282710&view=rev
Log:
Revert "[PR30341] Alias must point to a definition"
This reverts commit r282679.
Ninja check fails, reverting to debug the issue.
Removed:
cfe/trunk/test/C
hokein accepted this revision.
hokein added a comment.
This revision is now accepted and ready to land.
LGTM.
https://reviews.llvm.org/D24963
___
cfe-commits mailing list
cfe-commits@lists.llvm.org
http://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-
Author: ikudrin
Date: Thu Sep 29 03:11:57 2016
New Revision: 282703
URL: http://llvm.org/viewvc/llvm-project?rev=282703&view=rev
Log:
Revert r282692: Use fallback_malloc to allocate __cxa_eh_globals in case of
dynamic memory exhaustion.
The test breaks build bots.
Added:
libcxxabi/trunk/src
hokein updated this revision to Diff 72963.
hokein added a comment.
Correct the implementation of FixedCompilationDatabase::getCommonRoot.
https://reviews.llvm.org/D25027
Files:
include/clang/Tooling/CompilationDatabase.h
include/clang/Tooling/JSONCompilationDatabase.h
lib/Tooling/CommonO
Hahnfeld added a comment.
ping?
https://reviews.llvm.org/D22452
___
cfe-commits mailing list
cfe-commits@lists.llvm.org
http://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits
This revision was automatically updated to reflect the committed changes.
Closed by commit rL282701: XFAIL Driver/darwin-stdlib.cpp if
CLANG_DEFAULT_CXX_STDLIB is set (authored by Hahnfeld).
Changed prior to commit:
https://reviews.llvm.org/D24601?vs=72765&id=72960#toc
Repository:
rL LLVM
h
Author: hahnfeld
Date: Thu Sep 29 02:43:08 2016
New Revision: 282701
URL: http://llvm.org/viewvc/llvm-project?rev=282701&view=rev
Log:
XFAIL Driver/darwin-stdlib.cpp if CLANG_DEFAULT_CXX_STDLIB is set
Until someone rewrites the stdlib logic for Darwin so that we don't need
to pass down the -stdli
41 matches
Mail list logo