Hello!
Justus Winter <4win...@informatik.uni-hamburg.de> skribis:
> Quoting Samuel Thibault (2013-09-09 10:04:55)
[...]
>> > Also, according to [0] Debian/Hurd is the only "working" Hurd
>> > distribution (whatever that means, let's say not in "early stages of
>> > development" and not "defunct
A variable that keeps track if the console init has been called. It should
never receive values other than 0 and 1, so constrain it's possible range of
values to a boolean.
* device/cons.c (cn_inited): Use boolean_t instead of an int.
---
device/cons.c | 4 ++--
1 file changed, 2 insertions(+),
A variable that keeps track of the console buffer usage should never receive
values other than 0 and 1, so constrain it's value range to boolean. Plus, it's
more readable this way.
* device/cons.c (consbufused): Use boolean_t instead of an int.
---
device/cons.c | 8
1 file changed, 4
Function cnputc() should never modify it's argument so qualify it
with a const keyword.
* device/cons.c (cnputc): Qualify argument as const.
* device/cons.h (cnputc): Likewise.
---
device/cons.c | 2 +-
device/cons.h | 2 +-
2 files changed, 2 insertions(+), 2 deletions(-)
diff --git a/device/c
CONSMAJOR is never used. I'm guessing that in the past it was
a part of some problematic code. I don't see a reason to keep
it's definition.
* device/cons.h (CONSMAJOR): Remove definition.
---
device/cons.h | 3 ---
1 file changed, 3 deletions(-)
diff --git a/device/cons.h b/device/cons.h
inde
What follows is a small cleanup of the console code.
[PATCH 1/5] drop unused CONSMAJOR
[PATCH 2/5] track the console buffer usage with a boolean instead of an int
[PATCH 3/5] track the console init with a boolean instead of an int
[PATCH 4/5] qualify constant with the const
[PATCH 5/5] remove hyp_
Please comment on this removal.
The check 'defined(MACH_HYP) && 0' never evaluates to TRUE, so
I'm guessing this was a way to comment out this code. I don't
see hyp_console_write() anywhere defined except in xen, so there
should be some checking for that too. Plus, the call itself look like
it ne
Quoting Ludovic =?utf-8?Q?Court=C3=A8s?= (2013-09-10 20:00:32)
> Justus Winter <4win...@informatik.uni-hamburg.de> skribis:
>
> > Quoting Samuel Thibault (2013-09-09 19:40:23)
> >> Ludovic Courtès, le Mon 09 Sep 2013 18:48:03 +0200, a écrit :
> >> > Samuel Thibault skribis:
> >> > > Ludovic Court
Marin Ramesa, le Wed 11 Sep 2013 12:27:51 +0200, a écrit :
> The check 'defined(MACH_HYP) && 0' never evaluates to TRUE, so
> I'm guessing this was a way to comment out this code.
Yes. This is meant to be used for whoever would need to debug very
early initialization of Mach as a Xen domU.
Samue
Marin Ramesa, le Wed 11 Sep 2013 12:27:46 +0200, a écrit :
> [PATCH 1/5] drop unused CONSMAJOR
> [PATCH 2/5] track the console buffer usage with a boolean instead of an int
> [PATCH 3/5] track the console init with a boolean instead of an int
Applied these, thanks.
Samuel
Marin Ramesa, le Wed 11 Sep 2013 12:27:50 +0200, a écrit :
> Function cnputc() should never modify it's argument so qualify it
> with a const keyword.
>
> void
> cnputc(c)
> - char c;
> + const char c;
Well, this is not really useful: the function gets a copy of the
argument anyway.
Sa
Justus Winter <4win...@informatik.uni-hamburg.de> skribis:
> Quoting Ludovic =?utf-8?Q?Court=C3=A8s?= (2013-09-10 20:00:32)
>> Justus Winter <4win...@informatik.uni-hamburg.de> skribis:
>>
>> > Quoting Samuel Thibault (2013-09-09 19:40:23)
>> >> Ludovic Courtès, le Mon 09 Sep 2013 18:48:03 +0200,
Marin Ramesa, le Tue 10 Sep 2013 10:38:05 +0200, a écrit :
> * device/cirbuf.c: Remove register qualifiers.
Applied, thanks.
Samuel
Ludovic Courtès, le Wed 11 Sep 2013 19:59:24 +0200, a écrit :
> In the case we discuss here, the semantics of ‘task_create’ would be
> preserved.
>
> There’s surely a performance impact, that would have to be measured.
> Now, how bad is it compared to, say, calling user-space ethernet drivers
> vs
Marin Ramesa, le Tue 10 Sep 2013 10:38:04 +0200, a écrit :
> #if DEBUG
> -int cb_check_enable = 0;
> +const int cb_check_enable = 0;
I'd rather not.
It is useful to be able to modify the value "live" from the debugger, so
as to enable the check only for some time while debugging.
> #define
On Mon, Sep 09, 2013 at 09:45:18AM +0200, Samuel Thibault wrote:
> Ludovic Courtès, le Sat 07 Sep 2013 22:04:06 +0200, a écrit :
> > However, wouldn’t it be preferable to fix it by interposing on
> > ‘task_create’ calls, à la clans & chiefs? (IIUC, this can be done with
> > by setting the TASK_KER
Hi,
On Sat, Sep 7, 2013 at 2:53 AM, Pedro Alves wrote:
> This is what I meant:
> https://sourceware.org/ml/gdb-patches/2013-09/msg00253.html
>
> I was thinking you'd wrap gnu_xfer_memory.
>
I have study your patch, but I found there is no to_xfer_partial field
or something similar in gdbserver's
Hi,
this improves on my previous patch. Before a new master_device port
is created the old port is deallocated to prevent a port leak. None
of this happens when master_file (naming the device node) is
undefined.
This patch has been tested on Debian GNU/Hurd. With this patch,
killing netdde no
---
pfinet/ethernet.c | 17 +++--
1 file changed, 15 insertions(+), 2 deletions(-)
diff --git a/pfinet/ethernet.c b/pfinet/ethernet.c
index b96c09a..f9fadf1 100644
--- a/pfinet/ethernet.c
+++ b/pfinet/ethernet.c
@@ -241,11 +241,24 @@ ethernet_open (struct device *dev)
int
ethernet_x
A fresh `master_device' port is now obtained when accessing the device
file, not only on translator startup. This ensures that the device
can be re-opened after netdde has died.
---
devnode/devnode.c | 10 ++
1 file changed, 10 insertions(+)
diff --git a/devnode/devnode.c b/devnode/devno
Richard Braun, le Thu 12 Sep 2013 01:57:10 +0200, a écrit :
> On Mon, Sep 09, 2013 at 09:45:18AM +0200, Samuel Thibault wrote:
> > Ludovic Courtès, le Sat 07 Sep 2013 22:04:06 +0200, a écrit :
> > > However, wouldn’t it be preferable to fix it by interposing on
> > > ‘task_create’ calls, à la clans
21 matches
Mail list logo