[Bug hurd/19903] New: Shared mappings not being inherited by children processes

2016-04-03 Thread avarzille at riseup dot net
https://sourceware.org/bugzilla/show_bug.cgi?id=19903 Bug ID: 19903 Summary: Shared mappings not being inherited by children processes Product: glibc Version: unspecified Status: NEW Severity: normal P

Re: Shared mappings not being inherited by children

2016-04-03 Thread Agustina Arzille
On 04/03/2016 06:27 AM, Samuel Thibault wrote: So the fix would be just to remove the whole if ((flags & (MAP_TYPE|MAP_INHERIT)) == MAP_ANON block? Yes, that seems do the trick. You can submit that patch to the libc-al...@sourceware.org mailing list (explaining the rationale etc. alongsid

[PATCH] Turn mach_msg_type_{name,size}_t into unsigned chars.

2016-04-03 Thread Flavio Cruz
mach_msg_type_name_t and mach_msg_type_size_t are used as 8 bit fields in mach_msg_type_t struct, therefore they should be treated as unsigned char's to avoid warnings when using macros such as MACH_MSG_TYPE_POLYMORPIC. * include/mach/message.h: Update typedef. * include/mach/std_types.defs: Chang

[PATCH] Fix use of stringize in lexxer.l

2016-04-03 Thread Flavio Cruz
The fields instr and outstr should be set to a string and not to the stringified number represented by the string. This improves the readability of mig stubs code that creates mach_msg_type_t values for messages. * lexxer.l: Inline stringize in TPRETURN and TRETURN. --- lexxer.l | 16 +++-

Re: [PATCH] Use uint32_t instead of unsigned32_t.

2016-04-03 Thread Flávio Cruz
ping On 30 March 2016 at 02:26, Flavio Cruz wrote: > Implement stdint.h and use it in gnumach. > > Remove old type definitions such as signed* and unsigned*. > > * Makefile.am: Add -ffreestanding. > * i386/i386/xen.h: Use uint64_t. > * i386/include/mach/i386/machine_types.defs: Use uint32_t and

Re: Shared mappings not being inherited by children

2016-04-03 Thread Samuel Thibault
Richard Braun, on Sat 02 Apr 2016 20:55:58 +0200, wrote: > On Sat, Apr 02, 2016 at 01:35:49PM -0300, Agustina Arzille wrote: > > As a workaround, we could always use 'vm_map', no matter what, since the > > idea that 'vm_allocate' has a little less overhead is somewhat bogus to me, > > or > > keep

Re: [PATCH] Use word_size instead of 4.

2016-04-03 Thread Samuel Thibault
Flavio Cruz, on Sun 03 Apr 2016 02:27:23 +0200, wrote: > * server.c: Use word_size and update comments. > * type.c: Use word_size to compute padding. > * user.c: Use word_size and update comments. Applied, thanks! Samuel