configure output from largefile.m4

2024-06-16 Thread Bruno Haible
Hi Paul, In a configure output I see: checking for -I/Users/runner/include -I/usr/local/opt/libiconv/include -Wall -DCONTINUE_AFTER_ASSERT option for large files... none needed checking for -I/Users/runner/include -I/usr/local/opt/libiconv/include -Wall -DCONTINUE_AFTER_ASSERT option for ti

[PATCH 0/7] avoiding tzname usage in Gnulib code

2024-06-16 Thread Paul Eggert
tzname is problematic, because (as now mentioned in the Gnulib manual) it's unsafe in multithreaded code and its contents are typically unspecified even in single-threaded code. These patches rework the Gnulib code so that no other module depends on tzname. Paul Eggert (7): nstrftime: rename HA

[PATCH 4/7] time_r: refactor tm_zone tests

2024-06-16 Thread Paul Eggert
* m4/tm_gmtoff.m4 (gl_TM_GMTOFF): Also check for tm_zone and define HAVE_STRUCT_TM_TM_ZONE accordingly. * modules/time_r-tests (Files): Add m4/tm_gmtoff.m4. (configure.ac): Simplify by using gl_TM_GMTOFF. --- ChangeLog| 6 ++ m4/tm_gmtoff.m4 | 13 +++-- modules/time_r

[PATCH 5/7] parse-datetime: don’t depend on tzname

2024-06-16 Thread Paul Eggert
* lib/parse-datetime.y (TIME_ZONE_BUFSIZE): Move earlier. (parser_control) [!HAVE_STRUCT_TM_TM_ZONE]: New member tz_abbr, to save abbrs calculated by strftime %Z. (populate_local_time_zone_table): New function, which optimizes the HAVE_STRUCT_TM_TM_ZONE case as before, and falls back on strftime wi

[PATCH 6/7] nstrftime, time_rz: don’t depend on tzname

2024-06-16 Thread Paul Eggert
* lib/strftime.c (HAVE_TZNAME_ARRAY) [_LIBC]: Remove. All uses removed. (__strftime_internal): Simplify calculation of zone to be closer to what glibc does. However, in Gnulib do not look at tzname as this is problematic for all the usual reasons; instead, use the underlying strftime with %Z, maki

[PATCH 2/7] time_r-tests: avoid tzname test

2024-06-16 Thread Paul Eggert
* modules/time_r-tests (configure.ac): Do not check for tzname, as the tests don’t use it. Simply check for struct tm.tm_zone. --- ChangeLog| 5 + modules/time_r-tests | 7 +++ 2 files changed, 8 insertions(+), 4 deletions(-) diff --git a/ChangeLog b/ChangeLog index ebdd04567f

[PATCH 3/7] time: document struct tm portability

2024-06-16 Thread Paul Eggert
* doc/posix-headers/time.texi: Mention issues with tm_gmtoff, tm_zone, tzname, etc. --- doc/posix-headers/time.texi | 15 +++ 1 file changed, 15 insertions(+) diff --git a/doc/posix-headers/time.texi b/doc/posix-headers/time.texi index e7304cbd1a..26587d4c6a 100644 --- a/doc/posix-hea

[PATCH] Fix typos in ChangeLog and getpagesize.texi

2024-06-16 Thread Paul Eggert
--- ChangeLog| 2 +- doc/glibc-functions/getpagesize.texi | 2 +- 2 files changed, 2 insertions(+), 2 deletions(-) diff --git a/ChangeLog b/ChangeLog index c07a4b757a..3f5d7454fb 100644 --- a/ChangeLog +++ b/ChangeLog @@ -58,7 +58,7 @@ xsize: port to SIZE_MAX <

[PATCH 7/7] nstrftime: omit never-used code

2024-06-16 Thread Paul Eggert
* lib/strftime.c (__strftime_internal): Remove code protected by ‘#ifndef my_strftime’. my_strftime is always defined. This code isn’t needed for POSIX conformance as it’s never used in glibc. --- ChangeLog | 6 ++ lib/strftime.c | 10 -- 2 files changed, 6 insertions(+), 10 de

[PATCH 1/7] nstrftime: rename HAVE_TM_GMTOFF

2024-06-16 Thread Paul Eggert
* m4/tm_gmtoff.m4 (gl_TM_GMTOFF): Rename HAVE_TM_GMTOFF to HAVE_STRUCT_TM_TM_GMTOFF, for consistency with HAVE_STRUCT_TM_TM_ZONE. All uses changed. --- ChangeLog | 7 +++ lib/parse-datetime.y| 8 lib/strftime.c | 8 lib/strptime.c

Re: new module 'tzname', tm_zone and tm_gmtoff

2024-06-16 Thread Paul Eggert
On 2024-06-06 14:30, Bruno Haible wrote: OK. But how about the Linux man-pages? *https://man7.org/linux/man-pages/man3/tzset.3p.html is derived from POSIX and will be updated forPOSIX:2024, but POSIX:2024 (p. 2310-2311) does not warn against these 3 variables. *https://man7.org

Re: new module 'tzname', tm_zone and tm_gmtoff

2024-06-16 Thread Paul Eggert
On 2024-06-06 17:03, Bruno Haible wrote: Paul Eggert wrote: tzname is used in three places: - time_rz, This should be fixed to use strftime instead. This seems wrong for two reasons: * time_rz is a small module, without textual I/O. Fair enough, and the changes I recently installed

[PATCH] useless-if-before-free: Check for nullptr.

2024-06-16 Thread Collin Funk
* build-aux/useless-if-before-free (is_NULL): Add nullptr to the condition. (foo): Add nullptr to the regular expressions. --- ChangeLog| 7 +++ build-aux/useless-if-before-free | 8 2 files changed, 11 insertions(+), 4 deletions(-) diff --git a/ChangeLog b/Ch

Re: [PATCH] useless-if-before-free: Check for nullptr.

2024-06-16 Thread Collin Funk
Collin Funk wrote: > -my $VERSION = '2022-01-27 18:51'; # UTC > +my $VERSION = '2024-06-17 03:44'; # UTC What is the point of time stamping the file? Reminds me of the old SCCSID and RCSID stuff (which I have never used). I mention it because in my emacs init file: (setq enable-local-variabl