Re: fix inadequate Windows implementation of tmpfile

2007-02-17 Thread Bruno Haible
Paul Eggert wrote: > I think gnulib is for porting GNU applications, and if GNU > applications assume glibc behavior for a function then it's OK to > replace a vendor's function that behaves differrently. OK. So I'm adding Ben's module, with the following modifications: * tmpfile.c: - Don't

Re: fix inadequate Windows implementation of tmpfile

2007-02-17 Thread Ben Pfaff
Bruno Haible <[EMAIL PROTECTED]> writes: > Paul Eggert wrote: >> I think gnulib is for porting GNU applications, and if GNU >> applications assume glibc behavior for a function then it's OK to >> replace a vendor's function that behaves differrently. > > OK. So I'm adding Ben's module, with the fo

string_.h: break lines

2007-02-17 Thread Bruno Haible
This introduces some line breaking in the source, for the GL_LINK_WARNING arguments. Functionally a nop. 2007-02-17 Bruno Haible <[EMAIL PROTECTED]> * lib/string_.h (memmem, mempcpy, memrchr, stpcpy, stpncpy, strcasecmp, strncasecmp, strchr, strchrnul, strdup, strndup, strnlen,

Re: portability checks, errors and warnings

2007-02-17 Thread Bruno Haible
Paul Eggert wrote on 2007-02-05: > > he will get a link error about function 'rpl_strstr', and will likely > > report it as a bug in gnulib. > > I don't think this will be much of a problem in practice. We can > assume maintainers will read the gnulib documentation so that they > know w

new module 'link-warning'

2007-02-17 Thread Bruno Haible
The GL_LINK_WARNING macro will also be needed in all other header file overrides like . In order not to duplicate the code, I'm putting it into a separate module 'link-warning'. The file link-warning.h would go into lib/ if our generated could simply #include it. But we want the generated to be

string_h.m4 simplification

2007-02-17 Thread Bruno Haible
This patch merges gl_HEADER_STRING_H_DEFAULTS and gl_STRING_MODULE_INDICATOR_DEFAULTS into a single macro. Since both initialize a part of the variables needed to create string.h, and the other part is needed as well for the same purpose, it's hard to imagine a situation where one of the two is nee

add link warnings to inttypes.h

2007-02-17 Thread Bruno Haible
This patch adds link warnings (conditional, only if GNULIB_POSIXCHECK is defined) to inttypes.h. A side effect is that the 'inttypes' module will create inttypes.h always - like the 'string' module creates string.h always. 2007-02-17 Bruno Haible <[EMAIL PROTECTED]> * lib/inttypes_.h:

new test modules

2007-02-17 Thread Bruno Haible
Hi, I added minimal tests for the modules arpa_inet byteswap fcntl inttypes netinet_in stdbool string sys_select sys_socket sys_stat sys_time sysexits time unistd wchar wctype Just to check that the include file that it defines can really be included. Feel free t

conflicts between pathname.h and dirname.h

2007-02-17 Thread Ben Pfaff
pathname.h and dirname.h define macros with the same names, but conflicting definitions. Should they be merged? -- Ben Pfaff [EMAIL PROTECTED] http://benpfaff.org