Hello!
It seems that the AC_LIB_FROMPACKAGE macro from the havelib module can
be used at most twice for a given package name. The following works:
AC_INIT([foobar], [0.1], [t...@example.com])
AC_CONFIG_MACRO_DIR([.])
AC_LIB_FROMPACKAGE([a], [libfoo])
AC_LIB_FROMPACKAGE([b], [libfoo])
But when I
Hello everyone,
the havelib module cannot handle library names that contain the '+'
character, such as libGraphicsMagick++.so.
The attached patch fixes this for me, but I'm not sure if any special
quoting or escaping of '+' is necessary.
Martin
diff --git a/m4/lib-link.m4 b/m4/lib-link.m4
i
On Tue, 23. Feb 2010, 10:22:42 +0100, Jim Meyering wrote:
> You're all set:
> I've relaxed its license to "unlimited".
Thank you!
Martin
Hi,
the license of lib-ignore is listed as 'GPL'. Is this intended?
The module consists only of lib-ignore.m4, and that file carries an
'unlimited' license note, like most other m4 files. Also, gnulib-tool
does not replace that with a GPL note when copying the file.
Martin
On Thu, 26. Nov 2009, 10:43:07 +0100, Bruno Haible wrote:
> Other updates that would be interesting - does someone of you have access to
> such a machine?
> - NetBSD 5.0
Sent privately.
On Sun, 02. Aug 2009, 12:04:53 +0200, Bruno Haible wrote:
> Simon Josefsson wrote:
> > Avoiding -lws2_32 is good, but if the application links to -lws2_32
> > anyway, there will be no saving.
> > [...]
>
> [...]
> I'm now convinced that linking with -lws2_32 is the least evil.
> I have applied you
On Tue, 28. Jul 2009, 23:18:09 +0200, Simon Josefsson wrote:
> OTOH, I haven't tested whether my old patch still works. Martin, have
> you?
It applied cleanly (except for the ChangeLog entry) and I tested it on
Debian lenny and with a MinGW cross compiler. This time I built from
scratch, to avoid
Hello again,
I just noticed that this problem was already found and fixed by Simon in
March: http://www.mail-archive.com/bug-gnulib@gnu.org/msg13671.html
There was some discussion about the right approach, but no decision was
made.
Bruno, Simon, would you please reconsider applying the patch? Wi
On Tue, Jul 28, 2009 at 10:08:34AM +0200, Martin Lambers wrote:
> The following patch fixes this for me.
Sorry, this is not true (I forgot to 'make clean' and did not see this
earlier). The unistd.h header from gnulib defines gethostname to
rpl_gethostname, but no such function is a
Hello everybody,
W32 has gethostname in ws2_32.dll. This is not detected by
gethostname.m4, and gethostname is inadvertently replaced by a function
that always returns an empty string.
The following patch fixes this for me. It works on Debian and with a
MinGW cross compiler. I tried to change get
Hi,
a user reported a bug in the MinGW version of mpop. After narrowing the
problem down, it seems that after 'fseek(f, 0, SEEK_SET)' is called for
a file 'f' that was opened in mode "r+", subsequent attempts to write to
'f' (e.g. with fprintf) will fail on MinGW when the gnulib fseek module
is in
On Tue, 03. Feb 2009, 12:37:48 +0100, Simon Josefsson wrote:
> >> > Simon, Paolo, do you have any comments on the patches suggested in this
> >> > thread?
> >>
> >> I didn't see anything wrong -- on the contrary. If you resend it, I'll
> >> apply it.
> >
> > OK, I resend the part that I wrote (pr
On Mon, 02. Feb 2009, 22:27:03 +0100, Paolo Bonzini wrote:
> > Simon, Paolo, do you have any comments on the patches suggested in this
> > thread?
>
> I didn't see anything wrong -- on the contrary. If you resend it, I'll
> apply it.
OK, I resend the part that I wrote (provide POSIX semantics fo
On Fri, 26. Dec 2008, 01:35:46 +0100, Bruno Haible wrote:
> > Here's an updated
> > patch. I used memcpy() because POSIX requires silent truncation of the
> > option value in case optlen is smaller than necessary.
>
> Looks all fine to me, but it's Simon and Paolo who have to decide on this.
>
>
Hello Eric!
On Mon, 19. Jan 2009, 05:57:14 -0700, Eric Blake wrote:
> > The minimal test is probably to
> > - create one file,
> > - use link() to create a new name for it,
>
> Or print a message and return 77, to skip the test, if the current fs
> doesn't support links at this point (such as
Hello Bruno,
On Sun, 18. Jan 2009, 19:42:11 +0100, Bruno Haible wrote:
> Can you please also provide a unit test for this module?
> The minimal test is probably to
> - create one file,
> - use link() to create a new name for it,
> - then verify that the contents is the same,
> - then modif
On Sun, 18. Jan 2009, 19:33:50 +0100, Bruno Haible wrote:
> Your patch looks quite fine. I have applied it with this ChangeLog entry
Thank you.
> - Don't initialize GNULIB_UNLINK or HAVE_UNLINK - this is unrelated.
Sorry, this was a leftover of an unrelated patch.
> - In the module descript
I'd like to suggest a new module 'link' that provides the link(2)
function for MinGW. The module is modelled after the existing fsync
module.
Martin
---
lib/link.c | 83 +++
lib/unistd.in.h | 17 +++
m4/link.m4 | 19
Hello Bruno!
On Thu, 25. Dec 2008, 20:59:03 +0100, Bruno Haible wrote:
> What about getsockopt()? I would guess it needs to do the opposite
> conversion, no?
Yes of course, I forgot that because I did not use it. Here's an updated
patch. I used memcpy() because POSIX requires silent truncation of
Hi!
Today I updated gnulib for msmtp and subsequently added the
socket-related modules for W32 portability. This allowed me to remove
430 lines of workarounds in the networking code, most of them
W32-specific. Thanks a lot!
However, I had to introduce one new workaround: if a socket is given to
so
Hi,
the getpass-gnu module should depend on the fseeko module, just like the
getpass module does.
Martin
diff --git a/modules/getpass-gnu b/modules/getpass-gnu
index af493f9..92e2d79 100644
--- a/modules/getpass-gnu
+++ b/modules/getpass-gnu
@@ -7,6 +7,7 @@ lib/getpass.c
m4/getpass.m4
Depe
Bruno Haible wrote:
> > Do you want to replace the getpagesize function from libgcc.a on MinGW
> > with the implementation above? Or do you want the implementation above
> > only for native Windows variants that don't have getpagesize?
>
> The former. The function from libgcc.a is maybe not correct
Jeremy C. Reed received the following bug report about building
mpop-1.0.12 on DragonFly 1.8.0.
This version of mpop uses current gnulib files from 2007-11-27.
> Here is the error when attempting to build base64.o:
>
> In file included from /usr/include/wchar.h:73,
> from ./std
On Tue, 04. Dec 2007, 09:45:02 +0100, Bruno Haible wrote:
> > > The implementation that you gave in your previous patch
> > >
> > > #if (defined _WIN32 || defined __WIN32__) && ! defined __CYGWIN__
> > >SYSTEM_INFO system_info;
> > >GetSystemInfo (&system_info);
> > >return system_inf
On Mon, Dec 03, 2007 at 12:39:15PM +0100, Bruno Haible wrote:
> > MinGW has a getpagesize() function, but does not declare it.
>
> Strange. The mingw system I have access to does not have a getpagesize()
> function. In yours, in which library is it defined? And what is your mingw
> system? MSYS, C
On Tue, 27. Nov 2007, 18:38:13 +0100, Bruno Haible wrote:
> Martin Lambers wrote:
> > If a macro is used instead, should its definition go into
> > lib/unistd.h.in directly, or should it stay in a separate
> > lib/getpagesize.h, which is then included in lib/unistd.h.in?
>
On Tue, Nov 27, 2007 at 02:05:06PM +0100, Bruno Haible wrote:
> > - Provide a getpagesize function (not a macro) if the system does not
> > have one.
>
> What is the point of doing that? A function that in most cases just returns
> a fixed number can well be inlined. And since 'inline' is a bit
Hi everyone,
MinGW has a getpagesize() function, but does not declare it.
I attached a patch for the getpagesize module. It does the following:
- Don't provide a getpagesize.h header. Modify gnulibs unistd.h
instead.
- Provide a getpagesize declaration if the system does not provide one.
- Pro
On Tue, 22. Aug 2006, 20:43:38 +, Roman Bogorodskiy wrote:
> > > Roman Bogorodskiy reported that xvasprintf.c fails to compile on FreeBSD
> > > 4.x, and that the patch below fixes that. He can give more details if
> > > necessary. Apparently, FreeBSD does not have va_copy(). This should be
> >
On Mon, 21. Aug 2006, 20:15:41 +0200, Bruno Haible wrote:
> Martin Lambers wrote:
> > Currently, 'make install' in the gnulib directory of my projects always
> > creates the directory $(pkgdatadir) (/usr/local/share/ by
> > default), even if it is empty.
> >
Hi!
Roman Bogorodskiy reported that xvasprintf.c fails to compile on FreeBSD
4.x, and that the patch below fixes that. He can give more details if
necessary. Apparently, FreeBSD does not have va_copy(). This should be
catched by stdarg.m4, right?
Regards,
Martin
--- gnulib/xvasprintf.c.orig
Hi!
Currently, 'make install' in the gnulib directory of my projects always
creates the directory $(pkgdatadir) (/usr/local/share/ by
default), even if it is empty.
If I remove the initialization of pkgdata_DATA in Makefile.am, the
directory is not created.
No module that I use modifies the pkgd
On Tue, 04. Jul 2006, 18:31:21 +0200, Bruno Haible wrote:
> Martin Lambers wrote:
> > gnulib/m4/strndup.m4 checks for a deficient strndup() function. When
> > crosscompiling, it assumes that strndup() is broken if the target is AIX
> > and that it is ok otherwise.
>
Hi!
gnulib/m4/strndup.m4 checks for a deficient strndup() function. When
crosscompiling, it assumes that strndup() is broken if the target is AIX
and that it is ok otherwise.
This fails when crosscompiling to a target that has no strndup()
function at all, such as MinGW: HAVE_STRNDUP will wrongl
Now that we have a sys_select module, I'd like to propose the patch from
my previous mail again (make the nanosleep module use the sys_select
module). This would allow to use nanosleep on MinGW.
Martin
On Wed, 07. Jun 2006, 14:31:34 +0200, Simon Josefsson wrote:
> > Is there any interest in this module?
>
> Yes. I think it looks good. Unless someone objects soonish, I think
> we should install it.
I integrated the lates changes to the sys_socket module.
I also filled in Simon as the maintaine
On Thu, 25. May 2006, 21:16:03 +0200, Martin Lambers wrote:
> This new version of the patch tests HAVE__FTIME first, so that on native
> W32 platforms
> void _ftime (struct _timeb *timeptr);
> is used instead of
> void ftime (struct timeb *timeptr); .
Is there any interest i
On Tue, 23. May 2006, 22:18:23 +0200, Martin Lambers wrote:
> On Tue, 23. May 2006, 00:25:11 -0700, Paul Eggert wrote:
> > In that case, it may be best for gnulib to generate a substitute
> > file that does the right thing under Microsoft Windows
> > (or indeed, any platfor
On Tue, 23. May 2006, 22:21:15 +0200, Martin Lambers wrote:
> With the new sys_select module and the attached changes to the nanosleep
> module, my project compiles and links fine when crosscompiled using the
> mingw package.
I forgot to add the new file nanosleep.h to AC_LIBSOURCES. H
On Tue, 23. May 2006, 21:44:20 +0200, Martin Lambers wrote:
> OK, I added a version for ftime().
Sorry, this version has a problem:
Newer versions of MinGW not only have
void _ftime (struct _timeb *timeptr);
but also
void ftime (struct timeb *timeptr); .
Thus both HAVE_FTIME and HAVE__FTIME
-#if !defined _WIN32
+#if !((defined _WIN32 || defined __WIN32__) && !defined __CYGWIN__)
#include
@@ -170,13 +170,17 @@
return buf;
}
-#else /* WIN32 */
+#else /* W32 native */
/* Windows implementation by Martin Lambers <[EMAIL PROTECTED]>,
improved by Simon Jose
With the new sys_select module and the attached changes to the nanosleep
module, my project compiles and links fine when crosscompiled using the
mingw package.
Martin
diff -uNr gnulib/lib/nanosleep.c gnulib-sys_select_h/lib/nanosleep.c
--- gnulib/lib/nanosleep.c 2006-05-20 21:22:15.
On Tue, 23. May 2006, 00:25:11 -0700, Paul Eggert wrote:
> In that case, it may be best for gnulib to generate a substitute
> file that does the right thing under Microsoft Windows
> (or indeed, any platform that lacks ). That way, gnulib
> modules like nanosleep can simply "#include "
> uncondit
On Tue, 23. May 2006, 14:32:14 +0200, Bruno Haible wrote:
> Similar things should be done for systems that have no gettimeofday()
> but do have an 'ftime' function and 'struct timeb' declared in
> . (Old SysVR2 or SysVR3 systems. Microsoft did not invent this
> interface; they only prepended the un
On Sun, 09. Oct 2005, 08:56:50 +0200, Ralf Wildenhues wrote:
> If I may, a couple of comments on the code:
Thanks! I'm sorry that it took me so long to respond to this.
(The original thread is archived here:
http://www.mail-archive.com/bug-gnulib%40gnu.org/msg00823.html )
I updated the patch acc
On Sun, 21. May 2006, 21:27:15 -0700, Paul Eggert wrote:
> > No, unfortunately it does not, because the target system does not have a
> > nanosleep function.
>
> OK. Do the other parts of the patch (e.g., the HAVE_SYS_SELECT_H,
> TIME_WITH_SYS_TIME, etc.) address the problem? If not, what proble
On Fri, 19. May 2006, 11:01:49 -0700, Paul Eggert wrote:
> There's one other thing about this particular problem that may save us
> here, though. The current code tests that nanosleep works at runtime,
> not merely whether it links. I suspect this is overkill, at least
> nowadays. And, since the
On Thu, May 18, 2006 at 10:23:49PM +0200, Bruno Haible wrote:
> > +#ifdef _WIN32
>
> The conditional for Woe32 platforms, excluding Cygwin (which has normal Unix
> API),
> is
>#if (defined _WIN32 || defined __WIN32__) && !defined __CYGWIN__
Sorry, I somehow missed your mail about Cygwin defi
Hi,
I get the following error when using the nanosleep module and
crosscompiling to W32 with the Debian mingw32 package and
./configure --host=i586-mingw32msvc :
../gnulib/libgnu.a(nanosleep.o):nanosleep.c:(.text+0x64): undefined reference
to `_select'
The attached patch fixes this for me.
Re
On Tue, 07. Mar 2006, 14:30:52 +0100, Simon Josefsson wrote:
> diff -N modules/unistd
> --- /dev/null 1 Jan 1970 00:00:00 -
> +++ modules/unistd7 Mar 2006 13:30:18 -
> @@ -0,0 +1,31 @@
> +Description:
> +A for systems lacking it.
> +
> +Files:
> +lib/unistd_.h
> +m4/unistd_h.m4
> +
> +
Thanks for your comments. I tried to follow them and updated the patch.
The tests (good gettimeofday, bad gettimeofday, no gettimeofday) still
work.
I have one question, though:
> where this code is removed from AC_FUNC_GETTIMEOFDAY_CLOBBER:
>
> if test $jm_cv_func_gettimeofday_clobber = yes;
Since the future of the exit module is still unclear (at least to me),
and sysexits.h still does not define EX_OK, I'd like to bring this issue
up again.
I would prefer to define EX_OK to 0 for the following reasons:
1. Simplicity
2. This value is explicitly mentioned in the sysexits man page ("Th
On Fri, 02. Sep 2005, 12:11:37 -0700, Paul Eggert wrote:
> You don't need to check whether tp is NULL. Gettimeofday can assume
> its first arg is NULL.
>
> Assuming we can resolve the copyright issues it otherwise looks good to me.
> (Though I can't comment on the Microsoft Windows stuff.)
The p
Hi!
I think the size_max module misses the Makefile.am entry
"lib_SOURCES += size_max.h":
$ ./gnulib-tool --create-testdir --dir=/tmp/t size_max
$ cd /tmp/t
$ ./configure
$ make dist
The resulting tarball does not contain size_max.h.
The following patch fixes this:
--- modules/size_max.orig
On Fri, 02. Sep 2005, 12:11:37 -0700, Paul Eggert wrote:
> Hmm, I suspect that it's enough extra work that we'll need papers from
> you. Would you be willing to assign the copyright to the Free Software
> Foundation, so that we could install it in gnulib?
Yes.
> You don't need to check whether
On Fri, 02. Sep 2005, 08:31:26 +0200, Martin Lambers wrote:
> The second patch makes the gettime module use gettimeofday
> unconditionally. It depended on the gettimeofday module before, and
> this small change
> - simplifies the code
> - improves gettime time resolution
On Thu, 25. Aug 2005, 19:36:23 +0200, Jim Meyering wrote:
> Paul Eggert <[EMAIL PROTECTED]> wrote:
> > I suspect that he'll say it's OK with him as long as it's no real work
> > for him.
>
> That's accurate :)
Then I'd like to propose the following two patches for inclusion.
The first is a revis
Hi!
I think the inttostr module needs to include three additional m4 files
to define the following macros:
gl_AC_HEADER_STDINT_H (needed by intmax_t.m4, uintmax_t.m4),
gl_AC_HEADER_INTTYPES_H (needed by uintmax_t.m4), and
gl_AC_TYPE_UNSIGNED_LONG_LONG (needed by uintmax_t.m4).
Regards,
Martin
-
On Thu, 25. Aug 2005, 15:32:00 +0200, Bruno Haible wrote:
> > If so, how can this be done?
>
> It can be done by merging your .m4 file with Jim's one, and put a big
> #if inside lib/gettimeofday.c.
OK, I had no better idea than defining GETTIMEOFDAY_USE_REPLACEMENTS if
the replacement functions
Hi!
I'd like to provide a gettimeofday() function for systems that do not
have it (at least Win32).
I already wrote a module that works, see below. But this module
overwrites the existing gettimeofday module. I do not know how to
integrate the changes into the existing module because of the auto
On Wed, 24. Aug 2005, 18:39:02 +0200, Bruno Haible wrote:
> Martin Lambers wrote:
> > Back in February, I suggested to add EX_OK to the sysexit module
> > (http://lists.gnu.org/archive/html/bug-gnulib/2005-02/msg00042.html).
> > Is there a reason not to do that?
>
&
Hi!
Back in February, I suggested to add EX_OK to the sysexit module
(http://lists.gnu.org/archive/html/bug-gnulib/2005-02/msg00042.html).
Is there a reason not to do that?
Regards,
Martin
--- sysexit_h.orig 2005-08-24 17:47:34.966600112 +0200
+++ sysexit_h 2005-08-24 17:47:51.731051528
62 matches
Mail list logo