Yoann Vandoorselaere wrote on 2008-09-18:
> > > - Add the missing cond-tests module.
Applied as follows. I
- removed ENABLE_LOCKING,
- made use of gl_cond_define_initialized and gl_lock_define_initialized
(because the macros gl_cond_initializer and gl_lock_initializer are not
public),
Yoann Vandoorselaere wrote on 2008-09-18:
> Here is a new version of the patches, contain more dependencies fixes,
Yup, I noticed these as well:
- 'errno' is needed as a dependency because of ETIMEDOUT,
- 'time' is needed as a dependency for 'struct timespec'.
Also, let me make the definition
Yoann Vandoorselaere wrote on 2008-09-15:
> > - Correct pthread_atfork() detection.
Yup. Applied, with a more conventional variable name:
2008-09-30 Yoann Vandoorselaere <[EMAIL PROTECTED]>
Bruno Haible <[EMAIL PROTECTED]>
* m4/thread.m4 (gl_THREAD): Fix detection of pthr
Yoann Vandoorselaere wrote:
> > - Make 'lock-tests' and 'tls-tests' depend on the thread and yield
> > module, use YIELD_LIBS in place of the deprecated LIBSCHED variable, and
> > update 'lock-tests.c' and 'tls-tests.c' to use newer glthread API.
Yes, I'm applying nearly exactly your patch.
2008
Yoann Vandoorselaere wrote on 2008-09-15:
> > - Make 'lock-tests' and 'tls-tests' depend on the thread and yield
> > module, use YIELD_LIBS in place of the deprecated LIBSCHED variable, and
> > update 'lock-tests.c' and 'tls-tests.c' to use newer glthread API.
Nearly right. Only the USE_*_THREADS
Yoann Vandoorselaere wrote on 2008-09-15:
> > - Make 'lock-tests' and 'tls-tests' depend on the thread and yield
> > module, use YIELD_LIBS in place of the deprecated LIBSCHED variable, and
> > update 'lock-tests.c' and 'tls-tests.c' to use newer glthread API.
Doing this broke test-lock on mingw.
Hello Paolo,
> > select() on a regular file
> > should return "ready" always, no? There's no need to even call
> > WaitForSingleObject on this one, IMO.
>
> Right,
Patch applied.
> can you do the same for poll() too?
I fear I can't: I don't understand the differences between the various POLL*
Hello Paolo,
> > How about adding an assertion like this?
> >
> > + if (!timeout && rc == 0)
> > + abort ();
>
> But wouldn't this trigger in your case, thus aborting select() and poll()?
Yes it would currently abort in select(). But it would force us to fix the
problem in a way that does
Daniel Macks wrote:
> Would be great to get wordexp into gnulib. OS X 10.4 finally has it,
> but it's incompletely implemented (the flags are ignored), so it's
> easy to *think* you're getting something ported when in fact it may
> not work correctly. OS X 10.5 claims to have the flags implemented,
Hi Jim,
> I noticed that the configure-time test for the f_type member
> of struct statfs was failing on some systems.
>
> It didn't include .
> I've pushed the obvious fix:
This introduces a regression on HP-UX.
The use of HAVE_STRUCT_STATFS_F_TYPE is predicated by
HAVE_SYS_VFS_H && HAVE_FSTAT
Eric Blake byu.net> writes:
> > Does glibc do round-to-even here generally (not just in the one special case
> > you mentioned?) If so, the module name should be called fprintf-gnu,
otherwise
> > fprintf-posix-ext.
>
> Both glibc and the gnulib *printf replacement already round to nearest;
> an
I noticed that the configure-time test for the f_type member
of struct statfs was failing on some systems.
It didn't include .
I've pushed the obvious fix:
>From af791bcb46dd123f336f10c05d8fbb708e2022a2 Mon Sep 17 00:00:00 2001
From: Jim Meyering <[EMAIL PROTECTED]>
Date: Tue, 30 Sep 2008 17:56:0
On Tuesday 30 September 2008 12:13:08 Ian Jackson wrote:
> Sorry, I overlooked this message before. Now I'm really confused.
> You seem to have already rewritten it. So why are people asking for
> permission and/or copyright assignment ?
The core of filevercmp module is the verrevcmp function tak
-BEGIN PGP SIGNED MESSAGE-
Hash: SHA1
According to Bruno Haible on 9/30/2008 4:43 AM:
> Does glibc do round-to-even here generally (not just in the one special case
> you mentioned?) If so, the module name should be called fprintf-gnu, otherwise
> fprintf-posix-ext.
Both glibc and the gnu
Hi Eric,
> An interesting question popped up on the bug-gnu-utils list:
> http://lists.gnu.org/archive/html/bug-gnu-utils/2008-09/msg00055.html
>
> POSIX states that with %f, the low-order digit is rounded in an
> implementation-
> defined manner. However, since 0.5 is exactly half-way between
Ian Jackson writes ("Re: willing to contribute verrevcmp to gnulib?"):
> Did you base your version on the Debian specification at
> http://www.debian.org/doc/debian-policy/ch-controlfields.html#s-f-Version
> ?
And another thing: you should put a comment in it saying
/*
* This implements the
Kamil Dudka writes ("Re: willing to contribute verrevcmp to gnulib?"):
> we use the extended version (handling ~ character), even slightly
> modified to work better with file names (with suffixes). The new
> (gnulib) filevercmp code is in attachment.
Sorry, I overlooked this message before. Now I
Eric Blake <[EMAIL PROTECTED]> wrote:
> An interesting question popped up on the bug-gnu-utils list:
> http://lists.gnu.org/archive/html/bug-gnu-utils/2008-09/msg00055.html
>
> POSIX states that with %f, the low-order digit is rounded in an
> implementation-
> defined manner. However, since 0.5 i
Simon Josefsson <[EMAIL PROTECTED]> wrote:
> I ported Eric Blake's test-memchr.c fix to test-memrchr.c, and fixed
> another minor bug in test-getdate.c. This fixed the two warnings that
> are easy to fix on:
>
> http://autobuild.josefsson.org/gnulib/log-200809290932420171000.txt
>
> The rest are w
AJ: the FSF want to put an implementation of the dpkg version
comparison algorithm into gnulib. I approve of this, but the git logs
say that the current version was supplied by you. There are some
copyright questions.
Jim Meyering writes ("Re: willing to contribute verrevcmp to gnulib?"):
> Brun
20 matches
Mail list logo