rangeColMeans (or rangeMeans) takes a vector, but can recycle over columns
in a matrix. I guess we could have rangeMeans for vector-ish things,
rangeColMeans and rangeRowMeans for two-d things.
I have rangeMeans for Rles and RleDataFrame, which does each Rle. I'm
flexible on naming.
Pete
___
Yea. The performance profile of rowsum() is terrible in that example. It
would actually be faster to convert the CompressedIntegerList into an
ordinary list and lapply over it.
On Mon, Jun 2, 2014 at 11:00 PM, Hervé Pagès wrote:
> There is a lot going on with respect to the view* stuff, and y
There is a lot going on with respect to the view* stuff, and yes, it's
not just about Rle's but they also need to work on atomic vectors.
Right now min(), max(), sum(), and mean() all work on IntegerList,
NumericList, RleList, XIntegerViews and XDoubleViews but
implementations are disparate and s
So rangeMeans,matrix implies rangeColMeans? Honestly, I would just have a
rangeColMeans and rangeRowMeans, which is consistent with the existing
row/colMeans. Don't see a good reason to prefer columns over rows.
On Mon, Jun 2, 2014 at 5:34 PM, Peter Haverty
wrote:
> I have have rangeColMeans wh
I have have rangeColMeans which is essentially rangeMeans for
vector/matrix. I renamed this to make it a method on rangeMeans. I think it
would be great to have methods for all the commonly used types. We should
put some thought into how these would all share as much code as is
practical.
Pete
_
While we rework things, what about adding support for atomic vectors, in
addition to Rles? Also, what about functions that are optimized for
partitionings? Those would be easy to write and would let us greatly
accelerate e.g. sum,CompressedIntegerList. Right now we rely on rowsum()
which is fast bu
Hi Peter,
Seems like you have a pretty good implementation of the view* functions
in genoset. Nice work! And great to hear that there is so much room for
improvements to the implementation currently in IRanges. I'll try to
give this a shot soon but first I want to move Rle's to the S4Vectors
pack
Sounds cool. I agree about the need for range* functions, if just for
simplicity and convenience. Are you able to attach the patch?
Thanks,
Michael
On Sun, Jun 1, 2014 at 7:58 PM, Peter Haverty
wrote:
> I think viewMedians would be great. While you have the hood up, there are
> some opportuni
I think viewMedians would be great. While you have the hood up, there are
some opportunities for some speedups and code simplification, I believe.
I did some experimentation with view* in the genoset package. I made an
alternate version of the C for viewMeans and found about a 10X speedup. I
hoi
Hi Michael,
On 05/30/2014 11:37 AM, Michael Lawrence wrote:
Herve,
How hard do you think it would be to add a viewMedians? It would be nice
to have a robust average of e.g. coverage. Also, many genotypers
including GATK summarize non-alt runs using the median. We want to be
consistent.
Don't
10 matches
Mail list logo