From: [EMAIL PROTECTED]
> I supose that the end result of:
>
> for ($init_cnt=0;$init_cnt<=$#out_array_bin;$init_cnt++) {
>$out_array_bin[$init_cnt] = "";
> }
>
> and
>
> '@out_array_bin = ();' or 'undef @out_array_bin;'
>
> is not the some, is it?
No it's not.
Suppose
> -Original Message-
> From: Jenda Krynicky [mailto:[EMAIL PROTECTED]
> Sent: Tuesday, May 25, 2004 8:08 PM
> To: [EMAIL PROTECTED]
> Subject: RE: Question of memory management in Perl
>
>
> From: [EMAIL PROTECTED]
> > I don
From: [EMAIL PROTECTED]
> I don't know for sure the effect of:
>
> @out_array_bin = map {""} (@out_array_bin);
>
> instead of
>
> for ($init_cnt=0;$init_cnt<=$#out_array_bin;$init_cnt++) {
>$out_array_bin[$init_cnt] = "";
> }
>
> But is more readable.
Neither makes much s
Probably you notice that you have +- 1kb for each hexa values. This seems
that you have some global variables that are not necessary.
Usually the solution is having the variables scoped to the minimum code area
possible. Module 'strict' can help.
for instance if you have something like.
my @arr
>
> Hi all,
> I have question with respect to memory utilization using perl. I am
reading a huge file close to 786432 lines of hex values & am storing in
an array. I do a data reformatting using the data in these array & in
the sequence of process generate a number of arrays & eventually write
int
off the top of my head I would suggest you slice off the slice off the pieces
that you have used already when pulling data from the original array. That
way the array gets smaller as you finish modifiying its info and transferring
it somewhere else.
BassFool
On Monday 24 May 2004 02:57 pm, Ha