Ron Bergin writes:
> Sorry for not posting the if/elsif/else block, but to me that part
> appeared to be obvious, but I guess it wasn't.
Probably would have been for all but the densist I guess. Not the
first time I've been guilty of that.
> I see that Jim has posted the if/elsif/else part, so
On Apr 15, 9:21 am, rea...@newsguy.com (Harry Putnam) wrote:
> r...@i.frys.com writes:
> > Here's an example I gave in a similar question in another
> > forum.
>
> Thanks...
>
> I'm sorry to ask more but if someone asked to be shown an
> if/elsif/else construct being replaced by a dispatch table, I
On 4/15/10 Thu Apr 15, 2010 9:21 AM, "Harry Putnam"
scribbled:
> r...@i.frys.com writes:
>
>> Here's an example I gave in a similar question in another
>> forum.
>
> Thanks...
>
> I'm sorry to ask more but if someone asked to be shown an
> if/elsif/else construct being replaced by a dispatc
r...@i.frys.com writes:
> Here's an example I gave in a similar question in another
> forum.
Thanks...
I'm sorry to ask more but if someone asked to be shown an
if/elsif/else construct being replaced by a dispatch table, I don't
really see how that answered there question. It didn't for me.
W
Harry Putnam wrote:
> "Uri Guttman" writes:
>
>> i disagree that it is elegant. too often if/else lists
>> are not
>> needed. many can be replaced by dispatch tables. if one
>> of the clauses
>> does just a return or next/last that can be replaced
>> with a modifier or
>> shorter statement. withou
"Uri Guttman" writes:
> i disagree that it is elegant. too often if/else lists are not
> needed. many can be replaced by dispatch tables. if one of the clauses
> does just a return or next/last that can be replaced with a modifier or
> shorter statement. without ANY serious work, i have over 10k
Hi Mimi,
Mimi Cafe wrote:
I think this will work, but is it elegant.?
If (condition){
if (nexted_condition){
As others have noted, it will work. But as for elegance, this is a very subjective opinion and
contrary to what recent comments have said, my take on it is that it depends on
On 2010.04.13 23:17, Kenneth Wolcott wrote:
> Hi;
>
> On Tue, Apr 13, 2010 at 19:54, Uri Guttman wrote:
>>> "JG" == Jim Gibson writes:
>>
>> JG> On 4/13/10 Tue Apr 13, 2010 4:35 PM, "Mimi Cafe"
>>
>> JG> scribbled:
>>
>> >> I think this will work, but is it elegant.?
>>
>> JG> Yes, i
Yes, the nested if and elsif and else makes the code difficult to read and I
often get stuck trying to make sense of it all. For now, I will look to see
if I can move some bit and pieces to subroutines to improve readability.
Thanks guys
Mimi
-Original Message-
From: Jim Gibson
On Wednesday 14 Apr 2010 02:35:50 Mimi Cafe wrote:
> I think this will work, but is it elegant.?
>
>
>
> If (condition){
>
>if (nexted_condition){
>
> do this.
>
>}
>
>Elsif (nexted_condition){
>
> Do that...
>
>}
>
> else{
>
> Do something else.
>
>
Hi;
On Tue, Apr 13, 2010 at 19:54, Uri Guttman wrote:
>> "JG" == Jim Gibson writes:
>
> JG> On 4/13/10 Tue Apr 13, 2010 4:35 PM, "Mimi Cafe"
>
> JG> scribbled:
>
> >> I think this will work, but is it elegant.?
>
> JG> Yes, it will work, and yes, it is elegant, as long as it encapsul
> "JG" == Jim Gibson writes:
JG> On 4/13/10 Tue Apr 13, 2010 4:35 PM, "Mimi Cafe"
JG> scribbled:
>> I think this will work, but is it elegant.?
JG> Yes, it will work, and yes, it is elegant, as long as it encapsulates the
JG> logic that is required by your program.
i disagree
On 4/13/10 Tue Apr 13, 2010 4:35 PM, "Mimi Cafe"
scribbled:
> I think this will work, but is it elegant.?
Yes, it will work, and yes, it is elegant, as long as it encapsulates the
logic that is required by your program.
Be sure and watch your indenting, so you can mentally group the correct
b
I think this will work, but is it elegant.?
If (condition){
if (nexted_condition){
do this.
}
Elsif (nexted_condition){
Do that...
}
else{
Do something else.
}
}
else{
Do something else..
}
Mimi
14 matches
Mail list logo