On 1/29/2025 2:16 PM, Sathishkumar S wrote:
> Add devcoredump helper functions that can be reused for all jpeg versions.
>
> V2: (Lijo)
> - add amdgpu_jpeg_reg_dump_init() and amdgpu_jpeg_reg_dump_fini()
> - use reg_list and reg_count from init() to dump and print registers
> - memory alloca
On 1/29/2025 3:51 PM, Sundararaju, Sathishkumar wrote:
>
>
>
> On 1/29/2025 3:20 PM, Lazar, Lijo wrote:
>>
>> On 1/29/2025 2:16 PM, Sathishkumar S wrote:
>>> Add devcoredump helper functions that can be reused for all jpeg
>>> versions.
>>>
>>> V2: (Lijo)
>>> - add amdgpu_jpeg_reg_dump_init
On 1/29/2025 4:15 PM, Lazar, Lijo wrote:
On 1/29/2025 3:51 PM, Sundararaju, Sathishkumar wrote:
On 1/29/2025 3:20 PM, Lazar, Lijo wrote:
On 1/29/2025 2:16 PM, Sathishkumar S wrote:
Add devcoredump helper functions that can be reused for all jpeg
versions.
V2: (Lijo)
- add amdgpu_jpe
This patch is:
Reviewed-by: Leo Liu
On 1/29/25 03:46, Sathishkumar S wrote:
Add an inline function to calculate core specific register offsets for
JPEG v4.0.3 and reuse it, makes code more readable and easier to align.
Signed-off-by: Sathishkumar S
---
drivers/gpu/drm/amd/amdgpu/jpeg_v4_0_
Remove all KFD BOs from the private dma_resv object.
This prevents the KFD from being evitec unecessarily when an exported BO
is released.
Signed-off-by: Christian König
---
drivers/gpu/drm/amd/amdgpu/amdgpu_amdkfd.h| 5 +-
.../gpu/drm/amd/amdgpu/amdgpu_amdkfd_gpuvm.c | 52 ---
Test the fences in the private dma_resv object instead of the pointer to
a potentially shared dma_resv object.
This only matters for imported BOs with an SG table since those don't
get their dma_resv pointer replaced on release.
Signed-off-by: Christian König
---
drivers/gpu/drm/ttm/ttm_bo.c |
On Tue, 2025-01-28 at 15:29 +0100, Philipp Stanner wrote:
> drm_sched_init() has a great many parameters and upcoming new
> functionality for the scheduler might add even more. Generally, the
> great number of parameters reduces readability and has already caused
> one missnaming in:
>
> commit 6f
Hi Philipp,
On 28/01/25 11:29, Philipp Stanner wrote:
drm_sched_init() has a great many parameters and upcoming new
functionality for the scheduler might add even more. Generally, the
great number of parameters reduces readability and has already caused
one missnaming in:
commit 6f1cacf4eba7 ("
Hi Philipp,
On 29/01/25 09:39, Philipp Stanner wrote:
On Wed, 2025-01-29 at 07:53 -0300, Maíra Canal wrote:
Hi Philipp,
On 28/01/25 11:29, Philipp Stanner wrote:
drm_sched_init() has a great many parameters and upcoming new
functionality for the scheduler might add even more. Generally, the
g
On Wed, 2025-01-29 at 07:53 -0300, Maíra Canal wrote:
> Hi Philipp,
>
> On 28/01/25 11:29, Philipp Stanner wrote:
> > drm_sched_init() has a great many parameters and upcoming new
> > functionality for the scheduler might add even more. Generally, the
> > great number of parameters reduces readabi
On 1/29/2025 3:20 PM, Lazar, Lijo wrote:
On 1/29/2025 2:16 PM, Sathishkumar S wrote:
Add devcoredump helper functions that can be reused for all jpeg versions.
V2: (Lijo)
- add amdgpu_jpeg_reg_dump_init() and amdgpu_jpeg_reg_dump_fini()
- use reg_list and reg_count from init() to dump
On Tue, 28 Jan 2025 15:29:27 +0100
Philipp Stanner wrote:
> drm_sched_init() has a great many parameters and upcoming new
> functionality for the scheduler might add even more. Generally, the
> great number of parameters reduces readability and has already caused
> one missnaming in:
>
> commit
On Tue, 28 Jan 2025 22:49:47 +0100
Christian Gmeiner wrote:
> > int etnaviv_sched_init(struct etnaviv_gpu *gpu)
> > {
> > - int ret;
> > + const struct drm_sched_init_args args = {
>
> Why not declare it as static const struct drm_sched_init_args args = { ?
Because some bits in
>
> drm_sched_init() has a great many parameters and upcoming new
> functionality for the scheduler might add even more. Generally, the
> great number of parameters reduces readability and has already caused
> one missnaming in:
>
> commit 6f1cacf4eba7 ("drm/nouveau: Improve variable name in
> nou
>
> > > int etnaviv_sched_init(struct etnaviv_gpu *gpu)
> > > {
> > > - int ret;
> > > + const struct drm_sched_init_args args = {
> >
> > Why not declare it as static const struct drm_sched_init_args args = { ?
>
> Because some bits in there are not static, in this particular case,
>
On Tue, Jan 28, 2025 at 01:38:09PM +0200, Pekka Paalanen wrote:
> On Tue, 28 Jan 2025 11:37:53 +0200
> Raag Jadav wrote:
>
> > On Mon, Jan 27, 2025 at 12:23:28PM +0200, Pekka Paalanen wrote:
> > > On Wed, 22 Jan 2025 07:22:25 +0200
> > > Raag Jadav wrote:
> > >
> > > > On Tue, Jan 21, 2025 at
>
> drm_sched_init() has a great many parameters and upcoming new
> functionality for the scheduler might add even more. Generally, the
> great number of parameters reduces readability and has already caused
> one missnaming in:
>
> commit 6f1cacf4eba7 ("drm/nouveau: Improve variable name in
> nou
On Tue, Jan 28, 2025 at 03:29:27PM +0100, Philipp Stanner wrote:
> drm_sched_init() has a great many parameters and upcoming new
> functionality for the scheduler might add even more. Generally, the
> great number of parameters reduces readability and has already caused
> one missnaming in:
>
> co
Add devcoredump helper functions that can be reused for all jpeg versions.
V2: (Lijo)
- add amdgpu_jpeg_reg_dump_init() and amdgpu_jpeg_reg_dump_fini()
- use reg_list and reg_count from init() to dump and print registers
- memory allocation and freeing is moved to the init() and fini()
Signed-
Add an inline function to calculate core specific register offsets for
JPEG v4.0.3 and reuse it, makes code more readable and easier to align.
Signed-off-by: Sathishkumar S
---
drivers/gpu/drm/amd/amdgpu/jpeg_v4_0_3.c | 54 +++-
1 file changed, 24 insertions(+), 30 deletions(
Add register list and enable devcoredump for JPEG5_0_1
V2: (Lijo)
- remove version specific callbacks and use simplified helper functions
Signed-off-by: Sathishkumar S
---
drivers/gpu/drm/amd/amdgpu/jpeg_v5_0_1.c | 51 +++-
drivers/gpu/drm/amd/amdgpu/jpeg_v5_0_1.h | 61 +
Add register list and enable devcoredump for JPEG4_0_3
V2: (Lijo)
- remove version specific callbacks and use simplified helper functions
Signed-off-by: Sathishkumar S
---
drivers/gpu/drm/amd/amdgpu/jpeg_v4_0_3.c | 44
1 file changed, 44 insertions(+)
diff --git a/dri
This patch-series enables jpeg devcoredump support
V2: (Lijo)
- add amdgpu_jpeg_reg_dump_init() for memory allocation and reg_list ref
- use reg_list and reg_count from init() to dump and print registers
- add amdgpu_jpeg_reg_dump_fini() to free memory and clear reg_list ref
Sathishkumar S (9)
Add register list and enable devcoredump for JPEG4_0_0
V2: (Lijo)
- remove version specific callbacks and use simplified helper functions
Signed-off-by: Sathishkumar S
---
drivers/gpu/drm/amd/amdgpu/jpeg_v4_0.c | 26 +-
1 file changed, 25 insertions(+), 1 deletion(-)
di
Add register list and enable devcoredump for JPEG3_0_0
V2: (Lijo)
- remove version specific callbacks and use simplified helper functions
Signed-off-by: Sathishkumar S
---
drivers/gpu/drm/amd/amdgpu/jpeg_v3_0.c | 24
1 file changed, 24 insertions(+)
diff --git a/driver
Add register list and enable devcoredump for JPEG4_0_5
V2: (Lijo)
- remove version specific callbacks and use simplified helper functions
Signed-off-by: Sathishkumar S
---
drivers/gpu/drm/amd/amdgpu/jpeg_v4_0_5.c | 27 +++-
1 file changed, 26 insertions(+), 1 deletion(-)
di
Add register list and enable devcoredump for JPEG2_5_0
V2: (Lijo)
- remove version specific callbacks and use simplified helper functions
Signed-off-by: Sathishkumar S
---
drivers/gpu/drm/amd/amdgpu/jpeg_v2_5.c | 26 ++
1 file changed, 26 insertions(+)
diff --git a/driv
Add register list and enable devcoredump for JPEG2_0_0
V2: (Lijo)
- remove version specific callbacks and use simplified helper functions
Signed-off-by: Sathishkumar S
---
drivers/gpu/drm/amd/amdgpu/jpeg_v2_0.c | 24
1 file changed, 24 insertions(+)
diff --git a/driver
Reviewed-and-Tested-by: James Zhu for the series
On 2025-01-29 10:28, Christian König wrote:
Test the fences in the private dma_resv object instead of the pointer to
a potentially shared dma_resv object.
This only matters for imported BOs with an SG table since those don't
get their dma_resv p
From: Asad Kamal
Skip P2S table load for SMU v13.0.12
Signed-off-by: Asad Kamal
Reviewed-by: Lijo Lazar
---
drivers/gpu/drm/amd/pm/swsmu/smu13/smu_v13_0_6_ppt.c | 5 +++--
1 file changed, 3 insertions(+), 2 deletions(-)
diff --git a/drivers/gpu/drm/amd/pm/swsmu/smu13/smu_v13_0_6_ppt.c
b/dri
From: Le Ma
The CGCG residency can be observed with the change.
Signed-off-by: Le Ma
Reviewed-by: Hawking Zhang
---
drivers/gpu/drm/amd/amdgpu/gfx_v9_4_3.c | 1 +
1 file changed, 1 insertion(+)
diff --git a/drivers/gpu/drm/amd/amdgpu/gfx_v9_4_3.c
b/drivers/gpu/drm/amd/amdgpu/gfx_v9_4_3.c
in
From: Shiwu Zhang
Make psp_vbflash_status and psp_vbflash available in sysfs
Signed-off-by: Shiwu Zhang
Reviewed-by: Hawking Zhang
---
drivers/gpu/drm/amd/amdgpu/amdgpu_psp.c | 6 +-
1 file changed, 5 insertions(+), 1 deletion(-)
diff --git a/drivers/gpu/drm/amd/amdgpu/amdgpu_psp.c
b/dr
support gmc ip versioning though ip discovery binary
Signed-off-by: Mangesh Gadre
Signed-off-by: Shiwu Zhang
Reviewed-by: Hawking Zhang
---
drivers/gpu/drm/amd/amdgpu/gmc_v9_0.c | 2 ++
1 file changed, 2 insertions(+)
diff --git a/drivers/gpu/drm/amd/amdgpu/gmc_v9_0.c
b/drivers/gpu/drm/amd/a
support smuio ip versioning though ip discovery binary
Signed-off-by: Mangesh Gadre
Signed-off-by: Shiwu Zhang
Reviewed-by: Hawking Zhang
---
drivers/gpu/drm/amd/amdgpu/amdgpu_discovery.c | 1 +
1 file changed, 1 insertion(+)
diff --git a/drivers/gpu/drm/amd/amdgpu/amdgpu_discovery.c
b/drive
support smu ip versioning though ip discovery binary
Signed-off-by: Mangesh Gadre
Signed-off-by: Shiwu Zhang
Reviewed-by: Hawking Zhang
---
drivers/gpu/drm/amd/amdgpu/amdgpu_discovery.c | 1 +
1 file changed, 1 insertion(+)
diff --git a/drivers/gpu/drm/amd/amdgpu/amdgpu_discovery.c
b/drivers
support nbio ip versioning though ip discovery binary
Signed-off-by: Mangesh Gadre
Signed-off-by: Shiwu Zhang
Reviewed-by: Hawking Zhang
---
drivers/gpu/drm/amd/amdgpu/amdgpu_discovery.c | 1 +
1 file changed, 1 insertion(+)
diff --git a/drivers/gpu/drm/amd/amdgpu/amdgpu_discovery.c
b/driver
To workaround queue full h/w issue on Gfx7/8, when application create
AQL queues, the ring buffer bo allocate size is queue_size/2 and
mapped to GPU twice using 2 attachments with same ring_bo backing
memory.
For this case, user queue buffer validation should use queue_size/2 to
verify ring_bo all
Hi Dave, Simona,
Fixes for 6.14.
The following changes since commit 64179a1416e1420a34226ab3beb5f84710953d16:
Merge tag 'drm-misc-next-fixes-2025-01-24' of
https://gitlab.freedesktop.org/drm/misc/kernel into drm-next (2025-01-24
17:06:06 +0100)
are available in the Git repository at:
htt
In some ASICs L2 cache info may miss in kfd topology,
because the first bitmap may be empty, that means
the first cu may be inactive, so to find the first
active cu will solve the issue.
Signed-off-by: Eric Huang
---
drivers/gpu/drm/amd/amdkfd/kfd_topology.c | 18 --
1 file chang
Looks pretty good to me. One question that why this is not added to JPEG
5_0_0? Since the patch 3-9 cover the rest of versions, they are:
Reviewed-by: Leo Liu
On 1/29/25 03:46, Sathishkumar S wrote:
Add register list and enable devcoredump for JPEG2_5_0
V2: (Lijo)
- remove version specific c
Ping. This is urgent.
Marek
On Mon, Jan 27, 2025 at 10:52 AM Marek Olšák wrote:
> Updated patch attached.
>
> Vulkan can't support DCC and Z/S compression on GFX12 without this.
>
> Marek
>
> On Fri, Jan 24, 2025 at 10:15 AM Marek Olšák wrote:
>
>> Required by Vulkan because it can allocate wh
On 2025-01-29 10:28, Christian König wrote:
> Remove all KFD BOs from the private dma_resv object.
>
> This prevents the KFD from being evitec unecessarily when an exported BO
> is released.
>
> Signed-off-by: Christian König
Looks good to me. Assuming James doesn't find any issues in testin
Hi Leo,
Oh! I somehow missed it, I will enable it in 5_0_0 as well.
Initially I had some confusion around 4_0_5 and 5_0_0 as they both are
in dpg mode, but after checking the existing register access I enabled
it in 4_0_5, but missed to enable it in 5_0_0.
Regards,
Sathish
On 1/29/2025 10:06
Am 23.01.25 um 21:39 schrieb Philip Yang:
SVM migration unmap pages from GPU and then update mapping to GPU to
recover page fault. Currently unmap clears the PDE entry for range
length >= huge page and may free PTB bo. Then update mapping should
alloc new PT bo, but there is race bug that the fre
Reviewed-by: Alex Deucher
On Wed, Jan 29, 2025 at 1:32 PM Marek Olšák wrote:
>
> Ping. This is urgent.
>
> Marek
>
> On Mon, Jan 27, 2025 at 10:52 AM Marek Olšák wrote:
>>
>> Updated patch attached.
>>
>> Vulkan can't support DCC and Z/S compression on GFX12 without this.
>>
>> Marek
>>
>> On F
45 matches
Mail list logo