Re: [PATCH v2] drm/sched: Use struct for drm_sched_init() params

2025-01-30 Thread Danilo Krummrich
On Wed, Jan 29, 2025 at 04:18:30PM +0100, Philipp Stanner wrote: > On Tue, 2025-01-28 at 15:56 +0100, Danilo Krummrich wrote: > > On Tue, Jan 28, 2025 at 03:29:27PM +0100, Philipp Stanner wrote: > > > diff --git a/drivers/gpu/drm/nouveau/nouveau_sched.c > > > b/drivers/gpu/drm/nouveau/nouveau_sched

Re: [PATCH v2] drm/sched: Use struct for drm_sched_init() params

2025-01-30 Thread Philipp Stanner
On Tue, 2025-01-28 at 15:56 +0100, Danilo Krummrich wrote: > On Tue, Jan 28, 2025 at 03:29:27PM +0100, Philipp Stanner wrote: > > drm_sched_init() has a great many parameters and upcoming new > > functionality for the scheduler might add even more. Generally, the > > great number of parameters redu

Re: [PATCH v2] drm/sched: Use struct for drm_sched_init() params

2025-01-29 Thread Maíra Canal
Hi Philipp, On 29/01/25 09:39, Philipp Stanner wrote: On Wed, 2025-01-29 at 07:53 -0300, Maíra Canal wrote: Hi Philipp, On 28/01/25 11:29, Philipp Stanner wrote: drm_sched_init() has a great many parameters and upcoming new functionality for the scheduler might add even more. Generally, the g

Re: [PATCH v2] drm/sched: Use struct for drm_sched_init() params

2025-01-29 Thread Philipp Stanner
On Wed, 2025-01-29 at 07:53 -0300, Maíra Canal wrote: > Hi Philipp, > > On 28/01/25 11:29, Philipp Stanner wrote: > > drm_sched_init() has a great many parameters and upcoming new > > functionality for the scheduler might add even more. Generally, the > > great number of parameters reduces readabi

Re: [PATCH v2] drm/sched: Use struct for drm_sched_init() params

2025-01-29 Thread Maíra Canal
Hi Philipp, On 28/01/25 11:29, Philipp Stanner wrote: drm_sched_init() has a great many parameters and upcoming new functionality for the scheduler might add even more. Generally, the great number of parameters reduces readability and has already caused one missnaming in: commit 6f1cacf4eba7 ("

Re: [PATCH v2] drm/sched: Use struct for drm_sched_init() params

2025-01-29 Thread Frank Binns
On Tue, 2025-01-28 at 15:29 +0100, Philipp Stanner wrote: > drm_sched_init() has a great many parameters and upcoming new > functionality for the scheduler might add even more. Generally, the > great number of parameters reduces readability and has already caused > one missnaming in: > > commit 6f

Re: [PATCH v2] drm/sched: Use struct for drm_sched_init() params

2025-01-29 Thread Danilo Krummrich
On Tue, Jan 28, 2025 at 03:29:27PM +0100, Philipp Stanner wrote: > drm_sched_init() has a great many parameters and upcoming new > functionality for the scheduler might add even more. Generally, the > great number of parameters reduces readability and has already caused > one missnaming in: > > co

Re: [PATCH v2] drm/sched: Use struct for drm_sched_init() params

2025-01-29 Thread Christian Gmeiner
> > > > int etnaviv_sched_init(struct etnaviv_gpu *gpu) > > > { > > > - int ret; > > > + const struct drm_sched_init_args args = { > > > > Why not declare it as static const struct drm_sched_init_args args = { ? > > Because some bits in there are not static, in this particular case, >

Re: [PATCH v2] drm/sched: Use struct for drm_sched_init() params

2025-01-29 Thread Christian Gmeiner
> > drm_sched_init() has a great many parameters and upcoming new > functionality for the scheduler might add even more. Generally, the > great number of parameters reduces readability and has already caused > one missnaming in: > > commit 6f1cacf4eba7 ("drm/nouveau: Improve variable name in > nou

Re: [PATCH v2] drm/sched: Use struct for drm_sched_init() params

2025-01-29 Thread Christian Gmeiner
> > drm_sched_init() has a great many parameters and upcoming new > functionality for the scheduler might add even more. Generally, the > great number of parameters reduces readability and has already caused > one missnaming in: > > commit 6f1cacf4eba7 ("drm/nouveau: Improve variable name in > nou

Re: [PATCH v2] drm/sched: Use struct for drm_sched_init() params

2025-01-29 Thread Boris Brezillon
On Tue, 28 Jan 2025 22:49:47 +0100 Christian Gmeiner wrote: > > int etnaviv_sched_init(struct etnaviv_gpu *gpu) > > { > > - int ret; > > + const struct drm_sched_init_args args = { > > Why not declare it as static const struct drm_sched_init_args args = { ? Because some bits in

Re: [PATCH v2] drm/sched: Use struct for drm_sched_init() params

2025-01-29 Thread Boris Brezillon
On Tue, 28 Jan 2025 15:29:27 +0100 Philipp Stanner wrote: > drm_sched_init() has a great many parameters and upcoming new > functionality for the scheduler might add even more. Generally, the > great number of parameters reduces readability and has already caused > one missnaming in: > > commit

Re: [PATCH v2] drm/sched: Use struct for drm_sched_init() params

2025-01-28 Thread Matthew Brost
On Tue, Jan 28, 2025 at 03:29:27PM +0100, Philipp Stanner wrote: > drm_sched_init() has a great many parameters and upcoming new > functionality for the scheduler might add even more. Generally, the > great number of parameters reduces readability and has already caused > one missnaming in: > > co

Re: [PATCH v2] drm/sched: Use struct for drm_sched_init() params

2025-01-28 Thread Liviu Dudau
On Tue, Jan 28, 2025 at 03:29:27PM +0100, Philipp Stanner wrote: > drm_sched_init() has a great many parameters and upcoming new > functionality for the scheduler might add even more. Generally, the > great number of parameters reduces readability and has already caused > one missnaming in: > > co

[PATCH v2] drm/sched: Use struct for drm_sched_init() params

2025-01-28 Thread Philipp Stanner
drm_sched_init() has a great many parameters and upcoming new functionality for the scheduler might add even more. Generally, the great number of parameters reduces readability and has already caused one missnaming in: commit 6f1cacf4eba7 ("drm/nouveau: Improve variable name in nouveau_sched_init