debugfs register list for dump is cleaned as it have
some issues related to proper power state of the IP
before register read.
Since the above mentioned is removed we no longer want
this to be dumped part of the devcoredump and hence
removed.
Signed-off-by: Sunil Khatri
---
drivers/gpu/drm/amd/
There are some problem with existing amdgpu_reset_dump_register_list
debugfs node. It is supposed to read a list of registers but there
could be cases when the IP is not in correct power state. Register
read in such cases could lead to more problems.
We are taking care of all such power states in
Debugfs and devcoredump cleanup with removal of register list for dump
Sunil Khatri (2):
drm/amdgpu: Remove debugfs amdgpu_reset_dump_register_list
drm/amdgpu: Clean up the register dump via debugfs list
drivers/gpu/drm/amd/amdgpu/amdgpu.h | 13 ---
drivers/gpu/drm/amd/amdgpu/amdgp
There are some problem with existing amdgpu_reset_dump_register_list
debugfs node. It is supposed to read a list of registers but there
could be cases when the IP is not in correct power state. Register
read in such cases could lead to more problems.
We are taking care of all such power states in
debugfs register list for dump is cleaned as it have
some issues related to proper power state of the IP
before register read.
Since the above mentioned is removed we no longer want
this to be dumped part of the devcoredump and hence
removed.
Signed-off-by: Sunil Khatri
---
drivers/gpu/drm/amd/
Debugfs and devcoredump cleanup with removal of register list for dump
Sunil Khatri (2):
drm/amdgpu: Remove debugfs amdgpu_reset_dump_register_list
drm/amdgpu: Clean up the register dump via debugfs list
drivers/gpu/drm/amd/amdgpu/amdgpu.h | 13 ---
drivers/gpu/drm/amd/amdgpu/amdgp
[AMD Official Use Only - AMD Internal Distribution Only]
Ignore. Will be pushing new patch set.
-Original Message-
From: Sunil Khatri
Sent: Tuesday, July 30, 2024 10:52 AM
To: Deucher, Alexander ;
pelloux-pra...@rtg-sunil-navi33.amd.com; Pelloux-Prayer, Pierre-Eric
; Koenig, Christian
[Public]
Thanks, Kevin.
The revert patch seems correct, but we plan to refactor this function as the
following patch
fa57924c76d995 ("drm/amd/display: Refactor function
dm_dp_mst_is_port_support_mode()")
I'll make time to provide one. Thanks!
Regards,
Wayne
> -Original Message-
> From
[Public]
Hi,
Thanks for the report!
We're going to revert it and cc to stable.
Regards,
Wayne
> -Original Message-
> From: Jiri Slaby
> Sent: Thursday, July 18, 2024 3:09 PM
> To: Li, Roman ; amd-gfx@lists.freedesktop.org
> Cc: Wheeler, Daniel ; Wentland, Harry
> ; Li, Sun peng (Leo) ;
[Public]
Hi,
Thanks for the report.
Patch fa57924c76d995 ("drm/amd/display: Refactor function
dm_dp_mst_is_port_support_mode()")
is kind of correcting problems causing by commit:
4df96ba6676034 ("drm/amd/display: Add timing pixel encoding for mst mode
validation")
Sorry if it misses fixes tag
Problem:
Till now we are adding NOP packet one by one
i.e if we need N nop packets for padding we are adding
N NOP packets in the ring which does not use the HW
efficiently.
Solution:
Use the data block of the NOP packet for NOP packets
up to the max no of NOPS HW support. Using this HW would
skip
[Public]
This patch is,
Reviewed-by: Tim Huang
> -Original Message-
> From: amd-gfx On Behalf Of Yifan
> Zhang
> Sent: Tuesday, July 30, 2024 12:37 PM
> To: amd-gfx@lists.freedesktop.org
> Cc: Deucher, Alexander ; Zhang, Jesse(Jie)
> ; Zhang, Yifan
> Subject: [PATCH] drm/amdgpu: use
avoid using SDMA if it is unavailable.
Signed-off-by: Yifan Zhang
---
drivers/gpu/drm/amd/amdgpu/amdgpu_vm.c | 6 ++
1 file changed, 6 insertions(+)
diff --git a/drivers/gpu/drm/amd/amdgpu/amdgpu_vm.c
b/drivers/gpu/drm/amd/amdgpu/amdgpu_vm.c
index a060c28f0877..bcb729094521 100644
--- a/dr
This commit corrects the function comment for
'dpp401_dscl_program_isharp' in 'dcn401_dpp_dscl.c'. The comment
previously included a description for a non-existent parameter
'bs_coeffs_updated'. This parameter description has been removed to
reflect the function's actual parameters.
Fixes the bel
For rockchip rk3288 and rk3399, the display driver is rockchip
and gpu driver is panfrost. Currently, in drm-ci for rockchip
rk3288 and rk3399, only the gpu driver is tested. Refactor
the existing rockchip jobs to test both display and gpu driver
and update xfails.
Since the correct driver name is
For Amlogic Meson G12B (A311D) SOC the display driver is meson and
gpu driver is panfrost. Currently, in drm-ci for Meson G12B (A311D),
only the gpu driver is tested. Refactor the existing meson jobs
and add support in drm-ci to test both display and gpu driver for
Amlogic Meson G12B (A311D) and up
For mediatek mt8173, the display driver is mediatek, while the
gpu driver is powervr. Currently, in drm-ci for mt8173, only the
display driver is tested. Add support in drm-ci to test powervr
driver for mt8173. Powervr driver was merged in linux kernel,
but there's no mediatek support yet. So disab
For mediatek mt8183, the display driver is mediatek, while the
gpu driver is panfrost. Currently, in drm-ci for mt8183, only
the gpu driver is tested. Refactor the existing mediatek jobs
and add support in drm-ci to test both display and gpu driver
for mt8183 and update xfails.
Since the correct d
tools_test is a wrapper for running tools/intel_reg
and tools/intel_l3_parity. So skip these tests on
non-intel platforms and update expectaion files.
Signed-off-by: Vignesh Raman
---
v9:
- New patch in the series to skip tools_test on non-intel platforms
---
drivers/gpu/drm/ci/xfails/amdgpu
Some ARM SOCs have a separate display controller and GPU, each with
different drivers. For mediatek mt8173, the GPU driver is powervr,
and the display driver is mediatek. In the case of mediatek mt8183,
the GPU driver is panfrost, and the display driver is mediatek.
With rockchip rk3288/rk3399, the
Enable CONFIG_DRM_ANALOGIX_ANX7625 in the arm64 defconfig to get
display driver probed on the mt8183-kukui-jacuzzi-juniper machine.
arch/arm64/configs/defconfig has CONFIG_DRM_ANALOGIX_ANX7625=m,
but drm-ci don't have initrd with modules, so add
CONFIG_DRM_ANALOGIX_ANX7625=y in CI arm64 config.
A
[AMD Official Use Only - AMD Internal Distribution Only]
Some comments inline.
After fixed, the patch is
Reviewed-by: Yang Wang
Best Regards,
Kevin
-Original Message-
From: Kenneth Feng
Sent: Tuesday, July 30, 2024 9:45 AM
To: amd-gfx@lists.freedesktop.org
Cc: Wang, Yang(Kevin) ; Feng
Reviewed-by: Tom Chung
On 7/26/2024 10:03 PM, Srinivasan Shanmugam wrote:
This commit adds a null check for 'stream_status' in the function
'planes_changed_for_existing_stream'. Previously, the code assumed
'stream_status' could be null, but did not handle the case where it was
actually null. T
add overdrive support on smu v14.0.2/3
Signed-off-by: Kenneth Feng
---
.../gpu/drm/amd/pm/swsmu/smu14/smu_v14_0.c| 11 +-
.../drm/amd/pm/swsmu/smu14/smu_v14_0_2_ppt.c | 888 +-
2 files changed, 896 insertions(+), 3 deletions(-)
diff --git a/drivers/gpu/drm/amd/pm/swsmu/smu
[Public]
Ping on review.
Thanks,
Jon
> -Original Message-
> From: Kim, Jonathan
> Sent: Monday, July 22, 2024 2:57 PM
> To: amd-gfx@lists.freedesktop.org
> Cc: Kim, Jonathan ; Kim, Jonathan
>
> Subject: [PATCH] drm/amdkfd: fix debug watchpoints for logical devices
>
> The number of wa
On 7/29/2024 1:23 PM, Christian König wrote:
Caution: This message originated from an External Source. Use proper
caution when opening attachments, clicking links, or responding.
Am 25.07.24 um 20:19 schrieb Xiaogang.Chen:
From: Xiaogang Chen
When app unmap vm ranges(munmap) kfd/svm start
Am 26.07.24 um 16:21 schrieb Daniel Vetter:
On Fri, Jul 26, 2024 at 09:55:50AM +0200, Christian König wrote:
The current implementation of drm_sched_start uses a hardcoded
-ECANCELED to dispose of a job when the parent/hw fence is NULL.
This results in drm_sched_job_done being called with -ECANC
Am 26.07.24 um 14:30 schrieb Matthew Brost:
On Fri, Jul 26, 2024 at 09:55:50AM +0200, Christian König wrote:
The current implementation of drm_sched_start uses a hardcoded
-ECANCELED to dispose of a job when the parent/hw fence is NULL.
This results in drm_sched_job_done being called with -ECANC
Am 25.07.24 um 20:19 schrieb Xiaogang.Chen:
From: Xiaogang Chen
When app unmap vm ranges(munmap) kfd/svm starts drain pending page fault and
not handle any incoming pages fault of this process until a deferred work item
got executed by default system wq. The time period of "not handle page faul
Am 29.07.24 um 20:04 schrieb Christian König:
Am 29.07.24 um 19:26 schrieb Nikita Zhandarovich:
Hi,
On 7/29/24 02:23, Christian König wrote:
Am 26.07.24 um 14:52 schrieb Alex Deucher:
On Fri, Jul 26, 2024 at 3:05 AM Christian König
wrote:
Am 25.07.24 um 20:09 schrieb Nikita Zhandarovich:
S
Am 29.07.24 um 19:26 schrieb Nikita Zhandarovich:
Hi,
On 7/29/24 02:23, Christian König wrote:
Am 26.07.24 um 14:52 schrieb Alex Deucher:
On Fri, Jul 26, 2024 at 3:05 AM Christian König
wrote:
Am 25.07.24 um 20:09 schrieb Nikita Zhandarovich:
Several cs track offsets (such as 'track->db_s_r
On 2024-07-29 13:14, Christian König wrote:
> Am 29.07.24 um 12:42 schrieb Michel Dänzer:
>> On 2024-07-26 17:25, Alex Deucher wrote:
>>> On Fri, Jul 26, 2024 at 9:50 AM Alex Deucher
>>> wrote:
This adds allocation latency, but aligns better with user
expectations. The latency should i
On 2024-07-28 20:02, Melissa Wen wrote:
On 07/25, Alex Hung wrote:
On 2024-07-05 21:35, Melissa Wen wrote:
instead of parsing struct edid.
A more informative commit message will be helpful.
sure. I'll improve it in the next version.
A soft reminder - a few other patches need improved
On 2024-07-28 19:32, Melissa Wen wrote:
On 07/25, Alex Hung wrote:
Hi Melissa,
There are no commit messages in this patch.
Also, do you think this can be merged with Patch 5 "drm/amd/display: remove
redundant freesync parser for DP"?
Hi Alex,
Thanks for your feedback.
I'll add a brief d
Am 29.07.24 um 12:42 schrieb Michel Dänzer:
On 2024-07-26 17:25, Alex Deucher wrote:
On Fri, Jul 26, 2024 at 9:50 AM Alex Deucher wrote:
This adds allocation latency, but aligns better with user
expectations. The latency should improve with the drm buddy
clearing patches that Arun has been wo
On 2024-07-26 17:25, Alex Deucher wrote:
> On Fri, Jul 26, 2024 at 9:50 AM Alex Deucher
> wrote:
>>
>> This adds allocation latency, but aligns better with user
>> expectations. The latency should improve with the drm buddy
>> clearing patches that Arun has been working on.
>>
>> Signed-off-by:
On Fri, 26 Jul 2024, Alex Deucher wrote:
> Applied the series. Thanks!
Ah, replied to patch 1 before noticing this. Never mind about the
bikeshedding. :)
BR,
Jani.
--
Jani Nikula, Intel
On Fri, 26 Jul 2024, Thomas Weißschuh wrote:
> Instead of manually passing around 'struct edid *' and its size,
> use 'struct drm_edid', which encapsulates a validated combination of
> both.
>
> As the drm_edid_ can handle NULL gracefully, the explicit checks can be
> dropped.
>
> Also save a few
Am 26.07.24 um 14:52 schrieb Alex Deucher:
On Fri, Jul 26, 2024 at 3:05 AM Christian König
wrote:
Am 25.07.24 um 20:09 schrieb Nikita Zhandarovich:
Several cs track offsets (such as 'track->db_s_read_offset')
either are initialized with or plainly take big enough values that,
once shifted 8 bi
On 7/29/2024 11:17 AM, Lazar, Lijo wrote:
On 7/29/2024 11:08 AM, Khatri, Sunil wrote:
On 7/29/2024 10:08 AM, Lazar, Lijo wrote:
On 7/27/2024 12:51 AM, Khatri, Sunil wrote:
On 7/27/2024 12:13 AM, Alex Deucher wrote:
On Fri, Jul 26, 2024 at 1:16 PM Khatri, Sunil wrote:
On 7/26/2024 8:36 PM
[Public]
Hi,
Thanks for the report.
Patch fa57924c76d995 ("drm/amd/display: Refactor function
dm_dp_mst_is_port_support_mode()")
is kind of correcting problems causing by commit:
4df96ba6676034 ("drm/amd/display: Add timing pixel encoding for mst mode
validation")
Sorry if it misses fixes tag
I merged this patch into drm-misc-next.
Am 11.07.24 um 07:27 schrieb Easwar Hariharan:
I2C v7, SMBus 3.2, and I3C 1.1.1 specifications have replaced "master/slave"
with more appropriate terms. Inspired by Wolfram's series to fix drivers/i2c/,
fix the terminology for users of I2C_ALGOBIT bitbangi
42 matches
Mail list logo