Adds a check in the map_hw_resources function to prevent a potential
buffer overflow. The function was accessing arrays using an index that
could potentially be greater than the size of the arrays, leading to a
buffer overflow.
Adds a check to ensure that the index is within the bounds of the
arra
[AMD Official Use Only - General]
Reviewed-by: Tao Zhou
> -Original Message-
> From: amd-gfx On Behalf Of
> Stanley.Yang
> Sent: Wednesday, February 21, 2024 10:27 PM
> To: amd-gfx@lists.freedesktop.org
> Cc: Yang, Stanley
> Subject: [PATCH Review 1/1] drm/amdgpu: Fix ineffective ras_m
This is useful to prevent copy-on-write semantics
from changing the physical location of a page if
the parent writes to it after a fork().
Signed-off-by: Lang Yu
---
drivers/gpu/drm/amd/amdgpu/amdgpu_ttm.c | 1 +
drivers/gpu/drm/amd/amdkfd/kfd_svm.c| 1 +
2 files changed, 2 insertions(+)
di
Hi All,
Even using the older stock Ubuntu kernel, I am still seeing this GPU crash
killing my user sessions, even without intense 3-D activity.
It happens with X.org or Wayland, older kernel 6.5.0, and all recent latest
non-snapshot releases from kernel.org as well.
The more Wayland, and the n
On 1/28/24 02:04, Lenko Donchev wrote:
We are trying to get rid of all multiplications from allocation
functions to prevent integer overflows. Here the multiplication is
obviously safe, but using kcalloc() is more appropriate and improves
readability. This patch has no effect on runtime behavi
On Wed, Feb 21, 2024 at 2:31 PM Joao Paulo Pereira da Silva
wrote:
>
> While debugging with ftrace, it's useful to create filters to search
> within the codebase. However, since some function names lack prefixes,
> creating a good filter may become more difficult.
>
> Because of this, add prefix t
Applied. Thanks!
On Wed, Feb 21, 2024 at 6:08 AM Christian König
wrote:
>
> Am 21.02.24 um 10:59 schrieb Kunwu Chan:
> > For where the cache name and the structure name match.
> > Use the new KMEM_CACHE() macro instead of direct kmem_cache_create
> > to simplify the creation of SLAB caches.
>
>
While debugging with ftrace, it's useful to create filters to search
within the codebase. However, since some function names lack prefixes,
creating a good filter may become more difficult.
Because of this, add prefix to functions declared inside the header
dcn10/dcn10_cm_common.h to facilitate cr
On 2024-02-21 05:54, Jonathan Kim wrote:
Prevent dropping the KFD process reference at the end of a debug
IOCTL call where the acquired process value is an error.
Signed-off-by: Jonathan Kim
Reviewed-by: Felix Kuehling
---
drivers/gpu/drm/amd/amdkfd/kfd_chardev.c | 1 +
1 file change
On 21/02/2024 12:18, Arunpravin Paneer Selvam wrote:
Add a function to support defragmentation.
v1:
- Defragment the memory beginning from min_order
till the required memory space is available.
v2(Matthew):
- add amdgpu user for defragmentation
- add a warning if the two blocks ar
[AMD Official Use Only - General]
The series of 4 patches are:
Reviewed-by: Leo Liu
> -Original Message-
> From: amd-gfx On Behalf Of Alex
> Deucher
> Sent: Wednesday, February 21, 2024 12:00 PM
> To: amd-gfx@lists.freedesktop.org
> Cc: Zhang, Yifan ; Deucher, Alexander
>
> Subject: [P
Hi Túlio,
First of all thanks for your patch. See my comments inline.
On 2/17/24 13:20, Túlio Fernandes wrote:
Clean unnecessary braces in dc/dcn32/dcn32_resource_helpers.c and
dc/dcn32/dcn201_link_encoder.c
Did you identify this issue with checkpatch? If so, I recommend you
paste the error
On 21/02/2024 12:40, Paneer Selvam, Arunpravin wrote:
On 2/16/2024 5:33 PM, Matthew Auld wrote:
On 08/02/2024 15:49, Arunpravin Paneer Selvam wrote:
- Add tracking clear page feature.
- Driver should enable the DRM_BUDDY_CLEARED flag if it
successfully clears the blocks in the free path. O
On 2/15/24 05:57, Srinivasan Shanmugam wrote:
The is_psr_su parameter is a boolean flag indicating whether the Panel
Self Refresh Selective Update (PSR SU) feature is enabled which is a
power-saving feature that allows only the updated regions of the screen
to be refreshed, reducing the amount
From: Veerabadhran Gopalakrishnan
Enabled the VCN Power Gating and Clock Gating flags for VCN 4.0.6.
Signed-off-by: Veerabadhran Gopalakrishnan
Signed-off-by: Alex Deucher
---
drivers/gpu/drm/amd/amdgpu/soc21.c | 9 +++--
1 file changed, 7 insertions(+), 2 deletions(-)
diff --git a/drive
From: Veerabadhran Gopalakrishnan
Modified driver to use the appropriate FW files and instance.
v2: squash in fixes (Alex)
Signed-off-by: Veerabadhran Gopalakrishnan
Signed-off-by: Alex Deucher
---
drivers/gpu/drm/amd/amdgpu/amdgpu_vcn.c | 2 ++
drivers/gpu/drm/amd/amdgpu/vcn_v4_0_5.c | 3 ++
From: Yifan Zhang
This patch is to add vcn 4.0.6 support
Signed-off-by: Yifan Zhang
Signed-off-by: Alex Deucher
---
drivers/gpu/drm/amd/amdgpu/amdgpu_discovery.c | 1 +
1 file changed, 1 insertion(+)
diff --git a/drivers/gpu/drm/amd/amdgpu/amdgpu_discovery.c
b/drivers/gpu/drm/amd/amdgpu/amd
From: Veerabadhran Gopalakrishnan
Updated Query Video codecs for VCN 406
Signed-off-by: Veerabadhran Gopalakrishnan
Signed-off-by: Alex Deucher
---
drivers/gpu/drm/amd/amdgpu/soc21.c | 6 ++
1 file changed, 6 insertions(+)
diff --git a/drivers/gpu/drm/amd/amdgpu/soc21.c
b/drivers/gpu/dr
On Tue, Feb 20, 2024 at 2:38 PM Aurabindo Pillai
wrote:
>
> Add new firmware header definitions reqiured for DCN401
>
> Signed-off-by: Aurabindo Pillai
Acked-by: Alex Deucher
> ---
> drivers/gpu/drm/amd/include/atomfirmware.h | 33 ++
> 1 file changed, 33 insertions(+)
>
>
On Wed, Feb 21, 2024 at 1:06 AM Linux regression tracking (Thorsten
Leemhuis) wrote:
>
> On 20.02.24 21:18, Alex Deucher wrote:
> > On Tue, Feb 20, 2024 at 2:41 PM Romano wrote:
> >>
> >> If the increased low range is allowed via boot option, like in proposed
> >> patch, user clearly made an inte
On 2/21/2024 03:35, Ma Jun wrote:
Don't set power state flag when system enter runtime suspend,
or it may cause runtime resume failure issue.
Signed-off-by: Ma Jun
Reviewed-by: Mario Limonciello
Please add a fixes tag for 3a9626c816db901def438dc2513622e281186d39 when
committing.
---
d
Am 21.02.24 um 07:06 schrieb Linux regression tracking (Thorsten Leemhuis):
On 20.02.24 21:18, Alex Deucher wrote:
On Tue, Feb 20, 2024 at 2:41 PM Romano wrote:
If the increased low range is allowed via boot option, like in proposed
patch, user clearly made an intentional decision. Undefined,
Adds a check in the map_hw_resources function to prevent a
potential buffer overflow. The function was accessing arrays using an
index that could potentially be greater than the size of the arrays,
leading to a buffer overflow.
Adds a check to ensure that the index is within the bounds of
the arra
Am 21.02.24 um 13:18 schrieb Arunpravin Paneer Selvam:
Add a function to support defragmentation.
Thinking more about it maybe you want to call this function differently.
Essentially we are force merging pages even if their cleared flag
doesn't match, that is something different than defragme
Check amdgpu_ras_mask to fix ineffective ras_mask setting
due to special asic without sram ecc enable but with poison
supported.
Signed-off-by: Stanley.Yang
---
drivers/gpu/drm/amd/amdgpu/amdgpu_ras.c | 1 +
1 file changed, 1 insertion(+)
diff --git a/drivers/gpu/drm/amd/amdgpu/amdgpu_ras.c
b/
Use the new KMEM_CACHE() macro instead of direct kmem_cache_create
to simplify the creation of SLAB caches.
Signed-off-by: Kunwu Chan
---
drivers/gpu/drm/amd/amdgpu/amdgpu_fence.c | 4 +---
1 file changed, 1 insertion(+), 3 deletions(-)
diff --git a/drivers/gpu/drm/amd/amdgpu/amdgpu_fence.c
b/
Use the new KMEM_CACHE() macro instead of direct kmem_cache_create
to simplify the creation of SLAB caches.
Signed-off-by: Kunwu Chan
---
drivers/gpu/drm/amd/amdgpu/amdgpu_sync.c | 4 +---
1 file changed, 1 insertion(+), 3 deletions(-)
diff --git a/drivers/gpu/drm/amd/amdgpu/amdgpu_sync.c
b/dr
For where the cache name and the structure name match.
Use the new KMEM_CACHE() macro instead of direct kmem_cache_create
to simplify the creation of SLAB caches.
Kunwu Chan (3):
drm/amdgpu: Simplify the allocation of fence slab caches
drm/amdgpu: Simplify the allocation of mux_chunk slab cach
Use the new KMEM_CACHE() macro instead of direct kmem_cache_create
to simplify the creation of SLAB caches.
Signed-off-by: Kunwu Chan
---
drivers/gpu/drm/amd/amdgpu/amdgpu_ring_mux.c | 4 +---
1 file changed, 1 insertion(+), 3 deletions(-)
diff --git a/drivers/gpu/drm/amd/amdgpu/amdgpu_ring_mux
On 2/16/2024 5:33 PM, Matthew Auld wrote:
On 08/02/2024 15:49, Arunpravin Paneer Selvam wrote:
- Add tracking clear page feature.
- Driver should enable the DRM_BUDDY_CLEARED flag if it
successfully clears the blocks in the free path. On the otherhand,
DRM buddy marks each block as clea
On 2/16/2024 5:33 PM, Matthew Auld wrote:
On 08/02/2024 15:49, Arunpravin Paneer Selvam wrote:
- Add tracking clear page feature.
- Driver should enable the DRM_BUDDY_CLEARED flag if it
successfully clears the blocks in the free path. On the otherhand,
DRM buddy marks each block as clea
Add a function to support defragmentation.
v1:
- Defragment the memory beginning from min_order
till the required memory space is available.
v2(Matthew):
- add amdgpu user for defragmentation
- add a warning if the two blocks are incompatible on
defragmentation
- call full defragm
Add clear page support in vram memory region.
v1(Christian):
- Dont handle clear page as TTM flag since when moving the BO back
in from GTT again we don't need that.
- Make a specialized version of amdgpu_fill_buffer() which only
clears the VRAM areas which are not already cleared
-
- Add tracking clear page feature.
- Driver should enable the DRM_BUDDY_CLEARED flag if it
successfully clears the blocks in the free path. On the otherhand,
DRM buddy marks each block as cleared.
- Track the available cleared pages size
- If driver requests cleared memory we prefer cleared
Am 21.02.24 um 10:59 schrieb Kunwu Chan:
For where the cache name and the structure name match.
Use the new KMEM_CACHE() macro instead of direct kmem_cache_create
to simplify the creation of SLAB caches.
Reviewed-by: Christian König for the entire
series.
Kunwu Chan (3):
drm/amdgpu: Si
Prevent dropping the KFD process reference at the end of a debug
IOCTL call where the acquired process value is an error.
Signed-off-by: Jonathan Kim
---
drivers/gpu/drm/amd/amdkfd/kfd_chardev.c | 1 +
1 file changed, 1 insertion(+)
diff --git a/drivers/gpu/drm/amd/amdkfd/kfd_chardev.c
b/drive
Don't set power state flag when system enter runtime suspend,
or it may cause runtime resume failure issue.
Signed-off-by: Ma Jun
---
drivers/gpu/drm/amd/amdgpu/amdgpu_acpi.c | 3 +++
1 file changed, 3 insertions(+)
diff --git a/drivers/gpu/drm/amd/amdgpu/amdgpu_acpi.c
b/drivers/gpu/drm/amd/am
On 20.02.24 21:18, Alex Deucher wrote:
> On Tue, Feb 20, 2024 at 2:41 PM Romano wrote:
>>
>> If the increased low range is allowed via boot option, like in proposed
>> patch, user clearly made an intentional decision. Undefined, but won't
>> fry his hardware for sure. Undefined is also overclockin
For Windows, apps like MSI Afterburner is the one to try and what most
people go for. Using it in the past myself, I would be surprised if it
adhered to such a high min power cap. But even if it did, why would we
have to.
Relying on vendors cap in this case has already proven wrong because
th
This setting does not introduce stability problems or bugs.
Voltage/frequency ratio is dynamic relative to power cap, GPU auto
adjust to it. This is not like lowering voltage alone. By lowering GPU
power, it simply auto-adjust its frequency and voltage on the fly and
remain stable without crash
The functions defined in dc/clk_mgr/dcn10/rv1_clk_mgr_vbios_smu.c don't
have names that indicate where they were declared.
To better filter results in debug tools like ftrace, prefix these
functions with 'rv1_clk_mgr_vbios_smu_'.
Signed-off-by: David Tadokoro
---
.../drm/amd/display/dc/clk_mgr/
If the increased low range is allowed via boot option, like in proposed
patch, user clearly made an intentional decision. Undefined, but won't
fry his hardware for sure. Undefined is also overclocking in that
matter. You can go out of range with ratio of voltage vs frequency(still
within vendor
The function defined in dc/clk_mgr/dcn10/rv1_clk_mgr_clk.c doesn't
have a name that indicates where it was declared.
To better filter results in debug tools like ftrace, prefix this
function with 'rv1_clk_mgr_clk_'.
Signed-off-by: David Tadokoro
---
drivers/gpu/drm/amd/display/dc/clk_mgr/dcn10/
This patchset has three commits that add prefix to all the functions defined in
dc/clk_mgr/dcn10 that indicate the file that they were defined. Enforcing this
pattern makes filtering results in debug tools like ftrace better.
David Tadokoro (3):
drm/amd/display: add prefix to rv1_clk_mgr_clk.c f
On 20.02.24 16:27, Hans de Goede wrote:
> Hi,
>
> On 2/20/24 16:15, Alex Deucher wrote:
>> On Tue, Feb 20, 2024 at 10:03 AM Linux regression tracking (Thorsten
>> Leemhuis) wrote:
>>>
>>> On 20.02.24 15:45, Alex Deucher wrote:
On Mon, Feb 19, 2024 at 9:47 AM Linux regression tracking (Tho
On 20.02.24 15:45, Alex Deucher wrote:
> On Mon, Feb 19, 2024 at 9:47 AM Linux regression tracking (Thorsten
> Leemhuis) wrote:
>>
>> On 17.02.24 14:30, Greg KH wrote:
>>> On Sat, Feb 17, 2024 at 02:01:54PM +0100, Roman Benes wrote:
Minimum power limit on latest(6.7+) kernels is 190W for my G
The functions defined in dc/clk_mgr/dcn10/rv1_clk_mgr.c don't have
names that indicates where they were declared.
To better filter results in debug tools like ftrace, prefix these
functions with 'rv1_clk_mgr_'.
Signed-off-by: David Tadokoro
---
.../display/dc/clk_mgr/dcn10/rv1_clk_mgr.c| 22
Hi,
On 2/20/24 16:15, Alex Deucher wrote:
> On Tue, Feb 20, 2024 at 10:03 AM Linux regression tracking (Thorsten
> Leemhuis) wrote:
>>
>> On 20.02.24 15:45, Alex Deucher wrote:
>>> On Mon, Feb 19, 2024 at 9:47 AM Linux regression tracking (Thorsten
>>> Leemhuis) wrote:
On 17.02.24 14:3
48 matches
Mail list logo