tree/branch:
https://git.kernel.org/pub/scm/linux/kernel/git/next/linux-next.git master
branch HEAD: 1acf39ef8f1425cd105f630dc2c7c1d8fff27ed1 Add linux-next specific
files for 20230303
Warning reports:
https://lore.kernel.org/oe-kbuild-all/202302111601.jty4lkra-...@intel.com
https
Applied. Thanks!
Alex
On Fri, Mar 3, 2023 at 7:03 AM Muhammad Usama Anjum
wrote:
>
> The less than zero comparison of unsigned variable "value" is never
> true. Remove dead code.
>
> Fixes: c3ed0e72c872 ("drm/amdgpu: added a sysfs interface for thermal
> throttling")
> Signed-off-by: Muhammad
From: Lijo Lazar
Add initial SMU 13.0.6 implementation.
v1:
Initial implementation to support SMU 13.0.6.
v2:
Add driver interface version check.
v3: rebase (Alex)
v4: Enable i2c for avoid warning (Alex)
v5: sqaush in cleanups up through (Alex)
"drm/amd/pm: Ignore EIO error on SMUv13.0.6"
S
From: Hawking Zhang
Add mp v13_0_6 register offset and shift masks
header files
v2: update headers (Alex)
Signed-off-by: Hawking Zhang
Reviewed-by: Le Ma
Signed-off-by: Alex Deucher
---
.../include/asic_reg/mp/mp_13_0_6_offset.h| 456
.../include/asic_reg/mp/mp_13_0_6_sh_ma
From: Lijo Lazar
Initial version of PMFW interface and message
headers for SMU 13.0.6 support.
v2: squash in location fixes (Alex)
v3: squash in updates (Alex)
Signed-off-by: Lijo Lazar
Reviewed-by: Hawking Zhang
Signed-off-by: Alex Deucher
---
.../inc/pmfw_if/smu13_driver_if_v13_0_6.h
On 1/15/23 05:00, Deepak R Varma wrote:
The if / else block code has same effect irrespective of the logical
evaluation. Hence, simply the implementation by removing the unnecessary
conditional evaluation. While at it, also fix the long line checkpatch
complaint. Issue identified using cond_no_e
On 3/2/23 11:37, Harry Wentland wrote:
>
>
> On 3/1/23 15:21, Deepak R Varma wrote:
>> On Mon, Jan 23, 2023 at 12:23:19AM +0530, Deepak R Varma wrote:
>>> On Sun, Jan 15, 2023 at 12:52:10PM -0800, Joe Perches wrote:
On Sun, 2023-01-15 at 15:30 +0530, Deepak R Varma wrote:
> The if / e
On Thu, Mar 02, 2023 at 11:37:30AM -0500, Harry Wentland wrote:
>
>
> On 3/1/23 15:21, Deepak R Varma wrote:
> > On Mon, Jan 23, 2023 at 12:23:19AM +0530, Deepak R Varma wrote:
> >> On Sun, Jan 15, 2023 at 12:52:10PM -0800, Joe Perches wrote:
> >>> On Sun, 2023-01-15 at 15:30 +0530, Deepak R Varm
Treat the last page in a non-contiguous range as part of the following
contiguous range.
Signed-off-by: Felix Kuehling
Reviewed-by: Philip Yang
Reviewed-and-tested-by: Rajneesh Bhardwaj
Reviewed-by: Christian König
---
drivers/gpu/drm/amd/amdgpu/amdgpu_vm.c | 2 ++
1 file changed, 2 insertion
From: Aric Cyr
In this new version there are two major changes:
1) Transitioning to the new DC commit sequence
There is an extended effort to migrate to the new DC commit sequence
that better adheres to the DCN hardware constraints. Most of the code
was upstreamed already but not connected to a
From: Rodrigo Siqueira
The function dc_update_planes_and_stream handles multiple cases where DC
needs to remove and add planes in the commit tail phase. After Linux
started to use this function, some of the IGT kms_plane started to fail;
one good example to illustrate why the new sequence regress
From: Rodrigo Siqueira
[Why & How]
This commit is part of a sequence of changes that replaces the commit
sequence used in the DC with a new one. As a result of this transition,
we moved some specific parts from the commit sequence and brought them
to amdgpu_dm. This commit adds a wrapper inside D
From: Rodrigo Siqueira
[Why & How]
DC now uses a new commit sequence which is more robust since it
addresses cases where we need to reorganize pipes based on planes and
other parameters. As a result, this new commit sequence reset the DC
state by cleaning plane states and re-creating them accordi
From: Rodrigo Siqueira
[Why & How]
The old dc_commit_updates_for_stream lacks manipulation for many corner
cases where the DC feature requires special attention; as a result, it
starts to show its limitation (e.g., the SubVP feature is not supported
by it, among other cases). To modernize and uni
From: Rodrigo Siqueira
[Why & How]
There are two functions responsible for handling the DC commit state:
dc_commit_state and dc_commit_streams. Both have the same goal, but
dc_commit_streams surpess dc_commit_state in terms of completeness. For
this reason, maintaining these two functions makes m
From: Rodrigo Siqueira
[Why & How]
In the commit 68d1085eb2 ("drm/amd/display: Do not update DRR while
BW optimizations pending"), a modification was added to avoid adjusting
DRR if optimized bandwidth is set. This change was only intended for
DCN, but one part of the patch changed the code path
From: Alvin Lee
[Description]
- For pipe harvesting cases, the pipe index does not necessarily
match up with the OTG instance, so pass index by OTG Instance instead
- For pipe split cases pass HUBP instance, since the split index is
only used for HUBP programming
- Also check for OPP ID when
From: Gabe Teeger
[Why]
There is underflow and flickering occuring. The
underflow stops when hostvm is forced to active.
According to policy, hostvm should be enabled if riommu
is active, but this is not taken into account when
deciding whether to enable hostvm.
[What]
For DCN314, set hostvm to
From: Wayne Lin
[Why & How]
drm_dp_remove_payload() interface was changed. Correct amdgpu dm code
to pass the right parameter to the drm helper function.
Reviewed-by: Jerry Zuo
Acked-by: Qingqing Zhuo
Signed-off-by: Wayne Lin
---
.../amd/display/amdgpu_dm/amdgpu_dm_helpers.c | 57 +++
From: Alvin Lee
[Description]
- For min FCLK, choose the min of 300Mhz and PMFW requirement
- Also only apply min DET check in DML for non-UR cases
Reviewed-by: Jun Lei
Acked-by: Qingqing Zhuo
Signed-off-by: Alvin Lee
---
drivers/gpu/drm/amd/display/dc/dml/dcn32/dcn32_fpu.c| 5 +++--
From: Harry Wentland
[Why & How]
The only reason we have the DCN config is for
floating point support. Rename it to make that
clear and (hopefully) avoid misuse of the config
in the future.
Reviewed-by: Rodrigo Siqueira
Acked-by: Qingqing Zhuo
Signed-off-by: Harry Wentland
---
drivers/gpu/dr
From: Harry Wentland
[Why & How]
DC is littered with many DCN guards that are not needed.
Drop them.
Reviewed-by: Rodrigo Siqueira
Acked-by: Qingqing Zhuo
Signed-off-by: Harry Wentland
---
.../drm/amd/display/dc/core/dc_vm_helper.c| 2 --
drivers/gpu/drm/amd/display/dc/dc_dmub_srv.c |
From: Harry Wentland
[Why]
DM is littered with DCN guards leading to frequent
breakages on non-DCN builds when new code is added.
[How]
Remove all guards that are not needed.
Reviewed-by: Rodrigo Siqueira
Acked-by: Qingqing Zhuo
Signed-off-by: Harry Wentland
---
.../gpu/drm/amd/display/amdg
From: Agustin Gutierrez
[Why]
Current hotplug sequence causes temporary hang at the re-entry of the
optimized power state.
[How]
Keep a PHY active when detecting DP signal + DPMS active
Reviewed-by: Nicholas Kazlauskas
Acked-by: Qingqing Zhuo
Signed-off-by: Agustin Gutierrez
---
.../gpu/drm
From: Chris Park
[Why]
Runtime initialization of register addresses define
duplicate register offsets in resource file, and makes
register offsets in sub-block defined for compile
time initialization obsolete.
[How]
Remove obsolete sub block register offsets that is
no longer referenced.
Review
From: Wenjing Liu
[why]
Link components should not reply on dc_link_exports to access link function in
other link components.
Reviewed-by: Jun Lei
Acked-by: Qingqing Zhuo
Signed-off-by: Wenjing Liu
---
.../display/dc/dcn31/dcn31_dio_link_encoder.c | 5 ++--
.../display/dc/link/accessories/l
From: Wenjing Liu
[why]
link component should only have one interface serving dc.
[how]
We are moving dc_link functions exposed to DM to dc_link_exports
and unify link component interface in link.h with function pointer
to match the style of other dc component. This is the third step to move
dc_
From: Wenjing Liu
[Why & How]
- We have added link_dp_dpia_bw code but it is not currently
added in makefile. We are adding this to makefile so it would
be built.
- Remove unused dc_link.h
Reviewed-by: Jun Lei
Acked-by: Qingqing Zhuo
Signed-off-by: Wenjing Liu
---
drivers/gpu/drm/amd/display
From: Wenjing Liu
[why]
link component should only have one interface serving dc.
[how]
We are moving dc_link functions exposed to DM to dc_link_exports
and unify link component interface in link.h with function pointer
to match the style of other dc component. This is the second step to move
dc
From: Wenjing Liu
[why]
link component should only have one interface serving dc.
[how]
We are moving dc_link functions exposed to DM to dc_link_exports
and unify link component interface in link.h with function pointer
to match the style of other dc component. This is the first step to move
dc_
From: Harry Wentland
[Why & How]
DSC needs DCN but we are trying reduce the usage of the
DCN flag. It's easier to build the DSC code sprinkled
around DC core and the DMs and just guard the place where
DSC uses floating point code.
Since DSC is never enabled on non-DCN ASICs this won't
have any e
From: Harry Wentland
[Why & How]
DM should never use a non-interface function to call into
DC. The original code is incorrect on ASICs that don't
use DCN20's remove_stream_from_ctx function.
Reviewed-by: Aurabindo Pillai
Acked-by: Qingqing Zhuo
Signed-off-by: Harry Wentland
---
.../gpu/drm/a
From: Harry Wentland
[Why & How]
There is no reason we still need a config option for this.
Reviewed-by: Wenjing Liu
Acked-by: Qingqing Zhuo
Signed-off-by: Harry Wentland
---
drivers/gpu/drm/amd/display/Kconfig | 6 -
drivers/gpu/drm/amd/display/Makefile | 4
..
From: Mike Hsieh
[WHY]
There is a typo in dc_dsc_config_options structure
[HOW]
Fix the typo
Reviewed-by: Wenjing Liu
Acked-by: Qingqing Zhuo
Signed-off-by: Mike Hsieh
---
drivers/gpu/drm/amd/display/dc/dc_dsc.h | 2 +-
drivers/gpu/drm/amd/display/dc/dsc/dc_dsc.c | 6 +++---
2 files cha
From: Harry Wentland
[Why & How]
This fixes a couple misplaced CONFIG_DRM_AMD_DC_DCN
blocks.
Reviewed-by: Sun peng Li
Acked-by: Qingqing Zhuo
Signed-off-by: Harry Wentland
---
drivers/gpu/drm/amd/display/amdgpu_dm/amdgpu_dm_mst_types.c | 3 +++
1 file changed, 3 insertions(+)
diff --git a/d
From: Harry Wentland
[Why & How]
Remove dead code.
Reviewed-by: Sun peng Li
Acked-by: Qingqing Zhuo
Signed-off-by: Harry Wentland
---
.../amd/display/amdgpu_dm/amdgpu_dm_plane.c | 129 --
1 file changed, 129 deletions(-)
diff --git a/drivers/gpu/drm/amd/display/amdgpu_dm/a
From: Nicholas Kazlauskas
[Why]
Block periods that are too short as they have the potential to
currently cause hangs in other firmware components on the system.
[How]
Update the threshold, mostly targeting a block of 4k and downscaling.
Reviewed-by: Jun Lei
Acked-by: Qingqing Zhuo
Signed-off-
From: Nicholas Kazlauskas
[Why]
Allows finer control and tuning for debug and profiling.
[How]
Add the debug option into DC. The default remains the same as before
for now.
Reviewed-by: Jun Lei
Acked-by: Qingqing Zhuo
Signed-off-by: Nicholas Kazlauskas
---
drivers/gpu/drm/amd/display/dc/dc.
From: Aric Cyr
This version brings along the following:
- Correct way to find OPP index
- Unify DC logging for BW Alloc
- Add height granularity limitation for dsc slice height calculation
Acked-by: Qingqing Zhuo
Signed-off-by: Aric Cyr
---
drivers/gpu/drm/amd/display/dc/dc.h | 2 +-
1 file c
From: Alvin Lee
[Description]
For pipe harvesting cases we cannot rely on array index
to get the correct OPP instance, we must loop through
each instance to find the correct one.
Reviewed-by: Jun Lei
Acked-by: Qingqing Zhuo
Signed-off-by: Alvin Lee
---
.../drm/amd/display/dc/dcn32/dcn32_hwse
From: Mustapha Ghaddar
[WHY]
To keep all logging within DC unified
[HOW]
Use the standard DC Logging functions
Reviewed-by: Wenjing Liu
Reviewed-by: Meenakshikumar Somasundaram
Acked-by: Qingqing Zhuo
Signed-off-by: Mustapha Ghaddar
---
.../dc/link/protocols/link_dp_dpia_bw.c | 56 ++
From: Mike Hsieh
[WHY]
eDP add new limitation for Y granularity for selected update feature.
DSC does not include this limitation while calculating slice height.
[HOW]
Add new limitation while looking for DSC slice height.
Reviewed-by: Cruise Hung
Acked-by: Qingqing Zhuo
Signed-off-by: Mike H
This DC patchset brings improvements in multiple areas. In summary, we
highlight:
1) Transitioning to the new DC commit sequence
There is an extended effort to migrate to the new DC commit sequence
that better adheres to the DCN hardware constraints. Most of the code
was upstreamed already but n
On Fri, Mar 03, 2023 at 03:55:56PM +0100, Michel Dänzer wrote:
> On 3/3/23 08:16, Somalapuram Amaranath wrote:
> > Change the ttm_place structure member fpfn, lpfn, mem_type to
> > res_start, res_end, res_type.
> > Change the unsigned to u64.
> > Fix the dependence in all the DRM drivers and
> > cl
On 3/3/23 08:16, Somalapuram Amaranath wrote:
> Change the ttm_place structure member fpfn, lpfn, mem_type to
> res_start, res_end, res_type.
> Change the unsigned to u64.
> Fix the dependence in all the DRM drivers and
> clean up PAGE_SHIFT operation.
>
> Signed-off-by: Somalapuram Amaranath
>
Hi Marek,
Thank you for the patch! Perhaps something to improve:
[auto build test WARNING on drm-misc/drm-misc-next]
[also build test WARNING on drm/drm-next drm-intel/for-linux-next
drm-tip/drm-tip linus/master next-20230303]
[cannot apply to drm-intel/for-linux-next-fixes v6.2]
[If your patch
The less than zero comparison of unsigned variable "value" is never
true. Remove dead code.
Fixes: c3ed0e72c872 ("drm/amdgpu: added a sysfs interface for thermal
throttling")
Signed-off-by: Muhammad Usama Anjum
---
drivers/gpu/drm/amd/pm/amdgpu_pm.c | 2 +-
1 file changed, 1 insertion(+), 1 del
Commit 3840c5bcc245 ("drm/amdgpu: disentangle runtime pm and
vga_switcheroo") made amdgpu only register a vga_switcheroo client for
GPU's with PX, however AMD GPUs in dual gpu Apple Macbooks do need to
register, but don't have PX. Instead of AMD's PX, they use apple-gmux.
Use apple_gmux_detect() t
On 2023-02-28 03:33, Christian König wrote:
> This adds the infrastructure for an execution context for GEM buffers
> which is similar to the existinc TTMs execbuf util and intended to replace
> it in the long term.
>
> The basic functionality is that we abstracts the necessary loop to lock
> many
On 2023-02-28 14:13, Danilo Krummrich wrote:
> On 2/28/23 09:33, Christian König wrote:
>> This adds the infrastructure for an execution context for GEM buffers
>> which is similar to the existinc TTMs execbuf util and intended to replace
>
> "existing"
>
>> it in the long term.
>>
>> The basic f
Well big NAK to this!
We have discussed this extensively on the mailing list and absolutely
don't want to allow that.
Only for some ARM drivers we failed to block that soon enough and will
keep the functionality around to not break userspace.
Regards,
Christian.
Am 03.03.23 um 12:09 schrie
Use dmabuf mmap from exporting driver to do the mapping.
Signed-off-by: Marek Maslanka
Signed-off-by: Dominik Behr
---
drivers/gpu/drm/amd/amdgpu/amdgpu_dma_buf.c | 46 +
drivers/gpu/drm/amd/amdgpu/amdgpu_dma_buf.h | 2 +
drivers/gpu/drm/amd/amdgpu/amdgpu_drv.c | 2 +-
52 matches
Mail list logo