[AMD Official Use Only - General]
Reviewed-by: Feifei Xu
-Original Message-
From: amd-gfx On Behalf Of Evan Quan
Sent: Friday, January 20, 2023 11:28 AM
To: amd-gfx@lists.freedesktop.org
Cc: Deucher, Alexander ; Quan, Evan
Subject: [PATCH] drm/amd/pm: add missing AllowIHInterrupt
On 2023-01-19 11:56, Krylov Michael wrote:
> On Thu, 15 Dec 2022 07:07:33 -0500
> Luben Tuikov wrote:
>
>> On 2022-12-15 06:53, Robin Murphy wrote:
>>> On 2022-12-15 11:40, Luben Tuikov wrote:
On 2022-12-15 06:27, Christian König wrote:
> Am 15.12.22 um 11:19 schrieb Luben Tuikov:
>>
Add SMU13.0.0 AllowIHInterrupt message mapping.
Signed-off-by: Evan Quan
Change-Id: Ief5f12215572a8029970e79814495e67d20f2388
---
drivers/gpu/drm/amd/pm/swsmu/smu13/smu_v13_0_0_ppt.c | 1 +
1 file changed, 1 insertion(+)
diff --git a/drivers/gpu/drm/amd/pm/swsmu/smu13/smu_v13_0_0_ppt.c
b/drive
[AMD Official Use Only - General]
Reviewed-by: Graham Sider
-Original Message-
From: Kim, Jonathan
Sent: Thursday, January 19, 2023 7:44 PM
To: amd-gfx@lists.freedesktop.org
Cc: Sider, Graham ; Kuehling, Felix
; Kim, Jonathan ; Sider, Graham
Subject: [PATCH] drm/amdgpu: remove uncon
Rebase of driver has incorrect unconditional trap enablement
for GFX11 when adding mes queues.
Reported-by: Graham Sider
Signed-off-by: Jonathan Kim
---
drivers/gpu/drm/amd/amdgpu/mes_v11_0.c | 1 -
1 file changed, 1 deletion(-)
diff --git a/drivers/gpu/drm/amd/amdgpu/mes_v11_0.c
b/drivers/gp
From: Wayne Lin
[why & how]
The term (i.e. port & mst_port) that we used to use in amdgpu is a bit
confusing. Rename them to mst_output_port & mst_root respectively.
Signed-off-by: Wayne Lin
Signed-off-by: Harry Wentland
Acked-by: Harry Wentland
---
drivers/gpu/drm/amd/amdgpu/amdgpu_mode.h
From: Wayne Lin
[why & how]
adjust the coding in dm_helpers_dp_mst_send_payload_allocation()
for reading easily.
Signed-off-by: Wayne Lin
Signed-off-by: Harry Wentland
Acked-by: Harry Wentland
---
drivers/gpu/drm/amd/display/amdgpu_dm/amdgpu_dm_helpers.c | 6 +-
1 file changed, 5 inserti
From: Wayne Lin
[Why]
amdgpu expects to update payload table for one stream one time
by calling dm_helpers_dp_mst_write_payload_allocation_table().
Currently, it get modified to try to update HW payload table
at once by referring mst_state.
[How]
This is just a quick workaround. Should find way
From: Wayne Lin
[Why & How]
Now the vc_start_slot is controlled at drm side. When we
service a long HPD, we still need to run
dm_helpers_dp_mst_write_payload_allocation_table() to update
drm mst_mgr's relevant variable. Otherwise, on the next plug-in,
payload will get assigned with a wrong start
From: Wayne Lin
[why & how]
We still need to refer to port while removing payload at commit_tail.
we should keep the kref till then to release.
Bug: https://gitlab.freedesktop.org/drm/amd/-/issues/2171
Signed-off-by: Wayne Lin
Signed-off-by: Harry Wentland
Fixes: 4d07b0bc4034 ("drm/display/dp_
From: Wayne Lin
[why & how]
__drm_dbg() parameter set format is wrong and not aligned with the
format under CONFIG_DRM_USE_DYNAMIC_DEBUG is on. Fix it.
Signed-off-by: Wayne Lin
Signed-off-by: Harry Wentland
Acked-by: Harry Wentland
---
include/drm/drm_print.h | 2 +-
1 file changed, 1 insert
From: Lyude Paul
Looks like I made a pretty big mistake here without noticing: it seems when
I moved the assignments of mst_state->pbn_div I completely missed the fact
that the reason for us calling drm_dp_mst_update_slots() earlier was to
account for the fact that we need to call this function u
MST has been broken on amdgpu after a refactor in drm_dp_mst
code that was aligning drm_dp_mst more closely with the atomic
model.
The gitlab issue: https://gitlab.freedesktop.org/drm/amd/-/issues/2171
This series fixes it.
It can be found at
https://gitlab.freedesktop.org/hwentland/linux/-/tree
On 1/19/23 18:14, Melissa Wen wrote:
On 01/17, Joshua Ashton wrote:
Implements the 'content type' property for HDMI connectors.
Verified by checking the avi infoframe on a connected TV.
This also simplifies a lot of the code in that area as well, there were
a lot of temp variables doing very
On Thu, Jan 19, 2023 at 09:06:54AM +0100, Thomas Zimmermann wrote:
> Hi
>
> Am 18.01.23 um 20:21 schrieb Rodrigo Vivi:
> > On Thu, Jan 12, 2023 at 09:11:55PM +0100, Thomas Zimmermann wrote:
> > > Set the framebuffer info for drivers that support VGA switcheroo. Only
> > > affects the amdgpu and no
This patch enables the IH retry CAM on GFX9 series cards. This
retry filter is used to prevent sending lots of retry interrupts
in a short span of time and overflowing the IH ring buffer. This
will also help reduce CPU interrupt workload.
Signed-off-by: Mukul Joshi
---
v1:
- Reviewed by Felix.
v
[AMD Official Use Only - General]
Reviewed-by Alex Deucher
From: amd-gfx on behalf of Mario
Limonciello
Sent: Thursday, January 19, 2023 4:15 PM
To: amd-gfx@lists.freedesktop.org
Cc: Limonciello, Mario
Subject: [PATCH] Documentation: gpu: Fix number of column
A new column was added for MP0 version, but the table is imported
into an RST file and that needs to be accounted for.
Fixes: 393c5b8fa8d85 ("Documentation/gpu: Add MP0 version to
apu-asic-info-table")
Signed-off-by: Mario Limonciello
---
Documentation/gpu/amdgpu/driver-misc.rst | 2 +-
1 file
Hi Dave, Daniel,
Fixes for 6.2.
The following changes since commit e695bc7e542358978434c8489a5a164d2bbefae8:
Merge tag 'drm-msm-fixes-2023-01-12' of
https://gitlab.freedesktop.org/drm/msm into drm-fixes (2023-01-13 13:01:22
+1000)
are available in the Git repository at:
https://gitlab.fr
On 1/19/23 13:14, Melissa Wen wrote:
> On 01/17, Joshua Ashton wrote:
>> Implements the 'content type' property for HDMI connectors.
>> Verified by checking the avi infoframe on a connected TV.
>>
>> This also simplifies a lot of the code in that area as well, there were
>> a lot of temp variabl
lmers
> > > Acked-by: Rodrigo Siqueira
> > > Signed-off-by: Wenjing Liu
> >
> > I haven't done a bisection, but I am getting build failures due to code
> > added by this patch (d5a43956b73bd in next-20230119) when running
> > allmodconfig for RISC-V with gcc
by: Wesley Chalmers
> > Acked-by: Rodrigo Siqueira
> > Signed-off-by: Wenjing Liu
>
> I haven't done a bisection, but I am getting build failures due to code
> added by this patch (d5a43956b73bd in next-20230119) when running
> allmodconfig for RISC-V wit
On Thu, 15 Dec 2022 07:07:33 -0500
Luben Tuikov wrote:
> On 2022-12-15 06:53, Robin Murphy wrote:
> > On 2022-12-15 11:40, Luben Tuikov wrote:
> >> On 2022-12-15 06:27, Christian König wrote:
> >>> Am 15.12.22 um 11:19 schrieb Luben Tuikov:
> On 2022-12-15 04:46, Christian König wrote:
> >>>
patch (d5a43956b73bd in next-20230119) when running
allmodconfig for RISC-V with gcc-11.
drivers/gpu/drm/amd/amdgpu/../display/dc/link/link_dp_capability.c:233:21:
error: 'union hdmi_encoded_link_bw' declared inside parameter list will not be
visible outside of this definition o
tree/branch:
https://git.kernel.org/pub/scm/linux/kernel/git/next/linux-next.git master
branch HEAD: aa5c49149a823599764e6953229b028e4bf6e9cc Add linux-next specific
files for 20230119
Error/Warning reports:
https://lore.kernel.org/oe-kbuild-all/202301191616.r33dvxk4-...@intel.com
https
On 01/17, Joshua Ashton wrote:
> This was never filled in and thus never truly used.
>
> Checking the EDID for content_type support is not required for sending
> the avi infoframe packet.
>
> Signed-off-by: Joshua Ashton
> ---
> drivers/gpu/drm/amd/display/dc/dc_stream.h | 1 -
> drivers/gpu/d
On 01/17, Joshua Ashton wrote:
> Implements the 'content type' property for HDMI connectors.
> Verified by checking the avi infoframe on a connected TV.
>
> This also simplifies a lot of the code in that area as well, there were
> a lot of temp variables doing very little and unnecessary logic
> t
On 1/18/2023 15:14, Alex Deucher wrote:
Update to the latest launched dGPUs.
Link: https://www.amd.com/en/graphics/radeon-rx-graphics
Link: https://www.amd.com/en/graphics/amd-radeon-rx-laptops
Signed-off-by: Alex Deucher
Reviewed-by: Mario Limonciello
---
Documentation/gpu/amdgpu/dgpu-a
On Thu, Jan 19, 2023 at 8:16 AM Lijo Lazar wrote:
>
> Only Navi1x requires dummy read workaround. Allocate the table in VRAM
> only for Navi1x.
>
> Signed-off-by: Lijo Lazar
Acked-by: Alex Deucher
> ---
> drivers/gpu/drm/amd/pm/swsmu/amdgpu_smu.c | 5 ++---
> drivers/gpu/drm/amd/pm/swsm
Only Navi1x requires dummy read workaround. Allocate the table in VRAM
only for Navi1x.
Signed-off-by: Lijo Lazar
---
drivers/gpu/drm/amd/pm/swsmu/amdgpu_smu.c | 5 ++---
drivers/gpu/drm/amd/pm/swsmu/smu11/navi10_ppt.c | 6 ++
2 files changed, 8 insertions(+), 3 deletions(-)
diff --gi
Am 19.01.23 um 11:26 schrieb Daniel Vetter:
[SNIP]
I guess next step is that people will use chatgpt to write the patches for
these bugs.
To be honest I think that would result in quite some improvement in the
average patch quality.
That guessing this AI does has at least a statistically pro
On Thu, Jan 12, 2023 at 05:45:42PM +0100, Greg KH wrote:
> On Thu, Jan 12, 2023 at 04:26:45PM +0100, Daniel Vetter wrote:
> > On Thu, 12 Jan 2023 at 13:47, Greg KH wrote:
> > > On Wed, Jan 04, 2023 at 07:56:33PM +0200, Dragos-Marian Panait wrote:
> > > > From: Jiasheng Jiang
> > > >
> > > > [ Ups
Hi
Am 18.01.23 um 20:21 schrieb Rodrigo Vivi:
On Thu, Jan 12, 2023 at 09:11:55PM +0100, Thomas Zimmermann wrote:
Set the framebuffer info for drivers that support VGA switcheroo. Only
affects the amdgpu and nouveau drivers, which use VGA switcheroo and
generic fbdev emulation. For other drivers
33 matches
Mail list logo