[AMD Official Use Only]
Verified on Yellow Carp.
Acked-by: Aaron Liu
--
Best Regards
Aaron Liu
> -Original Message-
> From: Kazlauskas, Nicholas
> Sent: Tuesday, September 14, 2021 3:26 AM
> To: Alex Deucher
> Cc: amd-gfx list ; Liu, Aaron
>
> Subject: Re: [PATCH] drm/amd/display: Fi
[AMD Official Use Only]
Driver can exchange the custom profiling settings with SMU FW using the table
below:
TABLE_CUSTOM_DPM
And the related data structure is CustomDpmSettings_t.
BR
Evan
> -Original Message-
> From: Alex Deucher
> Sent: Monday, September 13, 2021 11:11 PM
> To: Danie
These bits are de-facto part of the uAPI, so declare them in a uAPI header.
The corresponding bit-fields and enums in user mode are defined in
https://github.com/RadeonOpenCompute/ROCT-Thunk-Interface/blob/master/include/hsakmttypes.h
HSA_CAP_... -> HSA_CAPABILITY
HSA_MEM_HEAP_TYPE_...
SVM range may includes multiple VMAs with different vm_flags, if prange
page index is the last page of the VMA offset + npages, update GPU
mapping to create GPU page table with same VMA access permission.
Signed-off-by: Philip Yang
---
drivers/gpu/drm/amd/amdkfd/kfd_svm.c | 2 ++
1 file changed,
On 2021-09-13 3:13 p.m., Alex Deucher wrote:
Acked-by: Alex Deucher
Can you add a fixes: tag?
Alex
Sure, I think the relevant patch is:
Fixes: 64b1d0e8d50 ("drm/amd/display: Add DCN3.1 HWSEQ")
Regards,
Nicholas Kazlauskas
On Mon, Sep 13, 2021 at 3:11 PM Nicholas Kazlauskas
wrote:
[Wh
Am 13.09.21 um 19:27 schrieb Anson Jacob:
Remove unused variable 'size'.
Signed-off-by: Anson Jacob
Yeah, that's because of the recent change that we now use the same size
for everything.
Reviewed-by: Christian König
---
drivers/gpu/drm/amd/amdgpu/amdgpu_ib.c | 1 -
1 file changed, 1
Acked-by: Alex Deucher
Can you add a fixes: tag?
Alex
On Mon, Sep 13, 2021 at 3:11 PM Nicholas Kazlauskas
wrote:
>
> [Why]
> The "base_addr_is_mc_addr" field was added for dcn3.1 support but
> pa_config was never updated to set it to false.
>
> Uninitialized memory causes it to be set to true
[Why]
The "base_addr_is_mc_addr" field was added for dcn3.1 support but
pa_config was never updated to set it to false.
Uninitialized memory causes it to be set to true which results in
address mistranslation and white screen.
[How]
Use memset to ensure all fields are initialized to 0 by default.
On Tue, Sep 7, 2021 at 9:42 PM Mike Lothian wrote:
>
> Hi
>
> I've just tested this out against Linus's tree and it seems to fix things
>
> Out of interest does Tonga have GPU reset when things go wrong?
Yes, it does.
Alex
>
> Thanks
>
> Mike
>
> On Tue, 7 Sept 2021 at 15:20, Harry Wentland wr
Applied. Thanks!
Alex
On Mon, Sep 13, 2021 at 11:24 AM Harry Wentland wrote:
>
> On 2021-09-10 11:37 a.m., Simon Ser wrote:
> > This patch allows panel orientation quirks from DRM core to be
> > used. They attach a DRM connector property "panel orientation"
> > which indicates in which directio
Reviewed-by: Alex Deucher
On Mon, Sep 13, 2021 at 1:28 PM Anson Jacob wrote:
>
> Remove unused variable 'size'.
>
> Signed-off-by: Anson Jacob
> ---
> drivers/gpu/drm/amd/amdgpu/amdgpu_ib.c | 1 -
> 1 file changed, 1 deletion(-)
>
> diff --git a/drivers/gpu/drm/amd/amdgpu/amdgpu_ib.c
> b/driv
Remove unused variable 'size'.
Signed-off-by: Anson Jacob
---
drivers/gpu/drm/amd/amdgpu/amdgpu_ib.c | 1 -
1 file changed, 1 deletion(-)
diff --git a/drivers/gpu/drm/amd/amdgpu/amdgpu_ib.c
b/drivers/gpu/drm/amd/amdgpu/amdgpu_ib.c
index 9274f32c3661..bc1297dcdf97 100644
--- a/drivers/gpu/drm/a
Reviewed-by: Alex Deucher
On Mon, Sep 13, 2021 at 12:56 PM Anson Jacob wrote:
>
> Add dummy function when CONFIG_HSA_AMD is not enabled.
>
> Fixes: 433d2448d57c ("drm/amdkfd: separate kfd_iommu_resume from kfd_resume")
> Signed-off-by: Anson Jacob
> ---
> drivers/gpu/drm/amd/amdgpu/amdgpu_amdk
Add dummy function when CONFIG_HSA_AMD is not enabled.
Fixes: 433d2448d57c ("drm/amdkfd: separate kfd_iommu_resume from kfd_resume")
Signed-off-by: Anson Jacob
---
drivers/gpu/drm/amd/amdgpu/amdgpu_amdkfd.h | 5 +
1 file changed, 5 insertions(+)
diff --git a/drivers/gpu/drm/amd/amdgpu/amdgp
Applied. Thanks.
Alex
On Mon, Sep 13, 2021 at 4:46 AM Paul Menzel wrote:
>
> As the user cannot do anything about the unsupported Trusted Memory Zone
> (TMZ) feature, do not warn about it, but make it informational, so
> demote the log level from warning to info.
>
> Signed-off-by: Paul Menzel
Applied. Thanks!
Alex
On Thu, Sep 9, 2021 at 2:07 PM Lyude Paul wrote:
>
> Reviewed-by: Lyude Paul
>
> On Thu, 2021-09-09 at 18:56 +0200, Michel Dänzer wrote:
> > From: Michel Dänzer
> >
> > This was unusual; normally, inline functions are declared static as
> > well, and defined in a header
On 2021-09-13 18:28, Felix Kuehling wrote:
> Am 2021-09-13 um 12:18 p.m. schrieb Michel Dänzer:
>> On 2021-09-13 17:19, Felix Kuehling wrote:
>>> Am 2021-09-13 um 10:19 a.m. schrieb Michel Dänzer:
From: Michel Dänzer
Avoids warning with -Wformat:
CC [M] drivers/gpu/drm/
Am 2021-09-13 um 12:18 p.m. schrieb Michel Dänzer:
> On 2021-09-13 17:19, Felix Kuehling wrote:
>> Am 2021-09-13 um 10:19 a.m. schrieb Michel Dänzer:
>>> From: Michel Dänzer
>>>
>>> Avoids warning with -Wformat:
>>>
>>> CC [M] drivers/gpu/drm/amd/amdgpu/../amdkfd/kfd_smi_events.o
>>> ../drivers
On 2021-09-13 17:19, Felix Kuehling wrote:
> Am 2021-09-13 um 10:19 a.m. schrieb Michel Dänzer:
>> From: Michel Dänzer
>>
>> Avoids warning with -Wformat:
>>
>> CC [M] drivers/gpu/drm/amd/amdgpu/../amdkfd/kfd_smi_events.o
>> ../drivers/gpu/drm/amd/amdgpu/../amdkfd/kfd_smi_events.c: In function
new ioctl cmd added to query zone device type. This will be
used once the test_hmm adds zone device public type.
Signed-off-by: Alex Sierra
---
lib/test_hmm.c | 15 ++-
lib/test_hmm_uapi.h | 7 +++
2 files changed, 21 insertions(+), 1 deletion(-)
diff --git a/lib/test_hmm.
Add two more parameters to set spm_addr_dev0 & spm_addr_dev1
addresses. These two parameters configure the start SP
addresses for each device in test_hmm driver.
Consequently, this configures zone device type as public.
Signed-off-by: Alex Sierra
---
tools/testing/selftests/vm/test_hmm.sh | 20 +
Test cases such as migrate_fault and migrate_multiple,
were modified to explicit migrate from device to sys memory
without the need of page faults, when using device public
type.
Snapshot test case updated to read memory device type
first and based on that, get the proper returned results
migrate_
Device Public type uses device memory that is coherently accesible by
the CPU. This could be shown as SP (special purpose) memory range
at the BIOS-e820 memory enumeration. If no SP memory is supported in
system, this could be faked by setting CONFIG_EFI_FAKE_MEMMAP.
Currently, test_hmm only suppo
In order to configure device public in test_hmm, two module parameters
should be passed, which correspond to the SP start address of each
device (2) spm_addr_dev0 & spm_addr_dev1. If no parameters are passed,
private device type is configured.
Signed-off-by: Alex Sierra
---
v5:
Remove devmem->pag
When CPU is connected throug XGMI, it has coherent
access to VRAM resource. In this case that resource
is taken from a table in the device gmc aperture base.
This resource is used along with the device type, which could
be DEVICE_PRIVATE or DEVICE_PUBLIC to create the device
page map region.
Signe
From: Ralph Campbell
ZONE_DEVICE struct pages have an extra reference count that complicates the
code for put_page() and several places in the kernel that need to check the
reference count to see that a page is not being used (gup, compaction,
migration, etc.). Clean up the code so the reference
Ref counter from device pages is init to zero during memmap init zone.
The first time a new device page is allocated to migrate data into it,
its ref counter needs to be initialized to one.
Signed-off-by: Alex Sierra
---
drivers/gpu/drm/amd/amdkfd/kfd_migrate.c | 3 ++-
1 file changed, 2 inserti
Public device type memory on VRAM to RAM migration, has similar access
as System RAM from the CPU. This flag sets the source from the sender.
Which in Public type case, should be set as
MIGRATE_VMA_SELECT_DEVICE_PUBLIC.
Signed-off-by: Alex Sierra
Reviewed-by: Felix Kuehling
---
drivers/gpu/drm/
This case is used to migrate pages from device memory, back to system
memory. Device public type memory is cache coherent from device and CPU
point of view.
Signed-off-by: Alex Sierra
---
v2:
condition added when migrations from device public pages.
---
include/linux/migrate.h | 1 +
mm/migrate.
Device memory that is cache coherent from device and CPU point of view.
This is use on platform that have an advance system bus (like CAPI or
CCIX). Any page of a process can be migrated to such memory. However,
no one should be allow to pin such memory so that it can always be
evicted.
Signed-off
v1:
AMD is building a system architecture for the Frontier supercomputer
with a coherent interconnect between CPUs and GPUs. This hardware
architecture allows the CPUs to coherently access GPU device memory.
We have hardware in our labs and we are working with our partner HPE on
the BIOS, firmware
From: Ralph Campbell
There are several places where ZONE_DEVICE struct pages assume a reference
count == 1 means the page is idle and free. Instead of open coding this,
add a helper function to hide this detail.
Signed-off-by: Ralph Campbell
Signed-off-by: Alex Sierra
Reviewed-by: Christoph He
On 2021-09-10 11:37 a.m., Simon Ser wrote:
> This patch allows panel orientation quirks from DRM core to be
> used. They attach a DRM connector property "panel orientation"
> which indicates in which direction the panel has been mounted.
> Some machines have the internal screen mounted with a rotat
On Fri, Sep 10, 2021 at 3:54 PM Felix Kuehling wrote:
>
> These bits are de-facto part of the uAPI, so declare them in a uAPI header.
>
Please include a link to the userspace that uses this in the commit message.
Alex
> Signed-off-by: Felix Kuehling
> ---
> MAINTAINERS
Am 2021-09-13 um 10:19 a.m. schrieb Michel Dänzer:
> From: Michel Dänzer
>
> Avoids warning with -Wformat:
>
> CC [M] drivers/gpu/drm/amd/amdgpu/../amdkfd/kfd_smi_events.o
> ../drivers/gpu/drm/amd/amdgpu/../amdkfd/kfd_smi_events.c: In function
> ‘kfd_smi_event_update_thermal_throttling’:
> ../
On Wed, Sep 8, 2021 at 3:23 AM Daniel Gomez wrote:
>
> On Tue, 7 Sept 2021 at 19:23, Alex Deucher wrote:
> >
> > On Tue, Sep 7, 2021 at 4:53 AM Daniel Gomez wrote:
> > >
> > > Add custom power profile mode support on smu10.
> > > Update workload bit list.
> > > ---
> > >
> > > Hi,
> > >
> > > I'
Please add a tag V2 in description explaining what was the delta from V1.
Other then that looks good to me.
Andrey
On 2021-09-12 7:48 p.m., xinhui pan wrote:
Direct IB submission should be exclusive. So use write lock.
Signed-off-by: xinhui pan
---
drivers/gpu/drm/amd/amdgpu/amdgpu_debugfs.
On Thu, Sep 9, 2021 at 11:25 PM Evan Quan wrote:
>
> With the shadow buffer support from generic framebuffer emulation, it's
> possible now to have runpm kicked when no update for console.
>
> Change-Id: I285472c9100ee6f649d3f3f3548f402b9cd34eaf
> Signed-off-by: Evan Quan
> Acked-by: Christian Kö
From: Michel Dänzer
Avoids warning with -Wformat:
CC [M] drivers/gpu/drm/amd/amdgpu/../amdkfd/kfd_smi_events.o
../drivers/gpu/drm/amd/amdgpu/../amdkfd/kfd_smi_events.c: In function
‘kfd_smi_event_update_thermal_throttling’:
../drivers/gpu/drm/amd/amdgpu/../amdkfd/kfd_smi_events.c:224:60: war
From: Michel Dänzer
Avoids warning with -Wformat:
CC [M] drivers/gpu/drm/amd/amdgpu/../amdkfd/kfd_smi_events.o
../drivers/gpu/drm/amd/amdgpu/../amdkfd/kfd_smi_events.c: In function
‘kfd_smi_event_update_thermal_throttling’:
../drivers/gpu/drm/amd/amdgpu/../amdkfd/kfd_smi_events.c:224:60: war
Thanks for the clarification Xinhui.
Based on Christian's explanation, what I understood is - this is an
exceptional case in debugfs calls and the other goal is to avoid
maintenance of one more lock just to support this API. I no longer have
any issues with this approach.
Thanks,
Lijo
On 9/
[AMD Official Use Only]
256 bytes alignment is for Video HW that is with GFX9, so it should be fine in
general.
Regards,
Leo
-Original Message-
From: Koenig, Christian
Sent: September 13, 2021 5:04 AM
To: Pan, Xinhui ; amd-gfx@lists.freedesktop.org
Cc: Deucher, Alexander ; Liu, Leo ;
NAK, this is not the lazy way to fix it at all.
The reset semaphore protects the scheduler and ring objects from
concurrent modification, so taking the write side of it is perfectly
valid here.
Christian.
Am 13.09.21 um 06:42 schrieb Pan, Xinhui:
[AMD Official Use Only]
yep, that is a lazy
Am 13.09.21 um 10:42 schrieb xinhui pan:
alloc extra msg from direct IB pool.
Reviewed-by: Christian König
Signed-off-by: xinhui pan
Reviewed-by: Christian König
---
change from v1:
msg is aligned to gpu page boundary
---
drivers/gpu/drm/amd/amdgpu/amdgpu_vcn.c | 97 +++-
Am 13.09.21 um 10:42 schrieb xinhui pan:
alloc extra msg from direct IB pool.
Signed-off-by: xinhui pan
It would be cleaner if Leo could confirm that 256 byte alignment would
work as well.
But either way Reviewed-by: Christian König
Regards,
Christian.
---
change from v1:
msg is alloca
Am 13.09.21 um 10:42 schrieb xinhui pan:
move BO allocation in sw_init.
Signed-off-by: xinhui pan
---
change from v3:
drop the bo resv lock in ib test.
---
drivers/gpu/drm/amd/amdgpu/amdgpu_uvd.c | 102
drivers/gpu/drm/amd/amdgpu/amdgpu_uvd.h | 1 +
drivers/gpu/dr
The warning
amdgpu :05:00.0: amdgpu: Trusted Memory Zone (TMZ) feature not supported
leaves the reader wondering, if anything can be done about it. As it’s
unsupported in the hardware, and nothing can be done about, mention that
in the log message.
amdgpu :05:00.0: amdgpu: Truste
As the user cannot do anything about the unsupported Trusted Memory Zone
(TMZ) feature, do not warn about it, but make it informational, so
demote the log level from warning to info.
Signed-off-by: Paul Menzel
---
drivers/gpu/drm/amd/amdgpu/amdgpu_gmc.c | 2 +-
1 file changed, 1 insertion(+), 1
alloc extra msg from direct IB pool.
Reviewed-by: Christian König
Signed-off-by: xinhui pan
---
change from v1:
msg is aligned to gpu page boundary
---
drivers/gpu/drm/amd/amdgpu/amdgpu_vcn.c | 97 +++--
1 file changed, 44 insertions(+), 53 deletions(-)
diff --git a/drivers
alloc extra msg from direct IB pool.
Signed-off-by: xinhui pan
---
change from v1:
msg is allocated separately.
msg is aligned to gpu page boundary
---
drivers/gpu/drm/amd/amdgpu/amdgpu_vce.c | 27 -
1 file changed, 13 insertions(+), 14 deletions(-)
diff --git a/drivers/
move BO allocation in sw_init.
Signed-off-by: xinhui pan
---
change from v3:
drop the bo resv lock in ib test.
---
drivers/gpu/drm/amd/amdgpu/amdgpu_uvd.c | 102
drivers/gpu/drm/amd/amdgpu/amdgpu_uvd.h | 1 +
drivers/gpu/drm/amd/amdgpu/uvd_v6_0.c | 11 +--
drivers/g
Am 13.09.21 um 10:34 schrieb Paul Menzel:
The warning
amdgpu :05:00.0: amdgpu: Trusted Memory Zone (TMZ) feature not
supported
leaves the reader wondering, if anything can be done about it. As it’s
unsupported in the hardware, and nothing can be done about, mention that
in the log mes
Am 13.09.21 um 10:27 schrieb Nirmoy Das:
Pass drm dev directly as rdev->ddev gets initialized later on
at radeon_device_init().
Bug: https://bugzilla.kernel.org/show_bug.cgi?id=214375
Signed-off-by: Nirmoy Das
Reviewed-by: Christian König
---
drivers/gpu/drm/radeon/radeon_kms.c | 2 +-
Pass drm dev directly as rdev->ddev gets initialized later on
at radeon_device_init().
Bug: https://bugzilla.kernel.org/show_bug.cgi?id=214375
Signed-off-by: Nirmoy Das
---
drivers/gpu/drm/radeon/radeon_kms.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/gpu/drm/rad
Am 13.09.21 um 10:09 schrieb xinhui pan:
Allow TTM know if vendor set new ttm mananger out of bounds by adding
build_bug_on.
Signed-off-by: xinhui pan
Yeah, that looks better. Reviewed-by: Christian König
Going to push that to drm-misc-next.
Thanks,
Christian.
---
drivers/gpu/drm/ttm
Allow TTM know if vendor set new ttm mananger out of bounds by adding
build_bug_on.
Signed-off-by: xinhui pan
---
drivers/gpu/drm/ttm/ttm_range_manager.c | 8
include/drm/ttm/ttm_device.h| 3 +++
include/drm/ttm/ttm_range_manager.h | 18 --
3 files chan
Update PSP TA unload function to use PSP TA context as input argument.
Signed-off-by: Candice Li
---
drivers/gpu/drm/amd/amdgpu/amdgpu_psp.c | 20 ++--
1 file changed, 10 insertions(+), 10 deletions(-)
diff --git a/drivers/gpu/drm/amd/amdgpu/amdgpu_psp.c
b/drivers/gpu/drm/amd/a
Update asd_context structure and add asd_initialize function to
conform ASD header/loading to generic TA systems.
Signed-off-by: Candice Li
---
drivers/gpu/drm/amd/amdgpu/amdgpu_psp.c | 60 ++---
drivers/gpu/drm/amd/amdgpu/amdgpu_psp.h | 10 ++---
2 files changed, 26 insertio
[AMD Official Use Only]
Of source IB test can hang the GPU.
But it wait fence with one specific timeout. and it not depends on gpu
scheduler.
So IB test must can return.
发件人: Lazar, Lijo
发送时间: 2021年9月13日 15:15
收件人: Christian König; Koenig, Christian; Pan
Am 13.09.21 um 09:15 schrieb Lazar, Lijo:
On 9/13/2021 12:21 PM, Christian König wrote:
Keep in mind that we don't try to avoid contention here. The goal is
rather to have as few locks as possible to avoid the extra overhead
in the hot path.
Contention is completely irrelevant for the debug a
On Wed, Sep 08, 2021 at 05:58:34PM -0500, Tom Lendacky wrote:
> diff --git a/arch/x86/kernel/cc_platform.c b/arch/x86/kernel/cc_platform.c
> new file mode 100644
> index ..3c9bacd3c3f3
> --- /dev/null
> +++ b/arch/x86/kernel/cc_platform.c
> @@ -0,0 +1,21 @@
> +// SPDX-License-Identifier
On Wed, Sep 08, 2021 at 05:58:33PM -0500, Tom Lendacky wrote:
> In prep for other confidential computing technologies, introduce a generic
preparation
> helper function, cc_platform_has(), that can be used to check for specific
> active confidential computing attributes, like memory encryption. T
On 2021-09-10 11:09, Guchun Chen wrote:
Vendor will define their own memory types on top of TTM_PL_PRIV,
but call ttm_set_driver_manager directly without checking mem_type
value when setting up memory manager. So add such check to aware
the case when array bounds.
v2: lower check level to WARN_O
On 9/13/2021 12:21 PM, Christian König wrote:
Keep in mind that we don't try to avoid contention here. The goal is
rather to have as few locks as possible to avoid the extra overhead in
the hot path.
Contention is completely irrelevant for the debug and device reset since
that are rarely o
64 matches
Mail list logo