Re: [PATCH 4/4] drm/i915/display: Add handling for new "active bpc" property

2021-06-06 Thread Werner Sembach
Am 04.06.21 um 19:30 schrieb Ville Syrjälä: On Fri, Jun 04, 2021 at 07:17:23PM +0200, Werner Sembach wrote: This commits implements the "active bpc" drm property for the Intel GPU driver. Signed-off-by: Werner Sembach --- drivers/gpu/drm/i915/display/intel_display.c | 13 + dri

Re: [PATCH 2/4] drm/uAPI: Add "active bpc" as feedback channel for "max bpc" drm property

2021-06-06 Thread Werner Sembach
Am 04.06.21 um 19:26 schrieb Ville Syrjälä: On Fri, Jun 04, 2021 at 07:17:21PM +0200, Werner Sembach wrote: Add a new general drm property "active bpc" which can be used by graphic drivers to report the applied bit depth per pixel back to userspace. While "max bpc" can be used to change the co

[PATCH 6/6] amdgpu/pm: add kernel documentation for smu_get_power_limit

2021-06-06 Thread Darren Powell
added doc tag "amdgpu_pp_power" with description added tags for enums pp_power_limit_level, pp_power_type added tag for function smu_get_power_limit Test: * Temporary insertion into Documentation/gpu/amdgpu.rst START Power Limit --- .. kernel-doc:: drivers/gpu/d

[PATCH 1/6] amdgpu/pm: reorder definition of swsmu_pm_funcs for readability

2021-06-06 Thread Darren Powell
Match the order of definition to the structure's declaration to help with locating included and missing functions of the API Signed-off-by: Darren Powell --- drivers/gpu/drm/amd/pm/swsmu/amdgpu_smu.c | 48 +++ 1 file changed, 24 insertions(+), 24 deletions(-) diff --git a/dr

[PATCH 5/6] amdgpu/pm: handle return value for get_power_limit

2021-06-06 Thread Darren Powell
Signed-off-by: Darren Powell --- drivers/gpu/drm/amd/pm/amdgpu_pm.c | 39 ++ 1 file changed, 24 insertions(+), 15 deletions(-) diff --git a/drivers/gpu/drm/amd/pm/amdgpu_pm.c b/drivers/gpu/drm/amd/pm/amdgpu_pm.c index 0a788cb38ee2..b2335a1d3f98 100644 --- a/drivers/g

[PATCH v3 0/6] Modify smu_get_power_limit to implement Powerplay API

2021-06-06 Thread Darren Powell
=== Description === modify smu_get_power_limit to implement Powerplay API v3: renamed enum pp_power_sample_window to enum pp_power_limit v2: rewrote the patchset to use two enums as args to get_power === Test System === * DESKTOP(AMD FX-8350 + NAVI10(731F/ca), BIOS: F2) + ISO(Ubuntu 20.04.1

[PATCH 4/6] amdgpu/pm: modify and add smu_get_power_limit to Powerplay API

2021-06-06 Thread Darren Powell
modify args of smu_get_power_limit to match Powerplay API .get_power_limit add smu_get_power_limit to Powerplay API swsmu_pm_funcs remove special handling of smu in amdgpu_hwmon_show_power_cap* * Test AMDGPU_PCI_ADDR=`lspci -nn | grep "VGA\|Display" | cut -d " " -f 1` AMDGPU_HWMON=`ls -la /sy

[PATCH 3/6] amdgpu/pm: modify Powerplay API get_power_limit to use new pp_power enums

2021-06-06 Thread Darren Powell
updated {amd_pm_funcs}->get_power_limit() signature rewrote pp_get_power_limit to use new enums pp_get_power_limit now returns -EOPNOTSUPP for unknown power limit update calls to {amd_pm_funcs}->get_power_limit() * Test Notes * testing hardware was NAVI10 (tests SMU path) ** needs testing on V

[PATCH 2/6] amdgpu/pm: clean up smu_get_power_limit function signature

2021-06-06 Thread Darren Powell
add two new powerplay enums (limit_level, type) add enums to smu_get_power_limit signature remove input bitfield stuffing of output variable limit update calls to smu_get_power_limit * Test AMDGPU_PCI_ADDR=`lspci -nn | grep "VGA\|Display" | cut -d " " -f 1` AMDGPU_HWMON=`ls -la /sys/class/hw