Re: [OpenWrt-Devel] dev.openwrt.org frequently gives 504 Gateway Time-out or 502 Bad Gateway errors

2014-03-19 Thread Catalin Patulea
Can you give this mirror a shot?
http://openwrt.nanobit.org/browser/trunk

It's just the svn repo, and it's not synced on a regular basis, but if
it can handle the load, I can see about improving it.

On Sun, Mar 16, 2014 at 12:28 PM, Weedy  wrote:
> On 16 Mar 2014 06:26, "Hannu Nyman"  wrote:
>>
>> Jo-Philipp Wich wrote on Tue Mar 4 12:26:43 CET 2014:
>>
>>> I reworked the trac-fcgi  launcher now and applied a number of
>>
>> > threading fixes to it, so far it seems to be way more responsive and
>> > both memory consumption and cpu load plummeted to 50MB RAM / 10% CPU
>> > per instance.
>> >
>> > On a first glance the result seems promising and the site is way
>> > more responsive now.
>>
>> Looks like your fix has worked pretty ok. At least for some time.
>>
>> In the past two days there has been some intermittent sluggishness, and
>> today I got again an 504  Gateway Time-out error. So, apparently something
>> still needs further fixing.
>>
>> I wonder if a scheduled service restart would help, in case there is some
>> memory leak or something like that, which causes the resource consumption to
>> grow gradually.
>
> Monit?
> Sounds like something monit should be watching for.
>
>
> ___
> openwrt-devel mailing list
> openwrt-devel@lists.openwrt.org
> https://lists.openwrt.org/cgi-bin/mailman/listinfo/openwrt-devel
>
___
openwrt-devel mailing list
openwrt-devel@lists.openwrt.org
https://lists.openwrt.org/cgi-bin/mailman/listinfo/openwrt-devel


[OpenWrt-Devel] [PATCH] fix `uci import` with not yet existing packages

2014-03-19 Thread Alexander Couzens
uci_file_commit() tries to open and lock a package file (e.g.
/etc/config/system)
before writing into. When the package file doesn't exist, uci fails with
'Entry not found'.
---
 file.c | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/file.c b/file.c
index 36bfdda..04973f3 100644
--- a/file.c
+++ b/file.c
@@ -714,7 +714,7 @@ static void uci_file_commit(struct uci_context *ctx, struct 
uci_package **packag
UCI_THROW(ctx, UCI_ERR_IO);
 
/* open the config file for writing now, so that it is locked */
-   f1 = uci_open_stream(ctx, p->path, SEEK_SET, false, false);
+   f1 = uci_open_stream(ctx, p->path, SEEK_SET, true, true);
 
/* flush unsaved changes and reload from delta file */
UCI_TRAP_SAVE(ctx, done);
-- 
1.9.0
___
openwrt-devel mailing list
openwrt-devel@lists.openwrt.org
https://lists.openwrt.org/cgi-bin/mailman/listinfo/openwrt-devel


[OpenWrt-Devel] [PATCH] kernel/generic: fix define in 642-bridge_port_isolate.patch

2014-03-19 Thread Jonas Eymann
Patch 642-bridge_port_isolate.patch needs to be updated
for kernels 3.12, 3.13 and 3.14 as the define for BR_ISOLATE_MODE
conflicts with BR_LEARNING

Signed-off-by: Jonas Eymann 
---
 target/linux/generic/patches-3.12/642-bridge_port_isolate.patch | 2 +-
 target/linux/generic/patches-3.13/642-bridge_port_isolate.patch | 2 +-
 target/linux/generic/patches-3.14/642-bridge_port_isolate.patch | 2 +-
 3 files changed, 3 insertions(+), 3 deletions(-)

diff --git a/target/linux/generic/patches-3.12/642-bridge_port_isolate.patch 
b/target/linux/generic/patches-3.12/642-bridge_port_isolate.patch
index be9b8f1..dd330b2 100644
--- a/target/linux/generic/patches-3.12/642-bridge_port_isolate.patch
+++ b/target/linux/generic/patches-3.12/642-bridge_port_isolate.patch
@@ -4,7 +4,7 @@
  #define BR_ADMIN_COST 0x0010
  #define BR_LEARNING   0x0020
  #define BR_FLOOD  0x0040
-+#define BR_ISOLATE_MODE   0x0020
++#define BR_ISOLATE_MODE   0x0080
  
  #ifdef CONFIG_BRIDGE_IGMP_SNOOPING
struct bridge_mcast_query   ip4_query;
diff --git a/target/linux/generic/patches-3.13/642-bridge_port_isolate.patch 
b/target/linux/generic/patches-3.13/642-bridge_port_isolate.patch
index be9b8f1..dd330b2 100644
--- a/target/linux/generic/patches-3.13/642-bridge_port_isolate.patch
+++ b/target/linux/generic/patches-3.13/642-bridge_port_isolate.patch
@@ -4,7 +4,7 @@
  #define BR_ADMIN_COST 0x0010
  #define BR_LEARNING   0x0020
  #define BR_FLOOD  0x0040
-+#define BR_ISOLATE_MODE   0x0020
++#define BR_ISOLATE_MODE   0x0080
  
  #ifdef CONFIG_BRIDGE_IGMP_SNOOPING
struct bridge_mcast_query   ip4_query;
diff --git a/target/linux/generic/patches-3.14/642-bridge_port_isolate.patch 
b/target/linux/generic/patches-3.14/642-bridge_port_isolate.patch
index 1d6b75c..5c5662d 100644
--- a/target/linux/generic/patches-3.14/642-bridge_port_isolate.patch
+++ b/target/linux/generic/patches-3.14/642-bridge_port_isolate.patch
@@ -4,7 +4,7 @@
  #define BR_ADMIN_COST 0x0010
  #define BR_LEARNING   0x0020
  #define BR_FLOOD  0x0040
-+#define BR_ISOLATE_MODE   0x0020
++#define BR_ISOLATE_MODE   0x0080
  
  #ifdef CONFIG_BRIDGE_IGMP_SNOOPING
struct bridge_mcast_query   ip4_query;
-- 
1.8.3.2
___
openwrt-devel mailing list
openwrt-devel@lists.openwrt.org
https://lists.openwrt.org/cgi-bin/mailman/listinfo/openwrt-devel


Re: [OpenWrt-Devel] [PATCH] netifd: Reload proto on topology change

2014-03-19 Thread Felix Fietkau
On 2014-03-14 10:14, Helmut Schaa wrote:
> Introduce a new device event "topology change" that gets signaled
> by bridges on adding/removing members.
> 
> On "topology changes" the proto handlers are requested to "renew"
> which is most useful for DHCP.
> 
> Signed-off-by: Helmut Schaa 
[...]
> diff --git a/scripts/netifd-proto.sh b/scripts/netifd-proto.sh
> index 7f08b1d..debfaa7 100644
> --- a/scripts/netifd-proto.sh
> +++ b/scripts/netifd-proto.sh
> @@ -20,6 +20,11 @@ _proto_do_teardown() {
>   eval "proto_$1_teardown \"$interface\" \"$ifname\""
>  }
>  
> +_proto_do_renew() {
> + json_load "$data"
> + eval "proto_$1_renew \"$interface\" \"$ifname\""
> +}
> +
>  _proto_do_setup() {
>   json_load "$data"
>   _EXPORT_VAR=0
The code should check if proto_*_renew exists (or add a default handler
for it) to avoid error logspam. Maybe it would even be useful for
proto-shell.c to check if renew is supported at init time (to avoid
useless shell callouts for proto handlers that don't support renew).

- Felix
___
openwrt-devel mailing list
openwrt-devel@lists.openwrt.org
https://lists.openwrt.org/cgi-bin/mailman/listinfo/openwrt-devel


Re: [OpenWrt-Devel] [PATCH] fix `uci import` with not yet existing packages

2014-03-19 Thread Felix Fietkau
On 2014-03-19 13:50, Alexander Couzens wrote:
> uci_file_commit() tries to open and lock a package file (e.g.
> /etc/config/system)
> before writing into. When the package file doesn't exist, uci fails with
> 'Entry not found'.
> ---
>  file.c | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)
> 
> diff --git a/file.c b/file.c
> index 36bfdda..04973f3 100644
> --- a/file.c
> +++ b/file.c
> @@ -714,7 +714,7 @@ static void uci_file_commit(struct uci_context *ctx, 
> struct uci_package **packag
>   UCI_THROW(ctx, UCI_ERR_IO);
>  
>   /* open the config file for writing now, so that it is locked */
> - f1 = uci_open_stream(ctx, p->path, SEEK_SET, false, false);
> + f1 = uci_open_stream(ctx, p->path, SEEK_SET, true, true);
I think that's wrong. The code should be changed to skip the first open
(which is only used for merging saved uci delta into the current runtime
state) if the config file does not yet exist.

- Felix
___
openwrt-devel mailing list
openwrt-devel@lists.openwrt.org
https://lists.openwrt.org/cgi-bin/mailman/listinfo/openwrt-devel


Re: [OpenWrt-Devel] [PATCH] netifd: Reload proto on topology change

2014-03-19 Thread Helmut Schaa
On Wed, Mar 19, 2014 at 3:15 PM, Felix Fietkau  wrote:
> On 2014-03-14 10:14, Helmut Schaa wrote:
>> Introduce a new device event "topology change" that gets signaled
>> by bridges on adding/removing members.
>>
>> On "topology changes" the proto handlers are requested to "renew"
>> which is most useful for DHCP.
>>
>> Signed-off-by: Helmut Schaa 
> [...]
>> diff --git a/scripts/netifd-proto.sh b/scripts/netifd-proto.sh
>> index 7f08b1d..debfaa7 100644
>> --- a/scripts/netifd-proto.sh
>> +++ b/scripts/netifd-proto.sh
>> @@ -20,6 +20,11 @@ _proto_do_teardown() {
>>   eval "proto_$1_teardown \"$interface\" \"$ifname\""
>>  }
>>
>> +_proto_do_renew() {
>> + json_load "$data"
>> + eval "proto_$1_renew \"$interface\" \"$ifname\""
>> +}
>> +
>>  _proto_do_setup() {
>>   json_load "$data"
>>   _EXPORT_VAR=0
> The code should check if proto_*_renew exists (or add a default handler
> for it) to avoid error logspam. Maybe it would even be useful for
> proto-shell.c to check if renew is supported at init time (to avoid
> useless shell callouts for proto handlers that don't support renew).

Good point. Let me respin ...
Helmut
___
openwrt-devel mailing list
openwrt-devel@lists.openwrt.org
https://lists.openwrt.org/cgi-bin/mailman/listinfo/openwrt-devel


Re: [OpenWrt-Devel] [PATCH netifd] Allow setting the UCI config path on the command line

2014-03-19 Thread Felix Fietkau
Committed in r39956

On 2014-03-18 16:43, Matthias Schiffer wrote:
> Ping?
> 
> On 03/04/2014 06:37 PM, Matthias Schiffer wrote:
>> Add a -c switch which allows setting an alternative UCI path instead of using
>> the libuci default.
>> 
>> Signed-off-by: Matthias Schiffer 
>> ---
>> Hi, this is a little patch we cooked up during the development of our new
>> Freifunk firmware, Project Gluon [1].
>> 
>> Use case:
>> 
>> Our firmware has a special mode of operation, the "config mode", in which the
>> normal init scripts don't run; instead only a minimal network configuration 
>> is
>> created and a first-configuration wizard runs on the web interface.
>> 
>> At first, we just manually configured eth0 like the failsafe mode does, but
>> switching to netifd made this much more robust and flexible.
>> 
>> [1] https://github.com/freifunk-gluon/gluon
>> 
>> 
>>  config.c | 4 +++-
>>  main.c   | 7 ++-
>>  netifd.h | 3 +++
>>  3 files changed, 12 insertions(+), 2 deletions(-)
>> 
>> diff --git a/config.c b/config.c
>> index 6784dda..4fe72dc 100644
>> --- a/config.c
>> +++ b/config.c
>> @@ -190,8 +190,10 @@ config_init_package(const char *config)
>>  ctx = uci_alloc_context();
>>  uci_ctx = ctx;
>>  
>> +if (config_path)
>> +uci_set_confdir(ctx, config_path);
>> +
>>  #ifdef DUMMY_MODE
>> -uci_set_confdir(ctx, "./config");
>>  uci_set_savedir(ctx, "./tmp");
>>  #endif
>>  } else {
>> diff --git a/main.c b/main.c
>> index 43ec24f..3d450e6 100644
>> --- a/main.c
>> +++ b/main.c
>> @@ -27,6 +27,7 @@
>>  
>>  unsigned int debug_mask = 0;
>>  const char *main_path = DEFAULT_MAIN_PATH;
>> +const char *config_path = DEFAULT_CONFIG_PATH;
>>  const char *resolv_conf = DEFAULT_RESOLV_CONF;
>>  static char **global_argv;
>>  
>> @@ -235,6 +236,7 @@ static int usage(const char *progname)
>>  " -d :Mask for debug messages\n"
>>  " -s :Path to the ubus socket\n"
>>  " -p :Path to netifd addons (default: %s)\n"
>> +" -c :Path to UCI configuration\n"
>>  " -h :Path to the hotplug script\n"
>>  " -r :Path to resolv.conf\n"
>>  " -l :   Log output level (default: %d)\n"
>> @@ -284,7 +286,7 @@ int main(int argc, char **argv)
>>  
>>  global_argv = argv;
>>  
>> -while ((ch = getopt(argc, argv, "d:s:p:h:r:l:S")) != -1) {
>> +while ((ch = getopt(argc, argv, "d:s:p:c:h:r:l:S")) != -1) {
>>  switch(ch) {
>>  case 'd':
>>  debug_mask = strtoul(optarg, NULL, 0);
>> @@ -295,6 +297,9 @@ int main(int argc, char **argv)
>>  case 'p':
>>  main_path = optarg;
>>  break;
>> +case 'c':
>> +config_path = optarg;
>> +break;
>>  case 'h':
>>  hotplug_cmd_path = optarg;
>>  break;
>> diff --git a/netifd.h b/netifd.h
>> index 75e997c..5a90858 100644
>> --- a/netifd.h
>> +++ b/netifd.h
>> @@ -30,10 +30,12 @@
>>  
>>  #ifdef DUMMY_MODE
>>  #define DEFAULT_MAIN_PATH   "./examples"
>> +#define DEFAULT_CONFIG_PATH "./config"
>>  #define DEFAULT_HOTPLUG_PATH"./examples/hotplug-cmd"
>>  #define DEFAULT_RESOLV_CONF "./tmp/resolv.conf"
>>  #else
>>  #define DEFAULT_MAIN_PATH   "/lib/netifd"
>> +#define DEFAULT_CONFIG_PATH NULL /* use the default set in libuci */
>>  #define DEFAULT_HOTPLUG_PATH"/sbin/hotplug-call"
>>  #define DEFAULT_RESOLV_CONF "/tmp/resolv.conf.auto"
>>  #endif
>> @@ -94,6 +96,7 @@ struct device;
>>  struct interface;
>>  
>>  extern const char *main_path;
>> +extern const char *config_path;
>>  void netifd_restart(void);
>>  void netifd_reload(void);
>>  
>> 
> 
> 
___
openwrt-devel mailing list
openwrt-devel@lists.openwrt.org
https://lists.openwrt.org/cgi-bin/mailman/listinfo/openwrt-devel


Re: [OpenWrt-Devel] [PATCH] ath10k: update firmware and allow choice between AP and STA firmwares

2014-03-19 Thread Felix Fietkau
On 2014-03-12 21:39, Matti Laakso wrote:
> This patch updates ath10k firmware to the latest version, changes the
> default firmware to be the one optimized for access point operation, and
> introduces a configuration option to choose the client-optimized
> firmware instead during build time.
> 
> Signed-off-by: Matti Laakso 
Committed in r39957, thanks.

- Felix
___
openwrt-devel mailing list
openwrt-devel@lists.openwrt.org
https://lists.openwrt.org/cgi-bin/mailman/listinfo/openwrt-devel


Re: [OpenWrt-Devel] dev.openwrt.org frequently gives 504 Gateway Time-out or 502 Bad Gateway errors

2014-03-19 Thread Jo-Philipp Wich
Hi.

> Can you give this mirror a shot?
> http://openwrt.nanobit.org/browser/trunk
> 
> It's just the svn repo, and it's not synced on a regular basis, but if
> it can handle the load, I can see about improving it.

504 Gateway Time-out
nginx

This was after holding Ctrl-R for 5 seconds.

~ Jow



signature.asc
Description: OpenPGP digital signature
___
openwrt-devel mailing list
openwrt-devel@lists.openwrt.org
https://lists.openwrt.org/cgi-bin/mailman/listinfo/openwrt-devel


[OpenWrt-Devel] [PATCH 1/2] [packages] new package: luabitop

2014-03-19 Thread Maxim Storchak
Hi,

This is a new lua package providing bit operations. It's required for
new luaposix.

Signed-off-by: Maxim Storchak 

-- 
Best regards,
Maxim Storchak
mailto:m.storc...@gmail.com
diff --git a/lang/luabitop/Makefile b/lang/luabitop/Makefile
new file mode 100644
index 000..1eccaa9
--- /dev/null
+++ b/lang/luabitop/Makefile
@@ -0,0 +1,51 @@
+#
+# Copyright (C) 2011 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=luabitop
+PKG_VERSION:=1.0.2
+PKG_RELEASE:=1
+
+_BASENAME:=LuaBitOp
+
+PKG_SOURCE:=$(_BASENAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=http://bitop.luajit.org/download/
+PKG_MD5SUM:=d0c1080fe0c844e8477279668e2d0d06
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(_BASENAME)-$(PKG_VERSION)
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/luabitop
+  SUBMENU:=Lua
+  SECTION:=lang
+  CATEGORY:=Languages
+  TITLE:=luabitop
+  URL:=http://bitop.luajit.org/
+  DEPENDS:=+lua
+endef
+
+define Package/luabitop/description
+Lua BitOp is a C extension module for Lua 5.1/5.2 which adds bitwise 
operations on numbers.
+endef
+
+define Build/Configure
+endef
+
+
+TARGET_CFLAGS += $(FPIC) -DLUA_USE_LINUX -DLUA_NUMBER_DOUBLE
+
+define Build/Compile
+   $(TARGET_CC) $(TARGET_CFLAGS) $(TARGET_CPPFLAGS) $(TARGET_CPPFLAGS) 
-std=gnu99 $(FPIC) -DLUA_USE_LINUX -shared -o $(PKG_BUILD_DIR)/bit.so 
$(PKG_BUILD_DIR)/bit.c
+endef
+
+define Package/luabitop/install
+   $(INSTALL_DIR) $(1)/usr/lib/lua
+   $(INSTALL_BIN) $(PKG_BUILD_DIR)/bit.so $(1)/usr/lib/lua
+endef
+
+$(eval $(call BuildPackage,luabitop))
___
openwrt-devel mailing list
openwrt-devel@lists.openwrt.org
https://lists.openwrt.org/cgi-bin/mailman/listinfo/openwrt-devel


Re: [OpenWrt-Devel] dev.openwrt.org frequently gives 504 Gateway Time-out or 502 Bad Gateway errors

2014-03-19 Thread Catalin Patulea
How much traffic does dev.openwrt.org get to /browser/* on average? (I
am not interested in /chrome/* or other handlers for now)

On Wed, Mar 19, 2014 at 11:23 AM, Jo-Philipp Wich  wrote:
> Hi.
>
>> Can you give this mirror a shot?
>> http://openwrt.nanobit.org/browser/trunk
>>
>> It's just the svn repo, and it's not synced on a regular basis, but if
>> it can handle the load, I can see about improving it.
>
> 504 Gateway Time-out
> nginx
>
> This was after holding Ctrl-R for 5 seconds.
>
> ~ Jow
>
>
> ___
> openwrt-devel mailing list
> openwrt-devel@lists.openwrt.org
> https://lists.openwrt.org/cgi-bin/mailman/listinfo/openwrt-devel
>
___
openwrt-devel mailing list
openwrt-devel@lists.openwrt.org
https://lists.openwrt.org/cgi-bin/mailman/listinfo/openwrt-devel


[OpenWrt-Devel] [PATCH] Fix existing "export -n" in ash

2014-03-19 Thread Christophe Lermytte
Minor fix to existing patch which did not correctly implement -n support for 
the export command in ash. The VEXPORT flag of a variable was set in the first 
call to setvareq() and then remained set in the subsequent call, because the 
variable already existed in the environment.

Although /lib/functions.sh by default does not export variables (NO_EXPORT=1), 
this issue was leading to dirty environments.

Without this fix:
(ash) export A=1; export -n B=2; /bin/ash -c "echo \$A, \$B"
1, 2

With this fix:
(ash) export A=1; export -n B=2; /bin/ash -c "echo \$A, \$B"
1,

Signed-off-by: Christophe Lermytte 
---
 package/utils/busybox/patches/250-ash_export-n.patch | 10 ++
 1 file changed, 6 insertions(+), 4 deletions(-)

diff --git a/package/utils/busybox/patches/250-ash_export-n.patch 
b/package/utils/busybox/patches/250-ash_export-n.patch
index 048c236..22c16e1 100644
--- a/package/utils/busybox/patches/250-ash_export-n.patch
+++ b/package/utils/busybox/patches/250-ash_export-n.patch
@@ -1,5 +1,7 @@
 a/shell/ash.c
-+++ b/shell/ash.c
+Index: busybox-1.19.4/shell/ash.c
+===
+--- busybox-1.19.4.orig/shell/ash.c
 busybox-1.19.4/shell/ash.c
 @@ -12611,8 +12611,17 @@ exportcmd(int argc UNUSED_PARAM, char **
const char *p;
char **aptr;
@@ -19,7 +21,7 @@
aptr = argptr;
name = *aptr;
if (name) {
-@@ -12624,10 +12633,12 @@ exportcmd(int argc UNUSED_PARAM, char **
+@@ -12624,10 +12633,11 @@ exportcmd(int argc UNUSED_PARAM, char **
vp = *findvar(hashvar(name), name);
if (vp) {
vp->flags |= flag;
@@ -27,7 +29,7 @@
continue;
}
}
-   setvar(name, p, flag);
+-  setvar(name, p, flag);
 +  setvar(name, p, flag & mask);
} while ((name = *++aptr) != NULL);
return 0;
-- 
1.9.1
___
openwrt-devel mailing list
openwrt-devel@lists.openwrt.org
https://lists.openwrt.org/cgi-bin/mailman/listinfo/openwrt-devel


[OpenWrt-Devel] [PATCH 2/2] [packages] luaposix, update to v31

2014-03-19 Thread Maxim Storchak
Hi,

This is an update for luaposix to v31. It provides more interfaces to
POSIX functions for Lua. There is also a new requirement, luabitop.

Tested on Raspberry Pi in LXC container running OpenWRT.

Signed-off-by: Maxim Storchak 

-- 
Best regards,
Maxim Storchak
mailto:m.storc...@gmail.com

diff --git a/lang/luaposix/Makefile b/lang/luaposix/Makefile
index 46cb211..f821655 100644
--- a/lang/luaposix/Makefile
+++ b/lang/luaposix/Makefile
@@ -8,13 +8,14 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=luaposix
-PKG_VERSION:=5.1.11
+PKG_VERSION:=v31
 PKG_RELEASE:=1
+_BASENAME:=release
 
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=http://luaforge.net/frs/download.php/4813
-PKG_MD5SUM:=edb76911dbdabe98dec49e3d8a126227
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)
+PKG_SOURCE:=$(_BASENAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=https://github.com/luaposix/luaposix/archive/
+PKG_MD5SUM:=a25ff76d54bbbebf7a1f3b20c9806ee3
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(_BASENAME)-$(PKG_VERSION)
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -23,8 +24,8 @@ define Package/luaposix
   SECTION:=lang
   CATEGORY:=Languages
   TITLE:=luaposix
-  URL:=http://luaposix.luaforge.net/
-  DEPENDS:=+lua +librt
+  URL:=http://luaforge.net/projects/luaposix/
+  DEPENDS:=+lua +librt +luabitop
 endef
 
 define Package/luaposix/description
@@ -33,6 +34,8 @@ define Package/luaposix/description
 endef
 
 define Build/Configure
+   cd $(PKG_BUILD_DIR) && ./bootstrap
+   $(call Build/Configure/Default)
 endef
 
 TARGET_CFLAGS += -DLUA_USE_LINUX $(FPIC) -std=gnu99
@@ -46,7 +49,8 @@ endif
 
 define Package/luaposix/install
$(INSTALL_DIR) $(1)/usr/lib/lua
-   $(INSTALL_BIN) $(PKG_BUILD_DIR)/posix.so $(1)/usr/lib/lua
+   $(INSTALL_BIN) $(PKG_BUILD_DIR)/ext/posix/.libs/posix_c.so 
$(1)/usr/lib/lua
+   $(INSTALL_BIN) $(PKG_BUILD_DIR)/lib/posix.lua $(1)/usr/lib/lua
 endef
 
 $(eval $(call BuildPackage,luaposix))
diff --git a/lang/luaposix/patches/100-eglibc-compat.patch 
b/lang/luaposix/patches/100-eglibc-compat.patch
index 96a6fce..10aad20 100644
--- a/lang/luaposix/patches/100-eglibc-compat.patch
+++ b/lang/luaposix/patches/100-eglibc-compat.patch
@@ -1,26 +1,28 @@
 a/lposix.c
-+++ b/lposix.c
-@@ -960,11 +960,13 @@ static int Pctermid(lua_State *L)/** c
+--- luaposix-release-v31/ext/posix/posix.c.orig2014-03-10 
14:22:45.0 +0200
 luaposix-release-v31/ext/posix/posix.c 2014-03-10 14:25:04.0 
+0200
+@@ -1970,6 +1970,7 @@
+   return 1;
  }
  
- 
 +#ifndef NO_GETLOGIN
- static int Pgetlogin(lua_State *L)/** getlogin() */
- {
+ /***
+ Current logged-in user.
+ @see getlogin(3)
+@@ -1980,6 +1981,7 @@
lua_pushstring(L, getlogin());
return 1;
  }
 +#endif
  
- 
  static void Fgetpasswd(lua_State *L, int i, const void *data)
-@@ -1778,7 +1780,9 @@ static const luaL_reg R[] =
+ {
+@@ -3786,7 +3788,9 @@
  #if _POSIX_VERSION >= 200112L
-   {"getgroups",   Pgetgroups},
+   MENTRY( Pgetgroups  ),
  #endif
 +#ifndef NO_GETLOGIN
-   {"getlogin",Pgetlogin},
+   MENTRY( Pgetlogin   ),
 +#endif
-   {"getopt_long", Pgetopt_long},
-   {"getpasswd",   Pgetpasswd},
-   {"getpid",  Pgetpid},
+   MENTRY( Pgetopt ),
+   MENTRY( Pgetpasswd  ),
+   MENTRY( Pgetpid ),
___
openwrt-devel mailing list
openwrt-devel@lists.openwrt.org
https://lists.openwrt.org/cgi-bin/mailman/listinfo/openwrt-devel


[OpenWrt-Devel] Collision between named interfaces in /etc/config/network and wifi indentifiers in /etc/config/wireless

2014-03-19 Thread Ben West
I believe I discovered that interfaces in /etc/config/network and
/etc/config/wireless sharing the same identifier causes a collision of some
sort that can disable all the device's network interfaces, i.e. such that
it no longer even responds to ping on eth0.

Possibly, this is intentional?

For example, in /etc/config/network:

config interface '*mesh*'
option proto 'static'
option ipaddr '5.X.X.X'
option dns  '208.67.222.222 208.67.222.220'
option netmask '255.0.0.0'
option broadcast '255.255.255.255'

And then this VIF in /etc/config/wireless:

config wifi-iface *mesh*
option network 'mesh'
option mode 'adhoc'
option device 'radio0'
option ssid 'MyMesh'
option bssid '02:CA:FF:EE:BA:BE'
option encryption 'psk2'
option key 'averystrongkey'

The collision was happening on repeater nodes in an OLSR-managed adhoc
network, not on gateway nodes oddly enough.  The repeater nodes in question
had 3 wireless VIFs, the adhoc IF, a public AP running coovachill, and a
private AP with WPA2 security.

Changing the identifier in /etc/config/wireless from "*mesh*" to "*wmesh*,"
i.e. anything besides "mesh," seemed to resolve the problem.

config wifi-iface *wmesh*
option network 'mesh'
option mode 'adhoc'
option device 'radio0'
option ssid 'MyMesh'
option bssid '02:CA:FF:EE:BA:BE'
option encryption 'psk2'
option key 'averystrongkey'

The wiki about /etc/config/wireless doesn't appear to make explicitly clear
that interface identifiers should not be the same as the 'network' property
for that interface.
http://wiki.openwrt.org/doc/uci/wireless

-- 
Ben West
http://gowasabi.net
b...@gowasabi.net
314-246-9434
___
openwrt-devel mailing list
openwrt-devel@lists.openwrt.org
https://lists.openwrt.org/cgi-bin/mailman/listinfo/openwrt-devel


Re: [OpenWrt-Devel] [RFC] mt7620 wifi

2014-03-19 Thread Michel Stempin


Le 15/02/2014 12:02, Roman Yeryomin a écrit :
> On 14 February 2014 20:43, Mikko Hissa  wrote:
>>
>> On 14 Feb 2014, at 01:04, Roman Yeryomin  wrote:
>>
>>> On 14 February 2014 00:34, Mikko Hissa  wrote:
 In rt2800lib.c function rt2800_get_txwi_rxwi_size()
 Add case MT7620 with RT5592.

*txwi_size = TXWI_DESC_SIZE_5WORDS;
*rxwi_size = RXWI_DESC_SIZE_6WORDS;
break;

>>>
>>> I suppose you mean RT5390 because:
>>> ieee80211 phy0: rt2x00_set_rt: Info - RT chipset 5390, rev 0500 detected
>>>
>>> Also as far as I understand (from datasheet) it's not the same as
>>> RT5592. Correct me if I'm wrong.
>>> So I added:
>>>
>>>case RT5390:
>>>*txwi_size = TXWI_DESC_SIZE_5WORDS;
>>>*rxwi_size = RXWI_DESC_SIZE_4WORDS;
>>>break;
>>
>> They should be 5 and 6 words not 5 and 4!
>>
>> *txwi_size = TXWI_DESC_SIZE_5WORDS;
>> *rxwi_size = RXWI_DESC_SIZE_6WORDS;
>> break;
> 
> You are right, it's 5 and 6 words - I misread the datasheet. Also
> seems there is a typo first stating txwi is 4 words but describing 5
> below.
> Anyway I tried txwi 5 and rxwi 6 and results are the same.
> 
>> The original driver detects MT7620 by chip id 0x5390 and bus type. The 
>> driver in rt2x00 for RT5390 is for a another chip. So you might not want to 
>> run the bits of code meant for RT5390 but create some dummy definition for 
>> MT7620 and set it in rt2800_probe_rt().
>>
> 
> Ook.. I'll try to separate and clean that.

Any news regarding the MT7620 WiFi?

Regards,
Michel
___
openwrt-devel mailing list
openwrt-devel@lists.openwrt.org
https://lists.openwrt.org/cgi-bin/mailman/listinfo/openwrt-devel


Re: [OpenWrt-Devel] [PATCH 2/2] [packages] luaposix, update to v31

2014-03-19 Thread Karl P


Your patch didn't come inline?  I haven't tested this out explicitly, but just a 
note that this would supersede http://patchwork.openwrt.org/patch/4990/


Why do you need all the _BASENAME juggling? What is the difference between 
"release-v31" and "v31" ?


Sincerely,
Karl P


On 03/19/2014 05:05 PM, Maxim Storchak wrote:

Hi,

This is an update for luaposix to v31. It provides more interfaces to
POSIX functions for Lua. There is also a new requirement, luabitop.

Tested on Raspberry Pi in LXC container running OpenWRT.

Signed-off-by: Maxim Storchak 



___
openwrt-devel mailing list
openwrt-devel@lists.openwrt.org
https://lists.openwrt.org/cgi-bin/mailman/listinfo/openwrt-devel


___
openwrt-devel mailing list
openwrt-devel@lists.openwrt.org
https://lists.openwrt.org/cgi-bin/mailman/listinfo/openwrt-devel