Re: RFR: 8263364: sun/net/www/http/KeepAliveStream/KeepAliveStreamCloseWithWrongContentLength.java wedged in getInputStream [v5]

2021-09-01 Thread Daniel Fuchs
On Tue, 31 Aug 2021 22:29:40 GMT, Ivan Šipka  wrote:

>> Ivan Šipka has updated the pull request with a new target base due to a 
>> merge or a rebase. The pull request now contains seven commits:
>> 
>>  - 8263364: output
>>  - 8263364: removing surplus imports
>>  - 8263364: refactor
>>  - 8263364: refactor
>>  - 8263364: refactor
>>  - 8263364: fixed headers
>>  - JDK-8263364: initial commit
>
> extend

@frkator Looks like your force-push on Jul 7 caused the `sponsor` label to be 
removed. Has anything changed - do I need to re-review?

-

PR: https://git.openjdk.java.net/jdk/pull/4472


RFR: 8273243: Fix indentations in java.net.InetAddress methods

2021-09-01 Thread Aleksei Efimov
Hi,

The fix changes indentations in the following `java.net.InetAddress` methods:
- getAddressesFromNameService
- getHostFromNameService

It helps to improve code readability. Can't say the same about 
`getHostFromNameService` diffs shown in this PR.

-

Commit messages:
 - 8273243: Fix indentations in java.net.InetAddress methods

Changes: https://git.openjdk.java.net/jdk/pull/5336/files
 Webrev: https://webrevs.openjdk.java.net/?repo=jdk&pr=5336&range=00
  Issue: https://bugs.openjdk.java.net/browse/JDK-8273243
  Stats: 53 lines in 1 file changed: 9 ins; 11 del; 33 mod
  Patch: https://git.openjdk.java.net/jdk/pull/5336.diff
  Fetch: git fetch https://git.openjdk.java.net/jdk pull/5336/head:pull/5336

PR: https://git.openjdk.java.net/jdk/pull/5336


Re: RFR: 8273243: Fix indentations in java.net.InetAddress methods

2021-09-01 Thread Brian Burkhalter
On Wed, 1 Sep 2021 16:53:50 GMT, Aleksei Efimov  wrote:

> Hi,
> 
> The fix changes indentations in the following `java.net.InetAddress` methods:
> - getAddressesFromNameService
> - getHostFromNameService
> 
> It helps to improve code readability. Can't say the same about 
> `getHostFromNameService` diffs shown in this PR.

Marked as reviewed by bpb (Reviewer).

src/java.base/share/classes/java/net/InetAddress.java line 689:

> 687: }
> 688: 
> 689: //XXX: if it looks a spoof just return the address?

looks _like_ a spoof

-

PR: https://git.openjdk.java.net/jdk/pull/5336


Re: RFR: 8273243: Fix indentations in java.net.InetAddress methods

2021-09-01 Thread Daniel Fuchs
On Wed, 1 Sep 2021 16:53:50 GMT, Aleksei Efimov  wrote:

> Hi,
> 
> The fix changes indentations in the following `java.net.InetAddress` methods:
> - getAddressesFromNameService
> - getHostFromNameService
> 
> It helps to improve code readability. Can't say the same about 
> `getHostFromNameService` diffs shown in this PR.

LGTM

-

Marked as reviewed by dfuchs (Reviewer).

PR: https://git.openjdk.java.net/jdk/pull/5336


Re: RFR: 8273243: Fix indentations in java.net.InetAddress methods [v2]

2021-09-01 Thread Aleksei Efimov
On Wed, 1 Sep 2021 17:08:24 GMT, Brian Burkhalter  wrote:

>> Aleksei Efimov has updated the pull request incrementally with one 
>> additional commit since the last revision:
>> 
>>   8273243: looks -> looks like
>
> src/java.base/share/classes/java/net/InetAddress.java line 689:
> 
>> 687: }
>> 688: 
>> 689: //XXX: if it looks a spoof just return the address?
> 
> looks _like_ a spoof

Thanks Brian. Changed it as suggested :)

-

PR: https://git.openjdk.java.net/jdk/pull/5336


Re: RFR: 8273243: Fix indentations in java.net.InetAddress methods [v2]

2021-09-01 Thread Aleksei Efimov
> Hi,
> 
> The fix changes indentations in the following `java.net.InetAddress` methods:
> - getAddressesFromNameService
> - getHostFromNameService
> 
> It helps to improve code readability. Can't say the same about 
> `getHostFromNameService` diffs shown in this PR.

Aleksei Efimov has updated the pull request incrementally with one additional 
commit since the last revision:

  8273243: looks -> looks like

-

Changes:
  - all: https://git.openjdk.java.net/jdk/pull/5336/files
  - new: https://git.openjdk.java.net/jdk/pull/5336/files/27c03f4d..f5627f73

Webrevs:
 - full: https://webrevs.openjdk.java.net/?repo=jdk&pr=5336&range=01
 - incr: https://webrevs.openjdk.java.net/?repo=jdk&pr=5336&range=00-01

  Stats: 1 line in 1 file changed: 0 ins; 0 del; 1 mod
  Patch: https://git.openjdk.java.net/jdk/pull/5336.diff
  Fetch: git fetch https://git.openjdk.java.net/jdk pull/5336/head:pull/5336

PR: https://git.openjdk.java.net/jdk/pull/5336