[GIT PULL] Staging driver fixes for 5.1-rc3

2019-03-30 Thread Greg KH
The following changes since commit 9e98c678c2d6ae3a17cb2de55d17f69dddaa231b:

  Linux 5.1-rc1 (2019-03-17 14:22:26 -0700)

are available in the Git repository at:

  git://git.kernel.org/pub/scm/linux/kernel/git/gregkh/staging.git 
tags/staging-5.1-rc3

for you to fetch changes up to cc26358f89c3e493b54766b1ca56cfc6b14db78a:

  staging: vt6655: Remove vif check from vnt_interrupt (2019-03-29 17:25:45 
+0100)


Staging driver fixes for 5.1-rc3

Here are some small staging driver fixes for 5.1-rc3, and one driver
removal.

The biggest thing here is the removal of the mt7621-eth driver as a
"real" network driver was merged in 5.1-rc1 for this hardware, so this
old driver can now be removed.

Other than that, there are just a number of small fixes, all resolving
reported issues and some potential corner cases for error handling
paths.

All of these have been in linux-next with no reported issues.

Signed-off-by: Greg Kroah-Hartman 


Aaro Koskinen (1):
  staging: octeon-ethernet: fix incorrect PHY mode

Aditya Pakki (3):
  staging: rtl8188eu: Fix potential NULL pointer dereference of kcalloc
  staging: rtlwifi: rtl8822b: fix to avoid potential NULL pointer 
dereference
  staging: rtlwifi: Fix potential NULL pointer dereference of kzalloc

Arnd Bergmann (2):
  staging: olpc_dcon_xo_1: add missing 'const' qualifier
  staging: axis-fifo: add CONFIG_OF dependency

Chao Yu (1):
  staging: erofs: fix to handle error path of erofs_vmap()

Dan Carpenter (2):
  staging: rtl8712: uninitialized memory in read_bbreg_hdl()
  staging: vc04_services: Fix an error code in vchiq_probe()

Gao Xiang (2):
  staging: erofs: fix error handling when failed to read compresssed data
  staging: erofs: keep corrupted fs from crashing kernel in erofs_readdir()

Ian Abbott (1):
  staging: comedi: ni_mio_common: Fix divide-by-zero for DIO cmdtest

Malcolm Priestley (2):
  staging: vt6655: Fix interrupt race condition on device start up.
  staging: vt6655: Remove vif check from vnt_interrupt

Maxim Zhukov (1):
  staging, mt7621-pci: fix build without pci support

NeilBrown (2):
  staging: remove mt7621-eth
  staging: mt7621-dts: update ethernet settings.

Samuel Thibault (1):
  staging: speakup_soft: Fix alternate speech with other synths

 drivers/staging/Kconfig|2 -
 drivers/staging/Makefile   |1 -
 drivers/staging/axis-fifo/Kconfig  |1 +
 drivers/staging/comedi/comedidev.h |2 +
 drivers/staging/comedi/drivers.c   |   33 +-
 drivers/staging/comedi/drivers/ni_mio_common.c |   10 +-
 drivers/staging/erofs/dir.c|   45 +-
 drivers/staging/erofs/unzip_vle.c  |   45 +-
 drivers/staging/erofs/unzip_vle_lz4.c  |7 +-
 drivers/staging/mt7621-dts/gbpc1.dts   |   29 +-
 drivers/staging/mt7621-dts/mt7621.dtsi |   73 +-
 .../devicetree/bindings/net/mediatek-net-gsw.txt   |   48 -
 drivers/staging/mt7621-eth/Kconfig |   39 -
 drivers/staging/mt7621-eth/Makefile|   14 -
 drivers/staging/mt7621-eth/TODO|   13 -
 drivers/staging/mt7621-eth/ethtool.c   |  250 ---
 drivers/staging/mt7621-eth/ethtool.h   |   15 -
 drivers/staging/mt7621-eth/gsw_mt7620.h|  277 ---
 drivers/staging/mt7621-eth/gsw_mt7621.c|  297 ---
 drivers/staging/mt7621-eth/mdio.c  |  275 ---
 drivers/staging/mt7621-eth/mdio.h  |   27 -
 drivers/staging/mt7621-eth/mdio_mt7620.c   |  173 --
 drivers/staging/mt7621-eth/mtk_eth_soc.c   | 2176 
 drivers/staging/mt7621-eth/mtk_eth_soc.h   |  716 ---
 drivers/staging/mt7621-eth/soc_mt7621.c|  161 --
 drivers/staging/mt7621-pci/Kconfig |1 +
 drivers/staging/octeon/ethernet-mdio.c |2 +-
 drivers/staging/octeon/ethernet.c  |   40 +-
 drivers/staging/octeon/octeon-ethernet.h   |4 +-
 drivers/staging/olpc_dcon/olpc_dcon_xo_1.c |2 +-
 drivers/staging/rtl8188eu/core/rtw_xmit.c  |9 +-
 drivers/staging/rtl8188eu/include/rtw_xmit.h   |2 +-
 drivers/staging/rtl8712/rtl8712_cmd.c  |   10 +-
 drivers/staging/rtl8712/rtl8712_cmd.h  |2 +-
 drivers/staging/rtl8723bs/core/rtw_xmit.c  |   14 +-
 drivers/staging/rtl8723bs/include/rtw_xmit.h   |2 +-
 drivers/staging/rtlwifi/phydm/rtl_phydm.c  |2 +
 drivers/staging/rtlwifi/rtl8822be/fw.c |2 +
 drivers/staging/speakup/speakup_soft.c |   16 +-
 drivers/staging/speakup/spk_priv.h |1 +
 drivers/staging/speakup/synth.c|6 +

Re: [PATCH v2] staging: rtl8723bs: core: fix line over 80 characters warning

2019-03-30 Thread Anirudh Rayabharam
On Wed, Mar 27, 2019 at 11:49:07PM +0530, Anirudh Rayabharam wrote:
> Checkpatch.pl complains that these lines are over 80 characters. Use the
> "psecuritypriv" pointer for consistency, remove unnecessary parantheses
> and fix the alignment.
> 
> This patch just cleans up a condition, it doesn't affect runtime.
> 
> Signed-off-by: Anirudh Rayabharam 
> ---
> v2: Made the commit message clearer, removed unnecessary parantheses and fixed
> the alignment as suggested by Dan Carpenter 
> 
>  drivers/staging/rtl8723bs/core/rtw_ap.c | 4 ++--
>  1 file changed, 2 insertions(+), 2 deletions(-)
> 
> diff --git a/drivers/staging/rtl8723bs/core/rtw_ap.c 
> b/drivers/staging/rtl8723bs/core/rtw_ap.c
> index 18fabf5ff44b..8062b7f36de2 100644
> --- a/drivers/staging/rtl8723bs/core/rtw_ap.c
> +++ b/drivers/staging/rtl8723bs/core/rtw_ap.c
> @@ -2336,8 +2336,8 @@ void rtw_ap_restore_network(struct adapter *padapter)
>   Update_RA_Entry(padapter, psta);
>   /* pairwise key */
>   /* per sta pairwise key and settings */
> - if ((padapter->securitypriv.dot11PrivacyAlgrthm == 
> _TKIP_) ||
> - (padapter->securitypriv.dot11PrivacyAlgrthm == 
> _AES_)) {
> + if (psecuritypriv->dot11PrivacyAlgrthm == _TKIP_ ||
> + psecuritypriv->dot11PrivacyAlgrthm == _AES_) {
>   rtw_setstakey_cmd(padapter, psta, true, false);
>   }
>   }
> -- 
> 2.17.1
> 

Unfortunately, the v2 of this patch was missed and v1 was applied to Greg's
staging tree. So, I am abandoning v2 of this patch. I will fix the alignment
and braces issue in a new patch.
___
devel mailing list
de...@linuxdriverproject.org
http://driverdev.linuxdriverproject.org/mailman/listinfo/driverdev-devel


[PATCH] staging: android: ion: fix err_cast.cocci warnings

2019-03-30 Thread kbuild test robot
From: kbuild test robot 

drivers/staging/android/ion/ion.c:427:9-16: WARNING: ERR_CAST can be used with 
buffer


 Use ERR_CAST inlined function instead of ERR_PTR(PTR_ERR(...))

Generated by: scripts/coccinelle/api/err_cast.cocci

Fixes: d51f182d188a ("staging: android: ion: refactory ion_alloc for kernel 
driver use")
CC: Zeng Tao 
Signed-off-by: kbuild test robot 
---

url:
https://github.com/0day-ci/linux/commits/Zeng-Tao/staging-android-ion-refactory-ion_alloc-for-kernel-driver-use/20190330-071409

 ion.c |2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

--- a/drivers/staging/android/ion/ion.c
+++ b/drivers/staging/android/ion/ion.c
@@ -424,7 +424,7 @@ struct dma_buf *ion_alloc(size_t len, un
return ERR_PTR(-ENODEV);
 
if (IS_ERR(buffer))
-   return ERR_PTR(PTR_ERR(buffer));
+   return ERR_CAST(buffer);
 
exp_info.ops = &dma_buf_ops;
exp_info.size = buffer->size;
___
devel mailing list
de...@linuxdriverproject.org
http://driverdev.linuxdriverproject.org/mailman/listinfo/driverdev-devel


Re: [PATCH] staging: android: ion: refactory ion_alloc for kernel driver use

2019-03-30 Thread kbuild test robot
Hi Zeng,

Thank you for the patch! Perhaps something to improve:

[auto build test WARNING on staging/staging-testing]
[also build test WARNING on v5.1-rc2 next-20190329]
[if your patch is applied to the wrong git tree, please drop us a note to help 
improve the system]

url:
https://github.com/0day-ci/linux/commits/Zeng-Tao/staging-android-ion-refactory-ion_alloc-for-kernel-driver-use/20190330-071409


coccinelle warnings: (new ones prefixed by >>)

>> drivers/staging/android/ion/ion.c:427:9-16: WARNING: ERR_CAST can be used 
>> with buffer

Please review and possibly fold the followup patch.

---
0-DAY kernel test infrastructureOpen Source Technology Center
https://lists.01.org/pipermail/kbuild-all   Intel Corporation
___
devel mailing list
de...@linuxdriverproject.org
http://driverdev.linuxdriverproject.org/mailman/listinfo/driverdev-devel


Re: [PATCH] staging: erofs: keep corrupted fs from crashing kernel in erofs_readdir()

2019-03-30 Thread Sasha Levin
Hi,

[This is an automated email]

This commit has been processed because it contains a "Fixes:" tag,
fixing commit: 3aa8ec716e52 staging: erofs: add directory operations.

The bot has tested the following trees: v5.0.5, v4.19.32.

v5.0.5: Build OK!
v4.19.32: Failed to apply! Possible dependencies:
6e78901a9f23 ("staging: erofs: separate erofs_get_meta_page")
7dd68b147d60 ("staging: erofs: use explicit unsigned int type")
8be31270362b ("staging: erofs: introduce erofs_grab_bio")
ab47dd2b0819 ("staging: erofs: cleanup z_erofs_vle_work_{lookup, register}")


How should we proceed with this patch?

--
Thanks,
Sasha
___
devel mailing list
de...@linuxdriverproject.org
http://driverdev.linuxdriverproject.org/mailman/listinfo/driverdev-devel


Re:Hello

2019-03-30 Thread Mr Wong
Hello this is Mr Wong again from hongkong,Can we send the Swift as discuss best 
regards.

Mr Wong Cheng

---
This email has been checked for viruses by Avast antivirus software.
https://www.avast.com/antivirus

___
devel mailing list
de...@linuxdriverproject.org
http://driverdev.linuxdriverproject.org/mailman/listinfo/driverdev-devel


Re: [GIT PULL] Staging driver fixes for 5.1-rc3

2019-03-30 Thread pr-tracker-bot
The pull request you sent on Sat, 30 Mar 2019 10:04:21 +0100:

> git://git.kernel.org/pub/scm/linux/kernel/git/gregkh/staging.git 
> tags/staging-5.1-rc3

has been merged into torvalds/linux.git:
https://git.kernel.org/torvalds/c/32faca66bd3f6aa7ec4212d20c7b2d45657fab10

Thank you!

-- 
Deet-doot-dot, I am a bot.
https://korg.wiki.kernel.org/userdoc/prtracker
___
devel mailing list
de...@linuxdriverproject.org
http://driverdev.linuxdriverproject.org/mailman/listinfo/driverdev-devel


[PATCH] Staging: greybus: usb: Fixed a coding style error

2019-03-30 Thread Will Cunningham
Line was >80 characters.

Signed-off-by: Will Cunningham 
---
 drivers/staging/greybus/usb.c | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/drivers/staging/greybus/usb.c b/drivers/staging/greybus/usb.c
index 1c246c73a085..5b4cbec88159 100644
--- a/drivers/staging/greybus/usb.c
+++ b/drivers/staging/greybus/usb.c
@@ -169,8 +169,8 @@ static int gb_usb_probe(struct gbphy_device *gbphy_dev,
return -ENOMEM;
 
connection = gb_connection_create(gbphy_dev->bundle,
- 
le16_to_cpu(gbphy_dev->cport_desc->id),
- NULL);
+   le16_to_cpu(gbphy_dev->cport_desc->id),
+   NULL);
if (IS_ERR(connection)) {
retval = PTR_ERR(connection);
goto exit_usb_put;
-- 
2.19.2

___
devel mailing list
de...@linuxdriverproject.org
http://driverdev.linuxdriverproject.org/mailman/listinfo/driverdev-devel


Re: [greybus-dev] [PATCH] Staging: greybus: usb: Fixed a coding style error

2019-03-30 Thread Alex Elder
On 3/31/19 1:04 AM, Joe Perches wrote:
> On Sun, 2019-03-31 at 01:30 -0400, Will Cunningham wrote:
>> Line was >80 characters.
> []
>> diff --git a/drivers/staging/greybus/usb.c b/drivers/staging/greybus/usb.c
> []
>> @@ -169,8 +169,8 @@ static int gb_usb_probe(struct gbphy_device *gbphy_dev,
>>  return -ENOMEM;
>>  
>>  connection = gb_connection_create(gbphy_dev->bundle,
>> -  
>> le16_to_cpu(gbphy_dev->cport_desc->id),
>> -  NULL);
>> +le16_to_cpu(gbphy_dev->cport_desc->id),
>> +NULL);
> 
> Blind adherence to 80 column limits leads to poor looking
> code.  Especially with longish identifier lengths.

I agree.  If it were me, I'd use a local variable.  For example:

struct greybus_descriptor_cport *cport_desc = gbphy_dev->cport_desc;

...

connection = gb_connection_create(gbphy_dev->bundle,
  le16_to_cpu(cport_desc->id), NULL);

Or maybe better:

u16 cport_id = le16_to_cpu(gbphy_dev->cport_desc->id);

...

connection = gb_connection_create(gbphy_dev->bundle, cport_id, NULL);

-Alex




> 
> Another way to do this, which is not necessarily actually
> better is to position the left side of the assignment on a
> separate line like:
> 
>   connection =
>gb_connection_create(gbphy_dev->bundle,
> le16_to_cpu(gbphy_dev->cport_desc->id),
> 
> Is that better?I prefer the original.
> It was better before as it was aligned to open parenthesis.
> 
> 
> ___
> greybus-dev mailing list
> greybus-...@lists.linaro.org
> https://lists.linaro.org/mailman/listinfo/greybus-dev
> 

___
devel mailing list
de...@linuxdriverproject.org
http://driverdev.linuxdriverproject.org/mailman/listinfo/driverdev-devel


Re: [greybus-dev] [PATCH] Staging: greybus: usb: Fixed a coding style error

2019-03-30 Thread Alex Elder
On 3/31/19 1:40 AM, Joe Perches wrote:
> On Sun, 2019-03-31 at 01:20 -0500, Alex Elder wrote:
>> On 3/31/19 1:04 AM, Joe Perches wrote:
>>> Blind adherence to 80 column limits leads to poor looking
>>> code.  Especially with longish identifier lengths.
>> I agree.  If it were me, I'd use a local variable.  For example:
>>
>>  struct greybus_descriptor_cport *cport_desc = gbphy_dev->cport_desc;
>>  ...
>>  connection = gb_connection_create(gbphy_dev->bundle,
>>le16_to_cpu(cport_desc->id), NULL);
>>
>> Or maybe better:
>>
>>  u16 cport_id = le16_to_cpu(gbphy_dev->cport_desc->id);
>>  ...
>>  connection = gb_connection_create(gbphy_dev->bundle, cport_id, NULL);
> 
> True.
> 
> A possible negative though:
> 
> Temporaries that are only used once are sometimes
> less readable as the declaration is supposed to be
> done at an open brace and that could be relatively
> far away from the set and use.

Then assign it where it's used.  The point is we're talking about
a readability issue (long lines), and no matter how you try to fix
it there are tradeoffs, and it's subjective.  In any case, I prefer
the use of the local variable to solve this readability problem over
splitting the line.

-Alex

___
devel mailing list
de...@linuxdriverproject.org
http://driverdev.linuxdriverproject.org/mailman/listinfo/driverdev-devel