[PATCH v15 2/3] drivers/common: add diagnostics macros to make code portable

2025-01-18 Thread Andre Muezerie
It was a common pattern to have "GCC diagnostic ignored" pragmas
sprinkled over the code and only activate these pragmas for certain
compilers (gcc and clang). Clang supports GCC's pragma for
compatibility with existing source code, so #pragma GCC diagnostic
and #pragma clang diagnostic are synonyms for Clang
(https://clang.llvm.org/docs/UsersManual.html).

Now that effort is being made to make the code compatible with MSVC
these expressions would become more complex. It makes sense to hide
this complexity behind macros. This makes maintenance easier as these
macros are defined in a single place. As a plus the code becomes
more readable as well.

Signed-off-by: Andre Muezerie 
---
 drivers/common/idpf/idpf_common_rxtx_avx512.c | 72 +--
 1 file changed, 34 insertions(+), 38 deletions(-)

diff --git a/drivers/common/idpf/idpf_common_rxtx_avx512.c 
b/drivers/common/idpf/idpf_common_rxtx_avx512.c
index b8450b03ae..81052e72c1 100644
--- a/drivers/common/idpf/idpf_common_rxtx_avx512.c
+++ b/drivers/common/idpf/idpf_common_rxtx_avx512.c
@@ -6,10 +6,6 @@
 #include "idpf_common_device.h"
 #include "idpf_common_rxtx.h"
 
-#ifndef __INTEL_COMPILER
-#pragma GCC diagnostic ignored "-Wcast-qual"
-#endif
-
 #define IDPF_DESCS_PER_LOOP_AVX 8
 #define PKTLEN_SHIFT 10
 
@@ -34,7 +30,7 @@ idpf_singleq_rearm_common(struct idpf_rx_queue *rxq)
dma_addr0 = _mm_setzero_si128();
for (i = 0; i < IDPF_VPMD_DESCS_PER_LOOP; i++) {
rxp[i] = &rxq->fake_mbuf;
-   _mm_store_si128((__m128i *)&rxdp[i].read,
+   _mm_store_si128(RTE_CAST_PTR(__m128i *, 
&rxdp[i].read),
dma_addr0);
}
}
@@ -108,8 +104,8 @@ idpf_singleq_rearm_common(struct idpf_rx_queue *rxq)
dma_addr4_7 = _mm512_add_epi64(dma_addr4_7, hdr_room);
 
/* flush desc with pa dma_addr */
-   _mm512_store_si512((__m512i *)&rxdp->read, dma_addr0_3);
-   _mm512_store_si512((__m512i *)&(rxdp + 4)->read, dma_addr4_7);
+   _mm512_store_si512(RTE_CAST_PTR(__m512i *, &rxdp->read), 
dma_addr0_3);
+   _mm512_store_si512(RTE_CAST_PTR(__m512i *, &(rxdp + 4)->read), 
dma_addr4_7);
}
 
rxq->rxrearm_start += IDPF_RXQ_REARM_THRESH;
@@ -164,8 +160,8 @@ idpf_singleq_rearm(struct idpf_rx_queue *rxq)
dma_addr0 = _mm_setzero_si128();
for (i = 0; i < IDPF_VPMD_DESCS_PER_LOOP; i++) {
rxp[i] = &rxq->fake_mbuf;
-   _mm_storeu_si128((__m128i 
*)&rxdp[i].read,
-dma_addr0);
+   _mm_storeu_si128(RTE_CAST_PTR
+   (__m128i *, 
&rxdp[i].read), dma_addr0);
}
}

rte_atomic_fetch_add_explicit(&rxq->rx_stats.mbuf_alloc_failed,
@@ -216,10 +212,10 @@ idpf_singleq_rearm(struct idpf_rx_queue *rxq)
 iovas1);
const __m512i desc6_7 = _mm512_bsrli_epi128(desc4_5, 8);
 
-   _mm512_storeu_si512((void *)rxdp, desc0_1);
-   _mm512_storeu_si512((void *)(rxdp + 2), desc2_3);
-   _mm512_storeu_si512((void *)(rxdp + 4), desc4_5);
-   _mm512_storeu_si512((void *)(rxdp + 6), desc6_7);
+   _mm512_storeu_si512(RTE_CAST_PTR(void *, rxdp), desc0_1);
+   _mm512_storeu_si512(RTE_CAST_PTR(void *, (rxdp + 2)), desc2_3);
+   _mm512_storeu_si512(RTE_CAST_PTR(void *, (rxdp + 4)), desc4_5);
+   _mm512_storeu_si512(RTE_CAST_PTR(void *, (rxdp + 6)), desc6_7);
 
rxp += IDPF_DESCS_PER_LOOP_AVX;
rxdp += IDPF_DESCS_PER_LOOP_AVX;
@@ -337,28 +333,28 @@ _idpf_singleq_recv_raw_pkts_avx512(struct idpf_rx_queue 
*rxq,
 
__m512i raw_desc0_3, raw_desc4_7;
const __m128i raw_desc7 =
-   _mm_load_si128((void *)(rxdp + 7));
+   _mm_load_si128(RTE_CAST_PTR(const __m128i *, rxdp + 7));
rte_compiler_barrier();
const __m128i raw_desc6 =
-   _mm_load_si128((void *)(rxdp + 6));
+   _mm_load_si128(RTE_CAST_PTR(const __m128i *, rxdp + 6));
rte_compiler_barrier();
const __m128i raw_desc5 =
-   _mm_load_si128((void *)(rxdp + 5));
+   _mm_load_si128(RTE_CAST_PTR(const __m128i *, rxdp + 5));
rte_compiler_barrier();
const __m128i raw_desc4 =
-   _mm_load_si128((void *)(rxdp + 4));
+   _mm_load_si128(RTE_CAST_PTR(const __m128i *, rxdp + 4)

[PATCH v15 1/3] eal: add diagnostics macros to make code portable

2025-01-18 Thread Andre Muezerie
It was a common pattern to have "GCC diagnostic ignored" pragmas
sprinkled over the code and only activate these pragmas for certain
compilers (gcc and clang). Clang supports GCC's pragma for
compatibility with existing source code, so #pragma GCC diagnostic
and #pragma clang diagnostic are synonyms for Clang
(https://clang.llvm.org/docs/UsersManual.html).

Now that effort is being made to make the code compatible with MSVC
these expressions would become more complex. It makes sense to hide
this complexity behind macros. This makes maintenance easier as these
macros are defined in a single place. As a plus the code becomes
more readable as well.

Signed-off-by: Andre Muezerie 
---
 lib/eal/include/rte_common.h | 46 
 1 file changed, 46 insertions(+)

diff --git a/lib/eal/include/rte_common.h b/lib/eal/include/rte_common.h
index 40592f71b1..4b87a0a352 100644
--- a/lib/eal/include/rte_common.h
+++ b/lib/eal/include/rte_common.h
@@ -156,6 +156,52 @@ typedef uint16_t unaligned_uint16_t;
 #define RTE_DEPRECATED(x)
 #endif
 
+/**
+ * Macros to cause the compiler to remember the state of the diagnostics as of
+ * each push, and restore to that point at each pop.
+ */
+#if !defined(__INTEL_COMPILER) && !defined(RTE_TOOLCHAIN_MSVC)
+#define __rte_diagnostic_push _Pragma("GCC diagnostic push")
+#define __rte_diagnostic_pop  _Pragma("GCC diagnostic pop")
+#else
+#define __rte_diagnostic_push
+#define __rte_diagnostic_pop
+#endif
+
+/**
+ * Macro to disable compiler warnings about removing a type
+ * qualifier from the target type.
+ */
+#if !defined(__INTEL_COMPILER) && !defined(RTE_TOOLCHAIN_MSVC)
+#define __rte_diagnostic_ignored_wcast_qual \
+   _Pragma("GCC diagnostic ignored \"-Wcast-qual\"")
+#else
+#define __rte_diagnostic_ignored_wcast_qual
+#endif
+
+/**
+ * Workaround to discard qualifiers (such as const, volatile, restrict) from a 
pointer,
+ * without the compiler emitting a warning.
+ */
+#define RTE_PTR_UNQUAL(X) ((void *)(uintptr_t)(X))
+
+/**
+ * Workaround to discard qualifiers (such as const, volatile, restrict) from a 
pointer
+ * and cast it to a specific type, without the compiler emitting a warning.
+ *
+ * @warning
+ * Although this macro can be abused for casting a pointer to point to a 
different type,
+ * alignment may be incorrect when casting to point to a larger type. E.g.:
+ *   struct s {
+ *   uint16_t a;
+ *   uint8_t  b;
+ *   uint8_t  c;
+ *   uint8_t  d;
+ *   } v;
+ *   uint16_t * p = RTE_CAST_PTR(uint16_t *, &v.c); // "p" is not 16 bit 
aligned!
+ */
+#define RTE_CAST_PTR(type, ptr) ((type)(uintptr_t)(ptr))
+
 /**
  * Mark a function or variable to a weak reference.
  */
-- 
2.47.2.vfs.0.1



[PATCH v15 3/3] drivers/net: add diagnostics macros to make code portable

2025-01-18 Thread Andre Muezerie
It was a common pattern to have "GCC diagnostic ignored" pragmas
sprinkled over the code and only activate these pragmas for certain
compilers (gcc and clang). Clang supports GCC's pragma for
compatibility with existing source code, so #pragma GCC diagnostic
and #pragma clang diagnostic are synonyms for Clang
(https://clang.llvm.org/docs/UsersManual.html).

Now that effort is being made to make the code compatible with MSVC
these expressions would become more complex. It makes sense to hide
this complexity behind macros. This makes maintenance easier as these
macros are defined in a single place. As a plus the code becomes
more readable as well.

Signed-off-by: Andre Muezerie 
---
 drivers/net/axgbe/axgbe_rxtx.h|  9 ---
 drivers/net/cpfl/cpfl_rxtx_vec_common.h   |  4 -
 drivers/net/dpaa2/dpaa2_rxtx.c| 15 +---
 drivers/net/fm10k/fm10k_rxtx_vec.c| 21 ++
 drivers/net/hns3/hns3_rxtx_vec_neon.h |  6 +-
 .../net/i40e/i40e_recycle_mbufs_vec_common.c  |  2 -
 drivers/net/i40e/i40e_rxtx_common_avx.h   | 22 +++---
 drivers/net/i40e/i40e_rxtx_vec_altivec.c  | 18 ++---
 drivers/net/i40e/i40e_rxtx_vec_avx2.c | 30 
 drivers/net/i40e/i40e_rxtx_vec_avx512.c   | 28 +++
 drivers/net/i40e/i40e_rxtx_vec_common.h   |  4 -
 drivers/net/i40e/i40e_rxtx_vec_neon.c | 35 -
 drivers/net/i40e/i40e_rxtx_vec_sse.c  | 28 +++
 drivers/net/iavf/iavf_rxtx_vec_avx2.c | 60 +++
 drivers/net/iavf/iavf_rxtx_vec_avx512.c   | 62 
 drivers/net/iavf/iavf_rxtx_vec_common.h   | 10 +--
 drivers/net/iavf/iavf_rxtx_vec_neon.c | 22 +++---
 drivers/net/iavf/iavf_rxtx_vec_sse.c  | 38 +-
 drivers/net/ice/ice_rxtx_common_avx.h | 18 ++---
 drivers/net/ice/ice_rxtx_vec_avx2.c   | 74 +--
 drivers/net/ice/ice_rxtx_vec_avx512.c | 64 +++-
 drivers/net/ice/ice_rxtx_vec_common.h |  4 -
 drivers/net/ice/ice_rxtx_vec_sse.c| 28 +++
 drivers/net/idpf/idpf_rxtx_vec_common.h   |  4 -
 .../ixgbe/ixgbe_recycle_mbufs_vec_common.c|  2 -
 drivers/net/ixgbe/ixgbe_rxtx_vec_neon.c   | 18 ++---
 drivers/net/ixgbe/ixgbe_rxtx_vec_sse.c| 20 ++---
 drivers/net/mlx5/mlx5_flow.c  |  5 +-
 drivers/net/mlx5/mlx5_rxtx_vec_altivec.h  |  5 --
 drivers/net/mlx5/mlx5_rxtx_vec_neon.h | 18 ++---
 drivers/net/mlx5/mlx5_rxtx_vec_sse.h  | 61 ---
 drivers/net/ngbe/ngbe_rxtx_vec_neon.c |  8 +-
 drivers/net/tap/tap_flow.c|  6 +-
 drivers/net/txgbe/txgbe_rxtx_vec_neon.c   |  8 +-
 drivers/net/virtio/virtio_rxtx_simple.c   |  4 -
 35 files changed, 316 insertions(+), 445 deletions(-)

diff --git a/drivers/net/axgbe/axgbe_rxtx.h b/drivers/net/axgbe/axgbe_rxtx.h
index a326ba9ac8..f5f74a0a39 100644
--- a/drivers/net/axgbe/axgbe_rxtx.h
+++ b/drivers/net/axgbe/axgbe_rxtx.h
@@ -6,15 +6,6 @@
 #ifndef _AXGBE_RXTX_H_
 #define _AXGBE_RXTX_H_
 
-/* to suppress gcc warnings related to descriptor casting*/
-#ifdef RTE_TOOLCHAIN_GCC
-#pragma GCC diagnostic ignored "-Wcast-qual"
-#endif
-
-#ifdef RTE_TOOLCHAIN_CLANG
-#pragma GCC diagnostic ignored "-Wcast-qual"
-#endif
-
 /* Descriptor related defines */
 #define AXGBE_MAX_RING_DESC4096 /*should be power of 2*/
 #define AXGBE_TX_DESC_MIN_FREE (AXGBE_MAX_RING_DESC >> 3)
diff --git a/drivers/net/cpfl/cpfl_rxtx_vec_common.h 
b/drivers/net/cpfl/cpfl_rxtx_vec_common.h
index 479e1ddcb9..5b98f86932 100644
--- a/drivers/net/cpfl/cpfl_rxtx_vec_common.h
+++ b/drivers/net/cpfl/cpfl_rxtx_vec_common.h
@@ -11,10 +11,6 @@
 #include "cpfl_ethdev.h"
 #include "cpfl_rxtx.h"
 
-#ifndef __INTEL_COMPILER
-#pragma GCC diagnostic ignored "-Wcast-qual"
-#endif
-
 #define CPFL_SCALAR_PATH   0
 #define CPFL_VECTOR_PATH   1
 #define CPFL_RX_NO_VECTOR_FLAGS (  \
diff --git a/drivers/net/dpaa2/dpaa2_rxtx.c b/drivers/net/dpaa2/dpaa2_rxtx.c
index e3b6c7e460..bfb5542bbc 100644
--- a/drivers/net/dpaa2/dpaa2_rxtx.c
+++ b/drivers/net/dpaa2/dpaa2_rxtx.c
@@ -1962,14 +1962,6 @@ dpaa2_dev_tx_ordered(void *queue, struct rte_mbuf 
**bufs, uint16_t nb_pkts)
return num_tx;
 }
 
-#if defined(RTE_TOOLCHAIN_GCC)
-#pragma GCC diagnostic push
-#pragma GCC diagnostic ignored "-Wcast-qual"
-#elif defined(RTE_TOOLCHAIN_CLANG)
-#pragma clang diagnostic push
-#pragma clang diagnostic ignored "-Wcast-qual"
-#endif
-
 /* This function loopbacks all the received packets.*/
 uint16_t
 dpaa2_dev_loopback_rx(void *queue,
@@ -2083,7 +2075,7 @@ dpaa2_dev_loopback_rx(void *queue,
if (unlikely((status & QBMAN_DQ_STAT_VALIDFRAME) == 0))
continue;
}
-   fd[num_rx] = (struct qbman_fd *)qbman_result_DQ_fd(dq_storage);
+   fd[num_rx] = RTE_PTR_UNQUAL(qbman_result_DQ_fd(dq_storage));
 
dq_storage++;

[PATCH v15 0/3] add diagnostics macros to make code portable

2025-01-18 Thread Andre Muezerie
v15:
 * Fixed a comment in rte_common.h to make Doxygen happy.
 * Fixed a typo (extra comma).
 * Added missing RTE_PTR_UNQUAL needed for ARM64.

v14:
 * Renamed RTE_PTR_DROP_QUALIFIERS into RTE_PTR_UNQUAL to more resemble
   C23 typeof_unqual.
 * Added macro RTE_CAST_PTR to make the cast more readable when removing
   a type qualifier from a pointer.

v13:
 * Renamed RTE_IGNORE_CAST_QUAL into RTE_PTR_DROP_QUALIFIERS.
 * Added (void *) cast to RTE_PTR_DROP_QUALIFIERS to avoid the need
   for casting the result in most places where the macro is used.

v12:
 * Added macro RTE_IGNORE_CAST_QUAL and used it as a more compact and
   readable form to suppress warnings where a cast is used to remove
   a type qualifier.

v11:
 * Added __rte_diagnostic_ignored_wcast_qual to a few more places where
   it was needed.

v10:
 * Added __rte_diagnostic_ignored_wcast_qual to a few more places where
   it was needed.

v9:
 * Added __rte_diagnostic_ignored_wcast_qual to a few more places where
   it was needed.

v8:
 * Added __rte_diagnostic_ignored_wcast_qual to a few more places where
   it was needed.

v7:
 * Added __rte_diagnostic_ignored_wcast_qual to a few more places where
   it was needed.

v6:
 * Added __rte_diagnostic_ignored_wcast_qual to a few more places where
   it was needed.

v5:
 * Added __rte_diagnostic_ignored_wcast_qual to a few more places where
   it was needed.

v4:
 * Added __rte_diagnostic_ignored_wcast_qual to a few more places where
   it was needed.

v3:
 * Added __rte_diagnostic_ignored_wcast_qual to a few more places where
   it was needed.

v2:
 * Removed __rte_diagnostic_ignored_wstrict_aliasing (introduced
   in v1).
 * Removed the pragmas from many files where they were not needed.
 * In the files where the pragmas were indeed needed, reduced the
   scope during which they are active, reducing the chance that
   unforeseen issues are hidden due to warning suppression.

Andre Muezerie (3):
  eal: add diagnostics macros to make code portable
  drivers/common: add diagnostics macros to make code portable
  drivers/net: add diagnostics macros to make code portable

 drivers/common/idpf/idpf_common_rxtx_avx512.c | 72 +-
 drivers/net/axgbe/axgbe_rxtx.h|  9 ---
 drivers/net/cpfl/cpfl_rxtx_vec_common.h   |  4 -
 drivers/net/dpaa2/dpaa2_rxtx.c| 15 +---
 drivers/net/fm10k/fm10k_rxtx_vec.c| 21 ++
 drivers/net/hns3/hns3_rxtx_vec_neon.h |  6 +-
 .../net/i40e/i40e_recycle_mbufs_vec_common.c  |  2 -
 drivers/net/i40e/i40e_rxtx_common_avx.h   | 22 +++---
 drivers/net/i40e/i40e_rxtx_vec_altivec.c  | 18 ++---
 drivers/net/i40e/i40e_rxtx_vec_avx2.c | 30 
 drivers/net/i40e/i40e_rxtx_vec_avx512.c   | 28 +++
 drivers/net/i40e/i40e_rxtx_vec_common.h   |  4 -
 drivers/net/i40e/i40e_rxtx_vec_neon.c | 35 -
 drivers/net/i40e/i40e_rxtx_vec_sse.c  | 28 +++
 drivers/net/iavf/iavf_rxtx_vec_avx2.c | 60 +++
 drivers/net/iavf/iavf_rxtx_vec_avx512.c   | 62 
 drivers/net/iavf/iavf_rxtx_vec_common.h   | 10 +--
 drivers/net/iavf/iavf_rxtx_vec_neon.c | 22 +++---
 drivers/net/iavf/iavf_rxtx_vec_sse.c  | 38 +-
 drivers/net/ice/ice_rxtx_common_avx.h | 18 ++---
 drivers/net/ice/ice_rxtx_vec_avx2.c   | 74 +--
 drivers/net/ice/ice_rxtx_vec_avx512.c | 64 +++-
 drivers/net/ice/ice_rxtx_vec_common.h |  4 -
 drivers/net/ice/ice_rxtx_vec_sse.c| 28 +++
 drivers/net/idpf/idpf_rxtx_vec_common.h   |  4 -
 .../ixgbe/ixgbe_recycle_mbufs_vec_common.c|  2 -
 drivers/net/ixgbe/ixgbe_rxtx_vec_neon.c   | 18 ++---
 drivers/net/ixgbe/ixgbe_rxtx_vec_sse.c| 20 ++---
 drivers/net/mlx5/mlx5_flow.c  |  5 +-
 drivers/net/mlx5/mlx5_rxtx_vec_altivec.h  |  5 --
 drivers/net/mlx5/mlx5_rxtx_vec_neon.h | 18 ++---
 drivers/net/mlx5/mlx5_rxtx_vec_sse.h  | 61 ---
 drivers/net/ngbe/ngbe_rxtx_vec_neon.c |  8 +-
 drivers/net/tap/tap_flow.c|  6 +-
 drivers/net/txgbe/txgbe_rxtx_vec_neon.c   |  8 +-
 drivers/net/virtio/virtio_rxtx_simple.c   |  4 -
 lib/eal/include/rte_common.h  | 46 
 37 files changed, 396 insertions(+), 483 deletions(-)

--
2.47.2.vfs.0.1



Re: [PATCH v5 01/15] net/xsc: add xsc PMD framework

2025-01-18 Thread WanRenyong
On 2025/1/18 2:49, Stephen Hemminger wrote:
> On Tue, 07 Jan 2025 10:49:40 +0800
> "WanRenyong"  wrote:
>
>> diff --git a/doc/guides/rel_notes/release_25_03.rst 
>> b/doc/guides/rel_notes/release_25_03.rst
>> index 426dfcd982..6f766add72 100644
>> --- a/doc/guides/rel_notes/release_25_03.rst
>> +++ b/doc/guides/rel_notes/release_25_03.rst
>> @@ -55,6 +55,10 @@ New Features
>>Also, make sure to start the actual text at the margin.
>>===
>>   
>> +* **Added Yunsilicon xsc net driver [EXPERIMENTAL].**
>> +
>> +  * Added the PMD for Yunsilicon metaScale serials NICs.
>> +
>>   
>>   Removed Items
>>   -
> This part will need to be rebased since release notes got updated on main 
> branch
OK, thank you!

-- 
Best regards,
WanRenyong