On 27.04.21 04:44, Justin Pryzby wrote:
On Thu, Apr 22, 2021 at 04:04:18PM -0400, Jeff Janes wrote:
This commit break line continuation prompts for unbalanced parentheses in
the psql binary. Skimming through this thread, I don't see that this is
intentional or has been noticed before.
with psq
On Wed, Apr 28, 2021 at 7:56 PM Tom Lane wrote:
>
> Greg Stark writes:
> >> On Tue, Apr 27, 2021 at 7:08 PM Bharath Rupireddy
> >> >> Make sense, we would lose the ability to differentiate temporary
> >> tables from the auto_explain logs.
>
> > There's no useful differentiation that can be done
On 14.04.21 15:20, Peter Eisentraut wrote:
On 12.04.21 07:46, Craig Ringer wrote:
> To use systemtap semaphores (the _ENABLED macros) you need to run
dtrace
> -g to generate a probes.o then link that into postgres.
>
> I don't think we do that. I'll double check soon.
On Thu, Apr 29, 2021 at 11:14 AM Masahiko Sawada wrote:
>
> On Thu, Apr 29, 2021 at 11:55 AM Amit Kapila wrote:
> >
> > On Thu, Apr 29, 2021 at 4:58 AM Masahiko Sawada
> > wrote:
> > >
> > > On Thu, Apr 29, 2021 at 5:41 AM Tom Lane wrote:
> > > >
> > > > It seems that the test case added by f5
On Mon, Apr 26, 2021 at 9:22 PM vignesh C wrote:
>
> On Wed, Apr 21, 2021 at 12:13 PM Peter Smith wrote:
> >
> > On Tue, Apr 20, 2021 at 3:45 PM Peter Smith wrote:
> > >
> > > Please find attached the latest patch set v73`*
> > >
> > > Differences from v72* are:
> > >
> > > * Rebased to HEAD @ t
On Tue, Apr 27, 2021 at 1:41 PM vignesh C wrote:
>
> On Wed, Apr 21, 2021 at 12:13 PM Peter Smith wrote:
> >
> > On Tue, Apr 20, 2021 at 3:45 PM Peter Smith wrote:
> > >
> > > Please find attached the latest patch set v73`*
> > >
> > > Differences from v72* are:
> > >
> > > * Rebased to HEAD @ t
On Tue, Apr 27, 2021 at 6:17 PM vignesh C wrote:
>
> On Wed, Apr 21, 2021 at 12:13 PM Peter Smith wrote:
> >
> > On Tue, Apr 20, 2021 at 3:45 PM Peter Smith wrote:
> > >
> > > Please find attached the latest patch set v73`*
> > >
> > > Differences from v72* are:
> > >
> > > * Rebased to HEAD @ t
On Wed, Apr 28, 2021 at 5:01 PM Amit Kapila wrote:
>
> On Wed, Apr 28, 2021 at 4:51 PM Masahiko Sawada wrote:
> >
> > On Wed, Apr 28, 2021 at 6:39 PM Amit Kapila wrote:
>
> @@ -1369,7 +1369,7 @@ ReorderBufferIterTXNNext(ReorderBuffer *rb,
> ReorderBufferIterTXNState *state)
> * Update the tota
On Thu, Apr 29, 2021 at 7:08 AM Peter Eisentraut
wrote:
>
> On 28.04.21 16:09, Alvaro Herrera wrote:
> > Looking at it now, I wonder how well do the "hostno" options work. If I
> > say "hostnogssenc", is an SSL-encrypted socket good? If I say
> > "hostnossl", is a GSS-encrypted socket good? If
On Thu, Apr 29, 2021 at 4:41 AM Tom Lane wrote:
>
> Michael Paquier writes:
> > On Wed, Apr 28, 2021 at 12:44:45PM +0300, Aleksander Alekseev wrote:
> >> I just wanted to let you know that TimescaleDB uses
> >> pg_isolation_regress and occasionally there are reports from some
> >> suffering/puzzl
On Thu, Apr 29, 2021 at 12:09 PM tanghy.f...@fujitsu.com
wrote:
>
>
> On Thursday, April 29, 2021 3:18 PM, Dilip Kumar wrote
>
> >I tried to think about how to write a test case for this scenario, but
> >I think it will not be possible to generate an automated test case for this.
> >Basically, we
For testing unusual situations I'd like to be able to cause a backend to
terminate due to something like a segfault. Do we currently have this in
testing ?
Dave Cramer
On Thu, Apr 29, 2021 at 4:27 PM Dave Cramer wrote:
> For testing unusual situations I'd like to be able to cause a backend to
> terminate due to something like a segfault. Do we currently have this in
> testing ?
Well, you could use pg_terminate_backend which sends SIGTERM to the
backend. Howev
The following review has been posted through the commitfest application:
make installcheck-world: tested, failed
Implements feature: tested, passed
Spec compliant: tested, passed
Documentation:not tested
Few minor comments :
- The latest patch has some hunk failures
-
On Tue, Apr 27, 2021 at 5:18 PM Dilip Kumar wrote:
>
> I have modified the patch based on the above comments.
>
The patch looks good to me. I have slightly modified the comments and
commit message. See, what you think of the attached? I think we can
leave the test for this as there doesn't seem t
On Thu, Apr 29, 2021 at 3:06 PM Amit Kapila wrote:
>
> On Wed, Apr 28, 2021 at 5:01 PM Amit Kapila
wrote:
> >
> > On Wed, Apr 28, 2021 at 4:51 PM Masahiko Sawada
wrote:
> > >
> > > On Wed, Apr 28, 2021 at 6:39 PM Amit Kapila
wrote:
> >
> > @@ -1369,7 +1369,7 @@ ReorderBufferIterTXNNext(ReorderB
Hi,
The function quote_identifier has extra post-increment operation as
highlighted below,
char *
quote_identifier(const char *s)
{
char *result = pg_malloc(strlen(s) * 2 + 3);
char *r = result;
*r++ = '"';
while (*s)
{
if (*s == '"')
*r++ = *s;
*r++ = *s;
Cc'ing Lukasz Biegaj because of the pgsql-general thread.
On 2021-Apr-29, Amit Kapila wrote:
> On Wed, Apr 28, 2021 at 7:36 PM Alvaro Herrera
> wrote:
> > ... It's strange that replication worked for them on pg10 though and
> > broke on 13. What did we change anything to make it so?
>
> No i
On Thu, Apr 29, 2021 at 06:35:28PM +0530, Vaibhav Dalvi wrote:
> Hi,
>
> The function quote_identifier has extra post-increment operation as
> highlighted below,
>
> char *
> quote_identifier(const char *s)
> {
>char *result = pg_malloc(strlen(s) * 2 + 3);
>char *r = result;
>
>*
Justin Pryzby writes:
> On Thu, Apr 29, 2021 at 06:35:28PM +0530, Vaibhav Dalvi wrote:
>> If my understanding is correct then '++' is not needed in the
>> above highlighted statement which is leading to overhead.
> I don't think the integer increment during pg_upgrade is a meaningful
> overhead.
On Tue, Apr 27, 2021 at 8:25 PM Andres Freund wrote:
>
> Hi,
>
> On 2021-04-27 12:40:29 -0400, Stephen Frost wrote:
> > So, what fields are people really looking at when querying
> > pg_stat_activity interactively? User, database, pid, last query,
> > transaction start, query start, state, wait e
concepts similar and related to migration/replication are applied with
the software tcapture , please give a look at https://www.tcapture.net/
Il giorno gio 29 apr 2021 alle ore 16:34 Bruce Momjian
ha scritto:
> On Tue, Mar 23, 2021 at 09:49:57AM +0100, Joel Jacobson wrote:
> > I recently rea
Greetings,
* Magnus Hagander (mag...@hagander.net) wrote:
> On Thu, Apr 29, 2021 at 7:08 AM Peter Eisentraut
> wrote:
> > On 28.04.21 16:09, Alvaro Herrera wrote:
> > > Looking at it now, I wonder how well do the "hostno" options work. If I
> > > say "hostnogssenc", is an SSL-encrypted socket go
On 2021-Apr-29, Tom Lane wrote:
> (On the other hand, if it were written the other way already, I'd also
> argue to leave it like that. Basically, this sort of change is just not
> worth troubling over. It doesn't improve things meaningfully and it
> creates back-patching hazards.)
This argumen
I'd do it like this. Note I removed an if/else block in addition to
your changes.
I couldn't convince myself that this is worth pushing though; either we
push it to all branches (which seems unwarranted) or we create
back-patching hazards.
--
Álvaro Herrera39°49'30"S
On 2021-Apr-16, Justin Pryzby wrote:
> If this parameter is set when a partitioned table is created, the partitioned
> table's tablespace will be set to the given tablespace, and which will be the
> default tablespace for partitions create in the future, even if
> default_tablespace itself has sin
Alvaro Herrera writes:
> I'd do it like this. Note I removed an if/else block in addition to
> your changes.
> I couldn't convince myself that this is worth pushing though; either we
> push it to all branches (which seems unwarranted) or we create
> back-patching hazards.
Yeah ... an advantage
Hi,
While debugging one of the logical decoding issues, I found that xid was
not included in restoring reorder buffer changes from disk log messages.
Attached a patch for it. I felt including the XID will be helpful in
debugging. Thoughts?
Regards,
Vignesh
From 9d3ee45b7b2c0d625af888579035a0fb9a1
On Mon, Apr 26, 2021 at 9:24 PM Alvaro Herrera wrote:
>
> On 2021-Apr-26, Bharath Rupireddy wrote:
>
> > I agree that we can just be clear about the problem. Looks like the
> > majority of the errors "conflicting or redundant options" are for
> > redundant options. So, wherever "conflicting or red
On 2021-Apr-29, vignesh C wrote:
> Thanks for the comments, please find the attached v3 patch which has
> the change for the first part.
Looks good to me. I would only add parser_errposition() to the few
error sites missing that.
--
Álvaro Herrera39°49'30"S 73°17'
On 2021-Apr-07, Andres Freund wrote:
> I'm also confused by the use of ConditionVariableTimedSleep(timeout =
> 10). Why do we need a timed sleep here in the first place? And why with
> such a short sleep?
I was scared of the possibility that a process would not set the CV for
whatever reason, cau
Thanks for the feedback, Justin. I've gone ahead and switched to use
memcmp. I also refactored it to:
1. Don't assume that any file with first 4 bytes matching the
relmapper magic number is a pg_relnode.map file
2. Don't assume the pg_relnode.map file is uncorrupted and intact; perform
a check o
On 2021-Apr-29, Tom Lane wrote:
> Alvaro Herrera writes:
> > I'd do it like this. Note I removed an if/else block in addition to
> > your changes.
>
> > I couldn't convince myself that this is worth pushing though; either we
> > push it to all branches (which seems unwarranted) or we create
> >
I think you should be able to avoid crashing if passed a non-relmapper file.
Make sure not to loop over more mappings than exist in the relmapper file of
the given size.
I guess you should warn if the number of mappings is too large for the file's
size. And then "cap" the number of mappings to th
On Thu, Apr 29, 2021 at 12:05 PM Justin Pryzby wrote:
> I think you should be able to avoid crashing if passed a non-relmapper
> file.
> Make sure not to loop over more mappings than exist in the relmapper file
> of
> the given size.
>
> I guess you should warn if the number of mappings is too la
On 4/29/21 6:56 AM, Dave Cramer wrote:
For testing unusual situations I'd like to be able to cause a backend to
terminate due to something like a segfault. Do we currently have this in
testing ?
If you can run SQL as a superuser from that backend, try:
COPY (SELECT pg_backend_pid())
TO PROGR
On Thu, Apr 29, 2021 at 9:44 PM vignesh C wrote:
>
>
>
> On Thu, Apr 29, 2021 at 3:06 PM Amit Kapila wrote:
> >
> > On Wed, Apr 28, 2021 at 5:01 PM Amit Kapila wrote:
> > >
> > > On Wed, Apr 28, 2021 at 4:51 PM Masahiko Sawada
> > > wrote:
> > > >
> > > > On Wed, Apr 28, 2021 at 6:39 PM Amit K
On Thu, Apr 29, 2021 at 02:39:42PM -0400, Alvaro Herrera wrote:
> On 2021-Apr-29, Tom Lane wrote:
> > Alvaro Herrera writes:
> > > I'd do it like this. Note I removed an if/else block in addition to
> > > your changes.
> >
> > > I couldn't convince myself that this is worth pushing though; eithe
On Sat, Apr 3, 2021 at 9:27 AM Thomas Munro wrote:
> Pushed! Thanks to all who contributed.
Here's something I wanted to park here to look into for the next
cycle: it turns out that kqueue's EV_EOF flag also has the right
semantics for this. That leads to the idea of exposing the event via
the
On Thu, Apr 29, 2021 at 10:44 PM Alvaro Herrera wrote:
>
> On 2021-Apr-29, vignesh C wrote:
>
> > Thanks for the comments, please find the attached v3 patch which has
> > the change for the first part.
>
> Looks good to me. I would only add parser_errposition() to the few
> error sites missing th
On Wed, 28 Apr 2021 at 23:05, Amit Khandekar wrote:
>
> On Wed, 28 Apr 2021 at 13:54, David Rowley wrote:
> > I've attached a patch to do this. The explain.c part is pretty similar
> > to your patch, I just took my original code and comment.
>
> Sounds good. And thanks for the cleanup patch, and
On 11/30/20 7:43 PM, Anastasia Lubennikova wrote:
This entry was inactive during this CF, so I've marked it as returned
with feedback. Feel free to resubmit an updated version to a future
commitfest.
I return the patch to commitfest. My current reason differs from reason
of origin author.
This
On Thu, Apr 29, 2021 at 12:07 PM Amit Kapila wrote:
>
> On Thu, Apr 29, 2021 at 11:14 AM Masahiko Sawada
> wrote:
> >
> > >
> > > How about doing both of the above suggestions? Alternatively, we can
> > > wait for both 'drop' and 'create' message to be delivered but that
> > > might be overkill.
On Thu, 29 Apr 2021 at 15:31, Peter Eisentraut
wrote:
> > So if you could produce a separate patch that adds the
> > _ENABLED guards targeting PG14 (and PG13), that would be helpful.
>
> Here is a proposed patch for this.
LGTM.
Applies and builds fine on master and (with default fuzz) on
REL_13_
On Wed, 14 Apr 2021, 22:29 Robert Haas, wrote:
> On Tue, Apr 13, 2021 at 10:42 PM Craig Ringer
> wrote:
> > I'd really love it if a committer could add an explanatory comment or
> > two in the area though. I'm happy to draft a comment patch if anyone
> > agrees my suggestion is sensible. The key
I've attached an updated patch. I forgot to call SH_ENTRY_CLEANUP,
when it's defined during SH_RESET.
I also tided up a couple of comments and change the code to use
pg_rotate_right32(.., 31) instead of adding a new function for
pg_rotate_left32 and calling that to shift left 1 bit.
David
v3-0
On Thu, Apr 29, 2021 at 5:24 PM Amit Kapila wrote:
>
> On Tue, Apr 27, 2021 at 5:18 PM Dilip Kumar wrote:
> >
> > I have modified the patch based on the above comments.
> >
>
> The patch looks good to me. I have slightly modified the comments and
> commit message. See, what you think of the attac
On Fri, Apr 30, 2021 at 8:16 AM Bharath Rupireddy
wrote:
>
> On Thu, Apr 29, 2021 at 10:44 PM Alvaro Herrera
> wrote:
> >
> > On 2021-Apr-29, vignesh C wrote:
> >
> > > Thanks for the comments, please find the attached v3 patch which has
> > > the change for the first part.
> >
> > Looks good to
On Fri, Apr 30, 2021 at 10:17 AM Dilip Kumar wrote:
> In this function, we already have the "defel" variable then I do not
> understand why you are using one extra variable and assigning defel to
> that?
> If the goal is to just improve the error message then you can simply
> use defel->defname?
On Fri, Apr 30, 2021 at 7:07 AM Justin Pryzby wrote:
>
> On Thu, Apr 29, 2021 at 02:39:42PM -0400, Alvaro Herrera wrote:
> > On 2021-Apr-29, Tom Lane wrote:
> > > Alvaro Herrera writes:
> > > > I'd do it like this. Note I removed an if/else block in addition to
> > > > your changes.
> > >
> > >
On Fri, Apr 30, 2021 at 10:43 AM Bharath Rupireddy
wrote:
>
> On Fri, Apr 30, 2021 at 10:17 AM Dilip Kumar wrote:
> > In this function, we already have the "defel" variable then I do not
> > understand why you are using one extra variable and assigning defel to
> > that?
> > If the goal is to jus
On Fri, Apr 30, 2021 at 10:51 AM Dilip Kumar wrote:
>
> On Fri, Apr 30, 2021 at 10:43 AM Bharath Rupireddy
> wrote:
> >
> > On Fri, Apr 30, 2021 at 10:17 AM Dilip Kumar wrote:
> > > In this function, we already have the "defel" variable then I do not
> > > understand why you are using one extra
On Fri, Apr 30, 2021 at 11:09 AM Bharath Rupireddy
wrote:
>
> On Fri, Apr 30, 2021 at 10:51 AM Dilip Kumar wrote:
> >
> > On Fri, Apr 30, 2021 at 10:43 AM Bharath Rupireddy
> > wrote:
> > >
> > > On Fri, Apr 30, 2021 at 10:17 AM Dilip Kumar
> > > wrote:
> > > > In this function, we already hav
On Fri, Apr 30, 2021 at 5:55 AM Masahiko Sawada wrote:
>
> On Thu, Apr 29, 2021 at 9:44 PM vignesh C wrote:
> >
> >
> >
> > On Thu, Apr 29, 2021 at 3:06 PM Amit Kapila wrote:
> > >
> > > On Wed, Apr 28, 2021 at 5:01 PM Amit Kapila
> > > wrote:
> > > >
> > > > On Wed, Apr 28, 2021 at 4:51 PM Ma
On Thu, Apr 29, 2021 at 9:45 PM vignesh C wrote:
>
> Hi,
>
> While debugging one of the logical decoding issues, I found that xid was not
> included in restoring reorder buffer changes from disk log messages.
> Attached a patch for it. I felt including the XID will be helpful in
> debugging. T
55 matches
Mail list logo