The original code is fine... I probably would write it the way you
suggest, but I can also see why people would write it the other way.
This isn't an official CodingStyle rule so I feel like the author gets
to choose. Part of the reason for CodingStyle is so that we don't run
into madness of chan
linux/ieee80211.h already defines constants for authentication
algorithms. Remove the duplicated definitions.
Signed-off-by: Jakub Sitnicki
---
drivers/staging/rtl8188eu/include/ieee80211.h | 6 --
1 file changed, 6 deletions(-)
diff --git a/drivers/staging/rtl8188eu/include/ieee80211.h
b
linux/ieee80211.h already defines constants for spatial multiplexing
power save modes. Remove the duplicated definitions.
Signed-off-by: Jakub Sitnicki
---
drivers/staging/rtl8188eu/include/wifi.h | 7 ---
1 file changed, 7 deletions(-)
diff --git a/drivers/staging/rtl8188eu/include/wifi.h
This short series was initially a patch[1] that had to be rebased and
split (patches 1 & 2).
Since then it has been extended to clean up other WLAN_* constants
duplicated in rtl8188eu driver's headers (patches 3 & 4).
[1]
http://lkml.kernel.org/g/1437750758-17120-1-git-send-email-jsitni...@gmail
linux/ieee80211.h already defines constants for information element IDs.
Resolve discrepancies in naming and remove the duplicated definitions.
Signed-off-by: Jakub Sitnicki
---
drivers/staging/rtl8188eu/core/rtw_ieee80211.c | 2 +-
drivers/staging/rtl8188eu/include/ieee80211.h | 38 --
Signed-off-by: Jakub Sitnicki
---
drivers/staging/rtl8188eu/os_dep/ioctl_linux.c | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)
diff --git a/drivers/staging/rtl8188eu/os_dep/ioctl_linux.c
b/drivers/staging/rtl8188eu/os_dep/ioctl_linux.c
index 554c04d..844ed6f 100644
--- a/drivers/stagi
On Tue, Jul 28, 2015 at 12:29:07PM -0400, Benjamin Romer wrote:
> diff --git a/drivers/staging/unisys/visornic/visornic_main.c
> b/drivers/staging/unisys/visornic/visornic_main.c
> index 18b0465..d5095c9 100644
> --- a/drivers/staging/unisys/visornic/visornic_main.c
> +++ b/drivers/staging/unisys/
> -Original Message-
> From: Dan Carpenter [mailto:dan.carpen...@oracle.com]
> Sent: Wednesday, July 29, 2015 4:28 AM
> To: Romer, Benjamin M
> Cc: gre...@linuxfoundation.org; jes.soren...@redhat.com; *S-Par-
> Maintainer; driverdev-devel@linuxdriverproject.org; Sell, Timothy C
> Subject: R
replace item-by-item size calculation of a struct
with the size of the struct.
This gets rid of a use of typedef NDIS_802_11_RATES_EX
Signed-off-by: Joshua Clayton
---
drivers/staging/rtl8712/rtl871x_cmd.c | 11 +--
1 file changed, 1 insertion(+), 10 deletions(-)
diff --git a/drivers/
The old comment refers to a typedef name which is being removed,
and to a style of calculation which is no longer being used.
It falsely states that IELength is variable length, instead of IEs.
Change comment to simply state that the IEs field is a buffer of
variable size and that IELength refers
Change the value to a name that conforms to Linux coding style.
"rates" is equally expressive in this context, and I have left alone
a comment and function name that describe the rates as supported rates.
Signed-off-by: Joshua Clayton
---
drivers/staging/rtl8712/ieee80211.c | 25 +
r8712_get_ndis_wlan_bssid_ex_sz has a "6 * sizeof(unsigned long)"
where the underlying struct has a 6 * unsigned char.
Simplify the calculation by just subtracting the variable part from
the size of the struct.
This also gets rid of a use of typedef NDIS_802_11_RATES_EX
Signed-off-by: Joshua Clay
struct ndis_wlan_bssid_ex is a doppelganger of struct wlan_bssid_ex,
and is used about a third as often.
Switch all instances to wlan_bssid_ex, and remove ndis_wlan_bssid_ex
This also gets rid of a use of typedef NDIS_802_11_RATES_EX
Signed-off-by: Joshua Clayton
---
drivers/staging/rtl8712/rt
Rename r8712_get_ndis_wlan_bssid_ex_sz() to r8712_get_wlan_bssid_ex_sz(),
which corresponds to the struct whose size it measures.
Signed-off-by: Joshua Clayton
---
drivers/staging/rtl8712/rtl871x_cmd.c | 8
drivers/staging/rtl8712/rtl871x_mlme.c | 16
drivers/
Coding style fix.
Get rid of typedefs NDIS_802_11_RATES and NDIS_802_11_RATES_EX
Undo any casting that was done as a result of the typedef.
Signed-off-by: Joshua Clayton
---
drivers/staging/rtl8712/rtl871x_ioctl_linux.c | 12 ++--
drivers/staging/rtl8712/wlan_bssdef.h | 7 +-
dgnc_ports_state_show exposes ports status which help an adversary to
plan an attack. Thus, the function is removed.
Signed-off-by: Salah Triki
---
drivers/staging/dgnc/dgnc_sysfs.c | 20
1 file changed, 20 deletions(-)
diff --git a/drivers/staging/dgnc/dgnc_sysfs.c
b/driv
Remove wrapper structs that just wrap struct ndis_wlan_bssid_ex,
and are unused.
Signed-off-by: Joshua Clayton
---
drivers/staging/rtl8712/rtl871x_cmd.h | 18 --
1 file changed, 18 deletions(-)
diff --git a/drivers/staging/rtl8712/rtl871x_cmd.h
b/drivers/staging/rtl8712/rtl871x
On Wed, Jul 29, 2015 at 02:55:30PM +0100, Salah Triki wrote:
> dgnc_ports_state_show exposes ports status which help an adversary to
> plan an attack. Thus, the function is removed.
>
> Signed-off-by: Salah Triki
This file can only be read by UID zero so this doesn't seem like an
issue. Have I
Fixed - warning: ‘*((void *)&strHostIFmsg+4).pu8Head’ may be used uninitialized
Signed-off-by: Chandra S Gorentla
---
drivers/staging/wilc1000/host_interface.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/staging/wilc1000/host_interface.c
b/drivers/staging/wilc10
On Wed, Jul 29, 2015 at 07:36:59PM +0530, Chandra S Gorentla wrote:
> Fixed - warning: ‘*((void *)&strHostIFmsg+4).pu8Head’ may be used
> uninitialized
>
I can't reproduce this warning and the original code looks fine to me.
When you say the word "fix" it means the code is buggy. Otherwise we
On Wed, Jul 29, 2015 at 05:20:37PM +0300, Dan Carpenter wrote:
> On Wed, Jul 29, 2015 at 07:36:59PM +0530, Chandra S Gorentla wrote:
> > Fixed - warning: ‘*((void *)&strHostIFmsg+4).pu8Head’ may be used
> > uninitialized
> >
>
> I can't reproduce this warning and the original code looks fine to
On Mon, Jul 27, 2015 at 11:16:14AM +0200, Robert Baldyga wrote:
> Convert endpoint configuration to new capabilities model.
>
> Fixed typo in "epc-nulk" to "epc-bulk".
>
> Signed-off-by: Robert Baldyga
> ---
> drivers/staging/emxx_udc/emxx_udc.c | 60
> ++---
>
Building with the attached random configuration file,
warning: (INTEL_MIC_HOST && CAIF_VIRTIO && VHOST_NET && VHOST_SCSI &&
VHOST_NET && VHOST_SCSI) selects VHOST_RING which has unmet direct
dependencies (NETDEVICES && CAIF_VIRTIO || VIRTUALIZATION)
drivers/built-in.o: In function `most_nd_setup'
Randy Dunlap posted a patch for this. It has to depend on NET.
regards,
dan carpenter
___
devel mailing list
de...@linuxdriverproject.org
http://driverdev.linuxdriverproject.org/mailman/listinfo/driverdev-devel
On Wed, Jul 29, 2015 at 08:07:43PM +0300, Dan Carpenter wrote:
> Randy Dunlap posted a patch for this. It has to depend on NET.
Yes, I should get this merged later this evening, thanks.
greg k-h
___
devel mailing list
de...@linuxdriverproject.org
http:
On Tue, 28 Jul 2015 10:45:07 -0700
Randy Dunlap wrote:
> From: Randy Dunlap
>
> Fix build errors when CONFIG_NET is not enabled by making the driver
> depend on NET.
> Also correct the loadable module name.
>
> ERROR: "__netdev_alloc_skb" [drivers/staging/most/aim-network/aim_network.ko]
> un
On Fri, Jul 24, 2015 at 08:55:53AM +0900, Chaehyun Lim wrote:
> Use kmalloc and kmalloc_array instead of WILC_MALLOC.
>
> Signed-off-by: Chaehyun Lim
> ---
> V2: Use GFP_KERNEL flag instead of GFP_ATOMIC
Please answer Dan's question for the next time you resend this series, I
can't take these as
On Tue, Jul 28, 2015 at 05:47:25PM +0900, Tony Cho wrote:
> This patch removes the warnings reported by checkpatch.pl on {} not
> necessary for the single statement blocks.
>
> Signed-off-by: Tony Cho
> Reviewed-by: Dan Carpenter
> ---
> drivers/staging/wilc1000/wilc_sdio.c | 28 ++-
On Tue, Jul 28, 2015 at 05:47:28PM +0900, Tony Cho wrote:
> This patch lets preprocessor conditionals (#ifdef) related to
> WILC_SDIO_IRQ_GPIO to compile out the entire functions. Compiling out
> the entire functions is preferred rather than portions of functions or
> expressions becausue doing so
On Tue, Jul 28, 2015 at 05:47:40PM +0900, Tony Cho wrote:
> The TODO list is updated for the WILC1000 kernel driver. The TODO list
> contains many items listed in time sequence.
I don't understand what you mean by "in time sequence"
>
> Signed-off-by: Tony Cho
> Reviewed-by: Dan Carpenter
> --
On Wed, Jul 29, 2015 at 07:36:59PM +0530, Chandra S Gorentla wrote:
> Fixed - warning: ‘*((void *)&strHostIFmsg+4).pu8Head’ may be used
> uninitialized
The warning is incorrect, look at the code, I don't see anything wrong
with it. I suggest upgrading to a newer version of gcc that doesn't
repo
On Wed, Jul 29, 2015 at 01:54:54PM -0700, Greg KH wrote:
> On Tue, Jul 28, 2015 at 05:47:28PM +0900, Tony Cho wrote:
> > /**
> > * Disable power sequencer
> > **/
> > - if (!sdio_read_reg(WILC_MISC, ®)) {
> > + if(!sdio_read_reg(WILC_MISC, ®)) {
>
I noticed this style chang
On Thu, Jul 30, 2015 at 12:14:08AM +0300, Dan Carpenter wrote:
> On Wed, Jul 29, 2015 at 01:54:54PM -0700, Greg KH wrote:
> > On Tue, Jul 28, 2015 at 05:47:28PM +0900, Tony Cho wrote:
> > > /**
> > >* Disable power sequencer
> > >**/
> > > - if (!sdio_read_reg(WILC_MISC, ®)) {
> > >
We checked that "it->options[3]" was non-zero on the line before so
there is no need to check again.
Signed-off-by: Dan Carpenter
diff --git a/drivers/staging/comedi/drivers/das16.c
b/drivers/staging/comedi/drivers/das16.c
index d7cf4b1..056bca9 100644
--- a/drivers/staging/comedi/drivers/das16
Got it, thanks.
regards,
dan carpenter
___
devel mailing list
de...@linuxdriverproject.org
http://driverdev.linuxdriverproject.org/mailman/listinfo/driverdev-devel
From: Dexuan Cui
Date: Tue, 28 Jul 2015 05:35:11 -0700
> With the 2 APIs supplied by the VMBus driver, the coming net/hvsock driver
> can register 2 callbacks and can know when a new hvsock connection is
> offered by the host, and when a hvsock connection is being closed by the
> host.
>
> Signe
From: Dexuan Cui
Date: Tue, 28 Jul 2015 05:35:23 -0700
> +/* hvsock_release() can be invoked in 2 paths:
> + * 1. on process termination:
> + * hvsock_sk_destruct+0x1a/0x20
> + * __sk_free+0x1d/0x130
> + * sk_free+0x19/0x20
> + * hvsock_release+0x138/0x160
> + * sock_release+0x1f/0x90
>
From: Dexuan Cui
Date: Tue, 28 Jul 2015 05:35:30 -0700
> In the SMP guest case, when the per-channel callback hvsock_events() is
> running on virtual CPU A, if the guest tries to close the connection on
> virtual CPU B: we invoke vmbus_close() -> vmbus_close_internal(),
> then we can have trouble
On Wednesday, July 29, 2015 2:37 PM, Dan Carpenter wrote:
> We checked that "it->options[3]" was non-zero on the line before so
> there is no need to check again.
>
> Signed-off-by: Dan Carpenter
v
> diff --git a/drivers/staging/comedi/drivers/das16.c
> b/drivers/staging/comedi/drivers/das16.c
>
On 2015년 07월 30일 05:50, Greg KH wrote:
On Tue, Jul 28, 2015 at 05:47:25PM +0900, Tony Cho wrote:
This patch removes the warnings reported by checkpatch.pl on {} not
necessary for the single statement blocks.
Signed-off-by: Tony Cho
Reviewed-by: Dan Carpenter
---
drivers/staging/wilc1000/w
On 2015년 07월 30일 06:01, Greg KH wrote:
On Tue, Jul 28, 2015 at 05:47:40PM +0900, Tony Cho wrote:
The TODO list is updated for the WILC1000 kernel driver. The TODO list
contains many items listed in time sequence.
I don't understand what you mean by "in time sequence"
Sorry for unclear senten
On 2015년 07월 30일 06:14, Dan Carpenter wrote:
On Wed, Jul 29, 2015 at 01:54:54PM -0700, Greg KH wrote:
On Tue, Jul 28, 2015 at 05:47:28PM +0900, Tony Cho wrote:
/**
* Disable power sequencer
**/
- if (!sdio_read_reg(WILC_MISC, ®)) {
+ if(!sdio_read_reg
On Thu, Jul 30, 2015 at 10:29:59AM +0900, tony.cho wrote:
>
> On 2015년 07월 30일 06:01, Greg KH wrote:
> >On Tue, Jul 28, 2015 at 05:47:40PM +0900, Tony Cho wrote:
> >>The TODO list is updated for the WILC1000 kernel driver. The TODO list
> >>contains many items listed in time sequence.
> >I don't u
On Wed, Jul 29, 2015 at 09:34:42PM -0400, Dave Perez wrote:
> This is a patch to the rtw_debug.c file that fixes styling errors relating to
> new lines after variable declarations.
>
> Signed-off-by: Dave Perez
> ---
> drivers/staging/rtl8188eu/core/rtw_debug.c | 2 ++
> 1 file changed,
On 2015년 07월 30일 06:29, Greg KH wrote:
On Thu, Jul 30, 2015 at 12:14:08AM +0300, Dan Carpenter wrote:
On Wed, Jul 29, 2015 at 01:54:54PM -0700, Greg KH wrote:
On Tue, Jul 28, 2015 at 05:47:28PM +0900, Tony Cho wrote:
/**
* Disable power sequencer
**/
- if
This is a patch to the rtw_debug.c file that fixes styling errors relating to
new lines after variable declarations.
Signed-off-by: Dave Perez
---
drivers/staging/rtl8188eu/core/rtw_debug.c | 2 ++
1 file changed, 2 insertions(+)
diff --git a/drivers/staging/rtl8188eu/core/rtw_debug.c
This is a patch to the rtw_debug.c file that fixes styling errors relating to
new lines after variable declarations.
Signed-off-by: Dave Perez
---
drivers/staging/rtl8188eu/core/rtw_debug.c | 2 ++
1 file changed, 2 insertions(+)
diff --git a/drivers/staging/rtl8188eu/core/rtw_debug.c
On 2015년 07월 30일 05:54, Greg KH wrote:
On Tue, Jul 28, 2015 at 05:47:28PM +0900, Tony Cho wrote:
This patch lets preprocessor conditionals (#ifdef) related to
WILC_SDIO_IRQ_GPIO to compile out the entire functions. Compiling out
the entire functions is preferred rather than portions of functio
On Wed, 2015-07-29 at 21:34 -0400, Dave Perez wrote:
> This is a patch to the rtw_debug.c file that fixes styling errors relating to
> new lines after variable declarations.
[]
> diff --git a/drivers/staging/rtl8188eu/core/rtw_debug.c
> b/drivers/staging/rtl8188eu/core/rtw_debug.c
[]
> @@ -219,6
From: "wang, biao"
Date: Thu, 30 Jul 2015 14:14:44 +0800
Subject: [PATCH] improve lmk to avoid deadlock issue
Consider the following case:
Task A trigger lmk with a lock held, while process B try to
get this lock, but unfortunately B is the very culprit Task lmk select to
kill.
So B will never be
50 matches
Mail list logo