Bulk requests to get or put objects in a mempool often vary in size.
A series of tests with pseudo random request sizes, to mitigate the
benefits of the CPU's dynamic branch predictor, was added.
Signed-off-by: Morten Brørup
Acked-by: Andrew Rybchenko
---
app/test/test_mempool_perf.c | 102
Bulk requests to get or put objects in a mempool often vary in size.
A series of tests with pseudo random request sizes, to mitigate the
benefits of the CPU's dynamic branch predictor, was added.
Also, various other minor changes:
- Improved the output formatting for readability.
- Added test for
Updated old code using bare "unsigned" with "unsigned int".
Signed-off-by: Morten Brørup
Acked-by: Andrew Rybchenko
---
app/test/test_mempool_perf.c | 24
1 file changed, 12 insertions(+), 12 deletions(-)
diff --git a/app/test/test_mempool_perf.c b/app/test/test_mempoo
Bulk requests to get or put objects in a mempool often vary in size.
A series of tests with pseudo random request sizes, to mitigate the
benefits of the CPU's dynamic branch predictor, was added.
Signed-off-by: Morten Brørup
Acked-by: Andrew Rybchenko
---
app/test/test_mempool_perf.c | 102
Improved the output parameter ordering and formatting for readability.
Signed-off-by: Morten Brørup
Acked-by: Andrew Rybchenko
---
app/test/test_mempool_perf.c | 20 +++-
1 file changed, 11 insertions(+), 9 deletions(-)
diff --git a/app/test/test_mempool_perf.c b/app/test/test_
Improved the output parameter ordering and formatting for readability.
Signed-off-by: Morten Brørup
Acked-by: Andrew Rybchenko
---
app/test/test_mempool_perf.c | 20 +++-
1 file changed, 11 insertions(+), 9 deletions(-)
diff --git a/app/test/test_mempool_perf.c b/app/test/test_
https://bugs.dpdk.org/show_bug.cgi?id=1686
Luca Boccassi (luca.bocca...@gmail.com) changed:
What|Removed |Added
Status|UNCONFIRMED |RESOLVED
On Mon, 31 Mar 2025 at 13:45, Thomas Monjalon:
>
> 29/03/2025 20:53, Tanzeel Ahmed:
> > make clean is unable to delete build directory
> > because *.o files are not removed.
Removing .o files is a simpler fix, as in the patch.
> > The other way to fix this would be to add all the
> > c files into
> -Original Message-
> From: Nawal Kishor
> Sent: Tuesday, March 4, 2025 10:55 AM
> To: dev@dpdk.org; Nithin Kumar Dabilpuram ;
> Kiran Kumar Kokkilagadda ; Sunil Kumar Kori
> ; Satha Koteswara Rao Kottidi
> ; Harman Kalra
> Cc: Jerin Jacob ; Ashwin Sekhar T K
> ; Nawal Kishor
> Subje
This patch defines rte_node specific dynamic field structure
(rte_node_mbuf_dynfield_t)
rte_node_mbuf_dynfield_t structure holds two types of fields
- Persistent data fields which are preserved across graph walk.
Currently size of persistent data fields is zero.
- Overloadable data fields which
Currently each rte_node registers separate mbuf dynamic fields for their
own purpose. This leads to wastage of mbuf space as once mbuf get passed
a particular node, the registered dynamic field(by that node) is no
longer used.
This patch series adds a global/common mbuf dynamic field which is
reus
Some testpmd application commands will use 'rss_conf->rss_key'
parameter with a NULL value to call 'rte_eth_dev_rss_hash_conf_get()'
API, and NFP PMD will coredump at these situations.
Fix this by add a check about the 'rss_conf->rss_key' pointer.
Fixes: 934e4c60fbff ("nfp: add RSS")
Cc: sta...@d
Hello,
I pulled the raw library bindings out of DPDK source into a dedicated crate and
cleaned up compilation warnings.
Also I started a testpmd like application - runpmd.
At this stage it can receive buffers and insert flows with very limited items
and actions coverage.
The total patches a
On 3/31/25 19:09, Bruce Richardson wrote:
Use the base code build handling logic in the drivers/meson.build file,
rather than re-implementing it in the driver itself.
Signed-off-by: Bruce Richardson
Acked-by: Andrew Rybchenko
28/03/2025 11:52, David Marchand:
> +scriptname, link_mode, abi_version_file, output, *files = sys.argv
You should add a comment to show the usage of the script.
[...]
> +if link_mode == 'mslinker':
> +with open(output, "w") as outfile:
> +print(f"EXPORTS", file=outfile)
> +fo
Updated old code using bare "unsigned" with "unsigned int".
Signed-off-by: Morten Brørup
Acked-by: Andrew Rybchenko
---
app/test/test_mempool_perf.c | 24
1 file changed, 12 insertions(+), 12 deletions(-)
diff --git a/app/test/test_mempool_perf.c b/app/test/test_mempoo
Added test for the "default" mempool with cache.
Skip the tests for the "default" mempool, if it happens to use the same
driver (i.e. operations) as already tested.
Signed-off-by: Morten Brørup
Acked-by: Andrew Rybchenko
---
app/test/test_mempool_perf.c | 84 +--
Bulk requests to get or put objects in a mempool often vary in size.
A series of tests with pseudo random request sizes, to mitigate the
benefits of the CPU's dynamic branch predictor, was added.
Also, various other minor changes:
- Improved the output formatting for readability.
- Added test for
Added test for the "default" mempool with cache.
Skip the tests for the "default" mempool, if it happens to use the same
driver (i.e. operations) as already tested.
Signed-off-by: Morten Brørup
Acked-by: Andrew Rybchenko
---
app/test/test_mempool_perf.c | 84 +--
While reviewing use of null device for testing, noticed several things
this driver is doing which are unnecessary.
v2 - fix spelling and patch gliches
add byte count
Stephen Hemminger (4):
net/null: fix packet copy
net/null: Tx optimizations
net/null: optimize Rx
net/null: count all
On Tue, 1 Apr 2025 16:45:45 -0700
Nandini Persad wrote:
> I'm reviewing the Contributor's Guidelines to be more
> clear and concise where necessary.
>
> Signed-off-by: Nandini Persad
> ---
> doc/guides/contributing/coding_style.rst | 105 +++
> doc/guides/contributing/desi
If RTE_ETHDEV_QUEUE_STAT_CNTRS is less than the number of queues
in a device, the device should still count packets for all queues.
Add byte counters.
Remove the igb_ prefix which was inherited from other driver.
Signed-off-by: Stephen Hemminger
---
drivers/net/null/rte_eth_null.c | 57
I'm reviewing the Contributor's Guidelines to be more
clear and concise where necessary.
Signed-off-by: Nandini Persad
---
doc/guides/contributing/coding_style.rst | 105 +++
doc/guides/contributing/design.rst | 9 +-
doc/guides/contributing/new_library.rst | 31 +++
All the null device does is call pktmbuf_free, can be marked lockless.
The statitistics need to use atomic for this.
Add byte count statistics as well.
Use rte_pktmbuf_free_bulk instead of a loop.
And pktmbuf_free handles multi-segment packets without problems.
There is no reason for eth_null_tx
No other rx_burst function checks args, remove it.
Since rx_burst can only safely be called by a single thread
at a time, there is no need for atomic operations on statistics.
Add byte count statistics.
Signed-off-by: Stephen Hemminger
---
drivers/net/null/rte_eth_null.c | 38 --
I have uploaded all these known issues into Bugzilla,
so they are not needed here anymore.
Signed-off-by:
---
doc/guides/rel_notes/known_issues.rst | 875 --
1 file changed, 875 deletions(-)
delete mode 100644 doc/guides/rel_notes/known_issues.rst
diff --git a/doc/guide
If doing copy on transmit, can potentially copy past the data
in the mbuf. Change to only copy data from that segment.
Fixes: c743e50c475f ("null: new poll mode driver")
Cc: muk...@igel.co.jp
Cc: sta...@dpdk.org
Signed-off-by: Stephen Hemminger
---
drivers/net/null/rte_eth_null.c | 12 ++---
On Tue, Mar 18, 2025 at 1:41 PM Luca Vizzarro wrote:
>
> Currently packet capturing in Scapy is used by running Scapy's own
> class AsyncSniffer in the same shell as packet sending. Because there is
> some start up time involved in the AsyncSniffer, doing this every single
> time a test case requi
On Tue, Apr 1, 2025 at 6:11 PM Thomas Monjalon wrote:
>
> 28/03/2025 11:52, David Marchand:
> > Display the version when a symbol was introduced.
> > This is needed for scripting the conversion from static to dynamically
> > generated version maps.
> > It is also useful when listing experimental s
There has logic problem in 'port_rss_hash_key_update()', the user input
will be overwritten by the call to 'rte_eth_dev_rss_hash_conf_get()',
so the RSS functions will not get update as expected.
--
testpmd> show port 0 rss-hash key
RSS functions:
ipv4 ipv6
RSS key:
6D5A56DA255B0EC24167253D4
> -Original Message-
> From: Luka Jankovic
> Sent: Wednesday, March 26, 2025 3:40 PM
> To: luka.janko...@ericsson.com
> Cc: Jerin Jacob ; dev@dpdk.org
> Subject: [EXTERNAL] [PATCH] eventdev: fix dereferencing null atomic locks
> pointer in test-eventdev
>
> Update atomic_init_locks to
> -Original Message-
> From: Rahul Bhansali
> Sent: Friday, March 21, 2025 3:34 PM
> To: dev@dpdk.org; Nithin Kumar Dabilpuram ;
> Kiran Kumar Kokkilagadda ; Sunil Kumar Kori
> ; Satha Koteswara Rao Kottidi
> ; Harman Kalra
> Cc: Jerin Jacob ; Rahul Bhansali
> Subject: [PATCH 3/3] net
On Mon, Mar 24, 2025 at 05:30:26PM +, Bruce Richardson wrote:
> Traditionally, DPDK has had a direct mapping of internal lcore-ids, to
> the actual core numbers in use. With higher core count servers becoming
> more prevalent the issue becomes one of increasing memory footprint when
> using suc
On Tue, 1 Apr 2025 09:50:46 +0530
Nitin Saxena wrote:
> +int rte_node_mbuf_dynfield_register(void)
> +{
> + struct node_mbuf_dynfield_mz *f = NULL;
> + const struct rte_memzone *mz = NULL;
> + int dyn_offset;
> +
> + RTE_BUILD_BUG_ON(sizeof(rte_node_mbuf_dynfield_t) <
> RTE_NODE_
28/03/2025 11:52, David Marchand:
> Rather than maintain a file in parallel of the code, symbols to be
> exported can be marked with a token RTE_EXPORT_*SYMBOL.
>
> From those marks, the build framework generates map files only for
> symbols actually compiled (which means that the WINDOWS_NO_EXPOR
35 matches
Mail list logo