On 5/21/07, Bobby Moretti <[EMAIL PROTECTED]> wrote: > In the past, we've favored polluting the class namespace over lack of > clarity. For example, simplify_trig = trig_simplify, simplify_rational = > rational_simplify, etc. Would it be so bad to have, something like: > > def numerical_approximation(self, prec): > try: > field = RealField(prec) > except TypeError: > field = prec > return self._mpfr_(field) > > in symbolic expression objects?
Actually I like that since it's so clear. Be careful to allow the answer to be in ComplexField if there is no coercion to RealField. William --~--~---------~--~----~------------~-------~--~----~ To post to this group, send email to sage-support@googlegroups.com To unsubscribe from this group, send email to [EMAIL PROTECTED] For more options, visit this group at http://groups.google.com/group/sage-support URLs: http://sage.math.washington.edu/sage/ and http://sage.scipy.org/sage/ -~----------~----~----~----~------~----~------~--~---