On Sat, 7 Nov 2015, Jeroen Demeyer wrote:
"backend" clearly refers to some bigger difference, like different data
structure, and applies mostly to functions creating some object.
Yes, I think this probably holds for "backend", "impl", "implementation"
and "solver". I would vote to unify all these to "implementation".
Here is a result of quick grepping:
algorithm 382
backend 3
impl 4
implementation 29
method 37
solver 55
Maybe first thing could be change method -> algorithm? (With
deprecation, of course.)
--
Jori Mäntysalo