On Thursday, November 27, 2014 2:23:09 AM UTC-8, Bruno Grenet wrote: > > While I agree that the current names can be confusing, we have to be > careful not to make something even more confusing. As mentioned earlier > by John, f.coefficients() is "correlated" with f.exponents() and I think > it is a good feature to keep,
A drawback of this correlation is that it leads people to the wrong way of accessing this information. If you need both exponents (exponent vectors for multivariate) and the corresponding coefficients, then you should get those tied together. I think f.dict() does this, but I'm not sure if it does it very efficiently. Getting the exponents and coefficients is then just a matter of f.dict().keys() and f.dict().values() [which fully deserve to be called f.exponents() and f. coefficients()]. If "dict" is an inefficient data structure to be using here, perhaps there should be a routine that returns f.dict().items() , in that case obviously *not* going through a dict. -- You received this message because you are subscribed to the Google Groups "sage-devel" group. To unsubscribe from this group and stop receiving emails from it, send an email to sage-devel+unsubscr...@googlegroups.com. To post to this group, send email to sage-devel@googlegroups.com. Visit this group at http://groups.google.com/group/sage-devel. For more options, visit https://groups.google.com/d/optout.