On Friday, June 6, 2014 6:35:01 PM UTC+1, vdelecroix wrote: > > Nevertheless, there is an intermediate solution which I proposed > recently in #16347 comment:12. Let me repeat it here. Instead of > returning an OA or a boolean we can write a function > "orthogonal_array_construction(k, n)" whose specification would be > "return a pair (f, args) such that f(*args) is an OA(k,n) or return > None if Sage has no idea how to build it". That way, even the internal > function would be clean. > That is very similar to what I proposed in https://groups.google.com/d/msg/sage-devel/OPe5VJpBiB4/OswLwqsMJKcJ
You could also wrap the args in a closure, then you don't have to pass them around. For the external, as Nathann already said, multiplying the namespace with > designs.orthogonal_array(k, n) > designs.orthogonal_array_existence(k, n) > designs.orthogonal_array_maximum_size(n) > looks ugly to me as there are many combinatorial designs on which you > would have the same. > How about is_orthogonal_array_implemented(k,n) instead of the passive. Also, since Nathan said that orthogonal_array_maximum_size is not the correct nomenclature there might be a better name as well. -- You received this message because you are subscribed to the Google Groups "sage-devel" group. To unsubscribe from this group and stop receiving emails from it, send an email to sage-devel+unsubscr...@googlegroups.com. To post to this group, send email to sage-devel@googlegroups.com. Visit this group at http://groups.google.com/group/sage-devel. For more options, visit https://groups.google.com/d/optout.