I am confused with the google-group - I posted the second message last
night, but I don't see it. And it shows 5 message on the top, but I
can only see 4. I don't know if others can see it, but (it seems no,
so I'll copy it from a saved file:
---------------------------------------
To add to the previous post, my future plans are:

- Make sure that faces enumeration is the same everywhere, especially
for vertices and facets. This is relevant for lattice polytopes,
polyhedra, cones, and fans. We have had recently to fix some doctests
in Polyhedra because of random sorting and I have had to fix some of
the new doctests when I switched from 4.4 to 4.4.2.rc0.

- Write good plotting functions. For Fano toric varieties they must be
well-coordinated with lattice polytopes and I want to make the latter
ones more convenient and flexible.

- Improve morphisms and their doctests in schemes in general. My first
attack on documenting/improving schemes.generic.homset&morphism was
not very succesful, but I am going to continue. TestSuite(s).run()
should eventually work for schemes and ambient spaces! While it may
seem reasonable to first fix these issues and then add new classes, I
think that it is also good to have more "generic" ambient spaces for
testing purposes. Besides, with toric varieties merged I will
definitely understand at least some modules in schemes ;-)

- Implement classes to be used for lattices of cones/fans/lattice
polytopes. Ironically, lattice polytopes don't support lattices! For
cones and fans providing "lattice=" argument should "just work".

- While some of my "old" code got incorporated into the posted
patches, I still have quite a bit of written code which I hope to
convert into this framework.

- Quoting Volker: "implement everything that is known!"
---------------------------------------

Alex, thank you for such a quick response! Now we have 5 out of 6
prerequisites reviewed!

Volker, thank you for looking over the code and commenting it!

I will move the Kaehler cone to toric varieties.

Plot functions actually belong to fans, while toric varieties should
provide meaningful labels, although for Fano varieties it can make
sense to have something more special involving the polytope and its
unused points. In any case for now I would like to ask to keep the
existing function as is with the comment that it will be replaced soon
- it does provide a somewhat useful plot and it is probably not the
highest priority to get pretty pictures.

For "Fano"... I thought a lot about it as I also don't quite like that
it is necessary to keep in mind several more words. Proposition 3.5.5
in Cox&Katz book says "Delta is reflexive if and only if P_Delta is
Fano". That differs from the definitions in Nill's paper, who also
points out that sometimes people imply "smooth" when they say Fano.
How about this:
- leave the module name fano_toric_variety
- rename class to FanoToricVarietyCrepantResolution_field
- rename constructor to FanoToricVarietyCR
- say in the introduction that for us Fano means Gorenstein Fano
(omitting "Gorenstein" seems to be quite common, we can also consider
later allowing "non-canoninal Fano polytopes")
- change printing to "Crepant resolution of (Gorenstein?) Fano toric
variety of dimension n"
This way we also don't have to worry about coherency of subdivisions,
which is less trivial than crepancy.

Once this is settled, my first priority will be to add classes for
lattices. I don't think we should have separate classes for M and N,
because they are "the same" on the one hand and there may be need for
more than two (even in the same dimension) on the other one. I
envision "Lattice" as derived in Sage from ZZ^n with custom names,
dual(), and morphisms between them (which will automatically induce
toric morphisms between objects living in the same lattice - that way
we get automatic embeddings for all affine subvarieties including the
canonical embedding of the torus!). I will also go over you lattice
classes to see what else is needed. I should be able to finish this
and post a patch by the end of May (probably not for lattice polytopes
yet, as this will be quite involved and in fact I feel a need to
change a lot in lattice polytopes in general).

Dima, thank you for the reference!

Andrey

-- 
To post to this group, send an email to sage-devel@googlegroups.com
To unsubscribe from this group, send an email to 
sage-devel+unsubscr...@googlegroups.com
For more options, visit this group at http://groups.google.com/group/sage-devel
URL: http://www.sagemath.org

Reply via email to