William Stein wrote: > 2009/5/21 Jason Grout <jason-s...@creativetrax.com>: >> Referring to http://trac.sagemath.org/sage_trac/ticket/6094 ... >> >> I hope this isn't too much bikeshedding [1]... >> >> Suppose a function has several ways to do its calculation, and wants to >> provide the user with a way to select between the different ways. >> >> What is the standard option name to select between the different ways? >> >> (a) my_function(algorithm='some way') >> (b) my_function(method='some way') >> (c) another option >> (d) there is no standard; different functions use different option names. >> >> If (a) or (d) is the answer, might I suggest that using 'method' instead >> of 'algorithm' is better because: > > The answer is (a). I see no reason to change. > Also, "method" is the standard programming term to refer to a member function > of a class. Hence "algorithm" is much less ambiguous.
Okay, both you and John bring up good points. I rest my case. Jason --~--~---------~--~----~------------~-------~--~----~ To post to this group, send email to sage-devel@googlegroups.com To unsubscribe from this group, send email to sage-devel-unsubscr...@googlegroups.com For more options, visit this group at http://groups.google.com/group/sage-devel URLs: http://www.sagemath.org -~----------~----~----~----~------~----~------~--~---