Both the poly.coefficients({x:1,y:2}) and poly.coefficients(x=1,y=2)
seem confusing to me (the latter one downright scary. Exponents and
variable names have no business being on opposite sides of an equality
sign). In mathematical terms, what you want to do is view the
polynomial ring k[x,y,z] as the ring k[z][x,y] and ask for the
coefficient of the monomial x*y^2.
Wouldn't it be clearer to have a call like

poly.polynomial_coefficient({z},x*y^2) ?

i.e., give the sum of the terms in poly that are of the form
z^e*x*y^2 ? In this setting,

(x^2*y^2+z*x*y^2+x*y).polynomial_coefficient({z,y},x*y^2) == y+z

which may be useful. polynomial_coefficient seems an ugly name to me,
but this interface is a lot easier to explain and much more explicit
about what the routine does.


--~--~---------~--~----~------------~-------~--~----~
To post to this group, send email to sage-devel@googlegroups.com
To unsubscribe from this group, send email to [EMAIL PROTECTED]
For more options, visit this group at http://groups.google.com/group/sage-devel
URLs: http://sage.scipy.org/sage/ and http://modular.math.washington.edu/sage/
-~----------~----~----~----~------~----~------~--~---

Reply via email to