Hi Sibgha,

It sounds like you're using an older version of the Review Board packages
with Apache. It could be that you have system-installed Review Board
packages and a system-installed rb-site. Bitnami would be using the version
they ship, which would differ.

In the Bitnami upgrade documentation, note the specific commands given to
upgrade Review Board and upgrade the site:

$ cd installdir/apps/reviewboard/htdocs
$ sudo venv/bin/easy_install -U ReviewBoard
$ sudo venv/bin/rb-site upgrade
installdir/apps/reviewboard/rb-sites/reviewboard/

If you use standard easy_install or standard rb-site, then you'll end up
using a system-installed version, and this will create the kind of error
you're seeing.

Christian

-- 
Christian Hammond
President/CEO of Beanbag <https://www.beanbaginc.com/>
Makers of Review Board <https://www.reviewboard.org/>

On Thu, May 18, 2017 at 11:29 PM, Sibgha Nazir <[email protected]>
wrote:

> Dear ReviewBoard,I installed ReviewBoard using an installer from Bitnami.
> And then I had to upgrade the review board to *2.5.10  *using the
> following link.
>
> https://docs.bitnami.com/installer/apps/reviewboard/#
> how-to-upgrade-review-board
>
> But the website shows the following error.
>
> Manual server updates required
>
> A recent upgrade requires manual updates to be made on this server. After
> these changes are made, you should restart your web server.
>
> If you have any questions or problems, please contact us on our mailing
> list <http://groups.google.com/group/reviewboard>.
>
>
>
>
> Review Board version mismatch
>
> The version of Review Board running does not match the version the site
> was last upgraded to. You are running *2.5.9* and the site was last
> upgraded to *2.5.10*.
>
> Please upgrade your site to fix this by running:
>
>     $ rb-site upgrade /opt/Review/apps/reviewboard/htdocs/rb-sites/reviewboard
>
>
>
> rizwan@rizwan-HP-ENVY-4-Notebook-PC:~$ sudo rb-site upgrade 
> /opt/Review/apps/reviewboard/htdocs/rb-sites/reviewboard
> Rebuilding directory structure
> Upgrading site settings_local.py
> Updating database. This may take a while.
>
> The log output below, including warnings and errors,
> can be ignored unless upgrade fails.
>
> ------------------ <begin log output> ------------------
> Creating tables ...
> Installing custom SQL ...
> Installing indexes ...
> Installed 0 object(s) from 0 fixture(s)
> No evolution required.
> ------------------- <end log output> -------------------
>
> Resetting in-database caches.
>
> Upgrade complete!
>
>
> I did the given command. and it was successful.
>
>
> RESTARTED THE SERVERS. The error remains.
>
>
> Thanks in advance.
>
> --
> Supercharge your Review Board with Power Pack:
> https://www.reviewboard.org/powerpack/
> Want us to host Review Board for you? Check out RBCommons:
> https://rbcommons.com/
> Happy user? Let us know! https://www.reviewboard.org/users/
> ---
> You received this message because you are subscribed to the Google Groups
> "reviewboard" group.
> To unsubscribe from this group and stop receiving emails from it, send an
> email to [email protected].
> For more options, visit https://groups.google.com/d/optout.
>

-- 
Supercharge your Review Board with Power Pack: 
https://www.reviewboard.org/powerpack/
Want us to host Review Board for you? Check out RBCommons: 
https://rbcommons.com/
Happy user? Let us know! https://www.reviewboard.org/users/
--- 
You received this message because you are subscribed to the Google Groups 
"reviewboard" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to [email protected].
For more options, visit https://groups.google.com/d/optout.

Reply via email to