On Sat, 10 Aug 2019 at 22:14, Tierney, Luke <luke-tier...@uiowa.edu> wrote:
>
> You could have your default method handle the cases you can handle; if
> you want that to dispatch you can use something like
>
> recover_data.default <- function(object, ...)
>      default_recover_data(object, ...)
> default_recover_data <- function(object, ...)
>      UseMethod("default_recover_data")

Indeed, this is probably the cleanest solution. And static. If you are
already using a default method, you can just rename it as
default_recover_data.default.

Iñaki

______________________________________________
R-package-devel@r-project.org mailing list
https://stat.ethz.ch/mailman/listinfo/r-package-devel

Reply via email to