On 8/2/2023 12:52 AM, Claudio Fontana wrote:
On 8/1/23 18:48, Claudio Fontana wrote:
On 7/31/23 18:21, Xiaoyao Li wrote:
Signed-off-by: Xiaoyao Li <xiaoyao...@intel.com>
---
  include/exec/memory.h | 9 +++++++++
  softmmu/memory.c      | 5 +++++
  2 files changed, 14 insertions(+)

diff --git a/include/exec/memory.h b/include/exec/memory.h
index 61e31c7b9874..e119d3ce1a1d 100644
--- a/include/exec/memory.h
+++ b/include/exec/memory.h
@@ -1679,6 +1679,15 @@ static inline bool memory_region_is_romd(MemoryRegion 
*mr)
   */
  bool memory_region_is_protected(MemoryRegion *mr);
+/**
+ * memory_region_can_be_private: check whether a memory region can be private

The name of the function is not particularly informative,

+ *
+ * Returns %true if a memory region's ram_block has valid gmem fd assigned.

but in your comment you describe more accurately what it does, why not make it 
the function name?

bool memory_region_has_valid_gmem_fd()


btw can a memory region have an invalid gmem_fd ?

If an invalid gmem_fd is just used to mark whether gmem_fd is present or not,

we could make it just:

bool memory_region_has_gmem_fd()

yes. It's a good suggestion!

I will use it in next version if no objection from others.

Thanks,
-Xiaoyao





Reply via email to