On Mon, 3 Oct 2022, BALATON Zoltan wrote:
This series includes some clean ups to mac_newworld and mac_oldworld to make them a bit simpler and more readable, It also removes the shared mac.h file that turns out was more of a random collection of unrelated things. Getting rid of this mac.h improves the locality of device models and reduces unnecessary interdependency.
Ping?
v3: Some more patch spliting and changes I've noticed and address more review comments v2: Split some patches and add a few more I've noticed now and address review comments BALATON Zoltan (13): mac_newworld: Drop some variables mac_oldworld: Drop some more variables mac_{old|new}world: Set tbfreq at declaration mac_{old|new}world: Avoid else branch by setting default value mac_{old|new}world: Simplify cmdline_base calculation mac_newworld: Clean up creation of Uninorth devices mac_{old|new}world: Reduce number of QOM casts hw/ppc/mac.h: Move newworld specific parts out from shared header hw/ppc/mac.h: Move macio specific parts out from shared header hw/ppc/mac.h: Move grackle-pcihost type declaration out to a header hw/ppc/mac.h: Move PROM and KERNEL defines to board code hw/ppc/mac.h: Rename to include/hw/nvram/mac_nvram.h mac_nvram: Use NVRAM_SIZE constant MAINTAINERS | 2 + hw/ide/macio.c | 1 - hw/intc/heathrow_pic.c | 1 - hw/intc/openpic.c | 1 - hw/misc/macio/cuda.c | 1 - hw/misc/macio/gpio.c | 1 - hw/misc/macio/macio.c | 8 +- hw/misc/macio/pmu.c | 1 - hw/nvram/mac_nvram.c | 2 +- hw/pci-host/grackle.c | 15 +-- hw/pci-host/uninorth.c | 1 - hw/ppc/mac.h | 105 ---------------- hw/ppc/mac_newworld.c | 225 ++++++++++++++++------------------ hw/ppc/mac_oldworld.c | 111 +++++++---------- include/hw/misc/macio/macio.h | 23 +++- include/hw/nvram/mac_nvram.h | 51 ++++++++ include/hw/pci-host/grackle.h | 44 +++++++ 17 files changed, 280 insertions(+), 313 deletions(-) delete mode 100644 hw/ppc/mac.h create mode 100644 include/hw/nvram/mac_nvram.h create mode 100644 include/hw/pci-host/grackle.h