CHANGELOG: v4 -> v5:
* added a patch to rename module_load_one and friends to module_load * qdev_new: just reuse module_object_class_by_name, to avoid duplicating code * changed return value of module_load to an int: -1 error (Error **errp set). 0 module or dependencies not installed, 1 loaded 2 already loaded (or built-in) Adapted all callers. * module_load: fixed some pre-existing memory leaks, used an out: label to do the cleanup. v3 -> v4: (Richard) * module_object_class_by_name: return NULL immediately on load error. * audio_driver_lookup: same. * bdrv_find_format: same. * dmg_open: handle optional compression submodules better: f.e., if "dmg-bz2" is not present, continue but offer a warning. If "dmg-bz2" load fails with error, error out and return. * module_load_dso: add newline to error_append_hint. v2 -> v3: * take the file existence check outside of module_load_file, rename module_load_file to module_load_dso, will be called only on an existing file. This will simplify the return value. (Richard) * move exported function documentation into header files (Richard) v1 -> v2: * do not treat the display help text any differently and do report module load _errors_. If the module does not exist (ENOENT, ENOTDIR), no error will be produced. DESCRIPTION: while investigating a permission issue in accel, where accel-tcg-x86_64.so was not accessible, I noticed that no errors were produced regarding the module load failure. This series attempts to improve module_load_one and module_load_qom_one to handle the error cases better and produce some errors. Patch 1 is already reviewed and is about removing an unused existing argument "mayfail" from the call stack. Patch 2 is the real meat, and that one I would say is RFC. Will follow up with comments on the specific questions I have. Patch 3 finally adds a simple check in accel/, aborting if a module is not found, but relying on the existing error report from module_load_qom_one. Claudio Fontana (4): module: removed unused function argument "mayfail" module: rename module_load_one to module_load module: add Error arguments to module_load and module_load_qom accel: abort if we fail to load the accelerator plugin accel/accel-softmmu.c | 8 +- audio/audio.c | 16 ++-- block.c | 21 ++++- block/dmg.c | 19 +++- hw/core/qdev.c | 5 +- include/qemu/module.h | 37 +++++++- qom/object.c | 18 +++- softmmu/qtest.c | 8 +- ui/console.c | 18 +++- util/module.c | 213 +++++++++++++++++++++++------------------- 10 files changed, 237 insertions(+), 126 deletions(-) -- 2.26.2