From: Marc-André Lureau <marcandre.lur...@redhat.com> This should be functionally equivalent, but slightly easier to read, with simplified paths and checks at the end of the function.
The following patch is a major rewrite to get rid of the assert(). Signed-off-by: Marc-André Lureau <marcandre.lur...@redhat.com> --- dump/dump.c | 30 ++++++++++++------------------ 1 file changed, 12 insertions(+), 18 deletions(-) diff --git a/dump/dump.c b/dump/dump.c index 4d9658ffa2..18f06cffe2 100644 --- a/dump/dump.c +++ b/dump/dump.c @@ -1107,37 +1107,31 @@ static bool get_next_page(GuestPhysBlock **blockptr, uint64_t *pfnptr, uint8_t *buf; /* block == NULL means the start of the iteration */ - if (!block) { - block = QTAILQ_FIRST(&s->guest_phys_blocks.head); - *blockptr = block; - assert((block->target_start & ~target_page_mask) == 0); - assert((block->target_end & ~target_page_mask) == 0); - *pfnptr = dump_paddr_to_pfn(s, block->target_start); - if (bufptr) { - *bufptr = block->host_addr; - } - return true; + if (block == NULL) { + *blockptr = block = QTAILQ_FIRST(&s->guest_phys_blocks.head); + addr = block->target_start; + } else { + addr = dump_pfn_to_paddr(s, *pfnptr + 1); } - - *pfnptr = *pfnptr + 1; - addr = dump_pfn_to_paddr(s, *pfnptr); + assert(block != NULL); if ((addr >= block->target_start) && (addr + s->dump_info.page_size <= block->target_end)) { buf = block->host_addr + (addr - block->target_start); } else { /* the next page is in the next block */ - block = QTAILQ_NEXT(block, next); - *blockptr = block; + *blockptr = block = QTAILQ_NEXT(block, next); if (!block) { return false; } - assert((block->target_start & ~target_page_mask) == 0); - assert((block->target_end & ~target_page_mask) == 0); - *pfnptr = dump_paddr_to_pfn(s, block->target_start); + addr = block->target_start; buf = block->host_addr; } + /* those checks are going away next */ + assert((block->target_start & ~target_page_mask) == 0); + assert((block->target_end & ~target_page_mask) == 0); + *pfnptr = dump_paddr_to_pfn(s, addr); if (bufptr) { *bufptr = buf; } -- 2.37.2