On 2022/6/15 上午12:15, Richard Henderson wrote:
+static void *get_ctx(struct target_sctx_info *info) +{ + return (void *)((char *)info + sizeof(struct target_sctx_info)); +}Return type should be struct target_sctx_info *.
I wonder that if we return target_fpu_context * and rename get_ctx to get_fpu_context() would be better.
So we need't cast like this: struct target_fpu_context *fpu_ctx = (struct target_fpu_context *) get_ctx(info); Thanks. Song Gao